After changing back to No Password, cannot log in anymore

Problems with the Windows version of XAMPP, questions, comments, and anything related.

After changing back to No Password, cannot log in anymore

Postby FrankC » 18. April 2013 15:03

Hi,

I set an SQL password yesterday evening, but today got tired of it because every time I wanted to use phpMyAdmin I had to enter it. And I realized that nobody else uses this computer. So I set it back to No Password. But now I cannot get in anymore, neither via phpMyAdmin nor via the php/mysqli_query way... This is the error that I'm getting when trying via phpMyAdmin:

Code: Select all
phpMyAdmin - Error
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.


I have already set the password value in config.inc.php back to ' ', checked whether the AllowNoPassword setting is still set to 'true', and deleted all localhost cookies, but no cure. What else should I do or what should I do differently?

Update Apr. 18:
The strange error report appeared to be due to cached stuff in the browser. I had to clear both the localhost cookies and the browser cache. I then got the normal error report back, "Cannot connect to MySQL", directly above the login form on localhost/phpMyAdmin. I then re-entered a password on http://localhost/security/ (on which page there is a link to: http://localhost/security/xamppsecurity.php, where it is actually done). Next, I re-started MySQL as instructed, re-entered the password on config.inc.php, re-started Apache as well just to be sure, and could get in again.

I will still try to get back to No Password, but for the time being I'm in again, which for the moment is more important.
FrankC
 
Posts: 21
Joined: 23. October 2011 03:57
Location: The city of cities
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 64-b

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 84 guests