Error 204

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error 204

Postby sohohesol » 13. April 2013 01:43

Good evening,

I am having a strange issue, I have my site in a folder under htdocs, the index.php main page displays correctly, when I try to click on links to other pages, I am receiving an error 204.

I have investigated to the point that the error is somehow related to the fact that the charset on the page cannot be located (utf-8) yet when I look at the code, it is there.

There is no information in the error logs, just the error 204 on the web apge when I try to open a link on the page.

I've been battling with this for a week now... am at my wits end!

Not quite sure what else I should post...

If someone could please help, I'd be very appreciative.

thank you,

Paul.

XAMPP version 1.8.1, Win 7 Ultimate SP1, 32 bit.
sohohesol
 
Posts: 3
Joined: 13. April 2013 01:28
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 32 bit

Re: Error 204

Postby Altrea » 13. April 2013 02:03

Hi Paul,

sohohesol wrote:I am having a strange issue, I have my site in a folder under htdocs, the index.php main page displays correctly, when I try to click on links to other pages, I am receiving an error 204.

HTTP Status Code 204 (No content) is not an error message, it is a success message (as all 2XX Codes).

sohohesol wrote:Not quite sure what else I should post...

If someone could please help, I'd be very appreciative.

Without knowing the exact contents of the requested page, nobody can say anything about that.
Can you request that by typing the URL to that page in your browsers address bar?

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6476
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Error 204

Postby sohohesol » 13. April 2013 02:21

Hi there,

thank you for trying to help with this issue, I include the link to the site so you can see what the issue is:

http://sohohesol.dyndns.org:8008/

I also placed a copy of the php file (renamed to .txt) at the following link:

http://sohohesol.dyndns.org:8008/!text/

what else might I provide to aide you?

Paul.
sohohesol
 
Posts: 3
Joined: 13. April 2013 01:28
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 32 bit

Re: Error 204

Postby Altrea » 13. April 2013 02:27

I just get two 403 access denied status messages if i try to access your provided urls :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6476
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Error 204

Postby sohohesol » 13. April 2013 02:32

Sorry about that, I had the .htaccess file restricted.. have changed it now, you should be able to get access.

thanks, Paul.
sohohesol
 
Posts: 3
Joined: 13. April 2013 01:28
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 32 bit

Re: Error 204

Postby Altrea » 13. April 2013 03:21

Okay, i can't provide much information because important parts (included files, functions, assets) are not present for me.
I assume that the problem is somewhere in the first lines if that file before your HTML DOCTYPE, otherwise you would get any type of output.
You can chaeck that by uncommenting that part or parts of that parts to come closer to that issue.

The charset error i get in my Firebug too is just an aftereffect of the real issue, because that "Error 204" message page doesn't provide any charset information and your responding webserver doesn't too (or gets somewhere lost at dyndns).

Would be interesting to know if you have that Error 204 issue only with dyndns or from localhost too.

Thats all i can say from far away here without a full test case.
Hope that helps you anyway :)

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6476
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests