mod_perl deactivated

Problems with the Windows version of XAMPP, questions, comments, and anything related.

mod_perl deactivated

Postby KasperB » 20. March 2013 10:53

hi, i have xampp 1.8.1 and i need it for perl, but it perl does not work. Does anybody know how i can get this working?
thanks in advance
KasperB
 
Posts: 1
Joined: 20. March 2013 10:44
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: mod_perl deactivated

Postby JonB » 21. March 2013 10:52

For mod_perl - the problem is not with XAMPP, the issue is that mod_perl has not been updated completely for Apache 2.4. You can Google for solutions, but it will require recompiling. read this carefully:

mod_perl is the marriage of Apache and Perl
mod_perl brings together two of the most powerful and mature technologies available to the web professional today.

mp2 is mod_perl for the 2.x.x branch of the Apache HTTPD Server.
mp1 is mod_perl for the 1.3 branch of the Apache HTTPD Server.

mp2 is fully compatible with httpd 2.0.x , and supports most of the 2.2.x feature set.

mod_perl's future plans are to keep on supporting httpd as it evolves - that has always been the goal, and will always be so.

Simply install mod_perl and you have the full power of the Apache Web Server at your fingertips:


http://perl.apache.org/start/index.html

The good news is you probably don't need mod_perl in most cases. You can use the shebang line method of invoking Perl:

add this line as the first line of your script (changing the XAMPP path if needed)
#!"C:\xampp-beta-181-2\perl\bin\perl.exe"

If you are building something that absolutely requires mod_perl use XAMPP version 1.7.7 or lower.

Good Luck
:)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: albert_tsai and 69 guests