Localhost wird plötzlich nicht mehr geladen

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Localhost wird plötzlich nicht mehr geladen

Postby maffy » 14. March 2013 11:22

Ich habe plötzlich das Problem, das meine Webseiten auf dem localhost nicht mehr geladen werden.
Es erscheint nur bitte warten und es passiert dann nichts mehr.

Image
maffy
 
Posts: 8
Joined: 04. October 2009 09:45
Location: Bad Bocklet - Steinach

Re: Localhost wird plötzlich nicht mehr geladen

Postby Altrea » 15. March 2013 05:53

Was steht in deinen Apache log Dateien?
Und was in deinem Windows Ereignis log?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6839
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Localhost wird plötzlich nicht mehr geladen

Postby maffy » 15. March 2013 08:36

Wie kann ich die Log Dateien Abrufen?

Ich habe nun das Xampp neu installiert aber ohne Erfolg.

Mysql wird nun grün unterlegt und gestartet, der Apache wird aber nicht nicht aktiviert.
maffy
 
Posts: 8
Joined: 04. October 2009 09:45
Location: Bad Bocklet - Steinach

Re: Localhost wird plötzlich nicht mehr geladen

Postby Altrea » 15. March 2013 11:05

maffy wrote:Wie kann ich die Log Dateien Abrufen?

\xampp\apache\logs\error.log
\xampp\apache\logs\access.log

Das Windows Ereignislog findest du in der Windows Computerverwaltung
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6839
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Localhost wird plötzlich nicht mehr geladen

Postby maffy » 15. March 2013 11:43

Apache log file
Code: Select all
[Thu Mar 14 15:37:45 2013] [notice] Digest: generating secret for digest authentication ...
[Thu Mar 14 15:37:45 2013] [notice] Digest: done
[Thu Mar 14 15:37:46 2013] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Thu Mar 14 15:37:46 2013] [notice] Server built: Sep 10 2011 11:34:11
[Thu Mar 14 15:37:46 2013] [notice] Parent: Created child process 4992
Apache server shutdown initiated...
Digest: generating secret for digest authentication ...
[Thu Mar 14 15:37:47 2013] [notice] Digest: done
[Thu Mar 14 15:37:47 2013] [notice] Child 4992: Child process is running
[Thu Mar 14 15:37:47 2013] [notice] Child 4992: Acquired the start mutex.
[Thu Mar 14 15:37:47 2013] [notice] Child 4992: Starting 150 worker threads.
[Thu Mar 14 15:37:47 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Mar 14 15:37:47 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Mar 14 15:37:47 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Mar 14 15:37:47 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Thu Mar 14 15:38:06 2013] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Mar 14 15:38:06 2013] [notice] Child 4992: Exit event signaled. Child process is ending.
[Thu Mar 14 15:38:07 2013] [notice] Child 4992: Released the start mutex
[Thu Mar 14 15:38:08 2013] [notice] Child 4992: All worker threads have exited.
[Thu Mar 14 15:38:08 2013] [notice] Child 4992: Child process is exiting
[Thu Mar 14 15:38:08 2013] [notice] Parent: Child process exited successfully.
[Fri Mar 15 08:24:59 2013] [notice] Digest: generating secret for digest authentication ...
[Fri Mar 15 08:24:59 2013] [notice] Digest: done
[Fri Mar 15 08:25:01 2013] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Mar 15 08:25:01 2013] [notice] Server built: Sep 10 2011 11:34:11
[Fri Mar 15 08:25:01 2013] [notice] Parent: Created child process 624
[Fri Mar 15 08:25:03 2013] [notice] Digest: generating secret for digest authentication ...
[Fri Mar 15 08:25:03 2013] [notice] Digest: done
[Fri Mar 15 08:25:04 2013] [notice] Child 624: Child process is running
[Fri Mar 15 08:25:04 2013] [notice] Child 624: Acquired the start mutex.
[Fri Mar 15 08:25:04 2013] [notice] Child 624: Starting 150 worker threads.
[Fri Mar 15 08:25:04 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Fri Mar 15 08:25:04 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Fri Mar 15 08:25:04 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Fri Mar 15 08:25:04 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
Terminating on signal SIGTERM(15)
[Fri Mar 15 11:24:39 2013] [warn] pid file F:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri Mar 15 11:24:39 2013] [notice] Digest: generating secret for digest authentication ...
[Fri Mar 15 11:24:39 2013] [notice] Digest: done
[Fri Mar 15 11:24:40 2013] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Mar 15 11:24:40 2013] [notice] Server built: Sep 10 2011 11:34:11
[Fri Mar 15 11:24:43 2013] [notice] Parent: Created child process 2104
[Fri Mar 15 11:24:44 2013] [notice] Digest: generating secret for digest authentication ...
[Fri Mar 15 11:24:44 2013] [notice] Digest: done
[Fri Mar 15 11:24:44 2013] [notice] Child 2104: Child process is running
[Fri Mar 15 11:24:44 2013] [notice] Child 2104: Acquired the start mutex.
[Fri Mar 15 11:24:44 2013] [notice] Child 2104: Starting 150 worker threads.
[Fri Mar 15 11:24:44 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Fri Mar 15 11:24:44 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Fri Mar 15 11:24:44 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Fri Mar 15 11:24:44 2013] [error] (OS 10038)Ein Vorgang bezog sich auf ein Objekt, das kein Socket ist.  : winnt_accept: getsockname error on listening socket, is IPv6 available?

maffy
 
Posts: 8
Joined: 04. October 2009 09:45
Location: Bad Bocklet - Steinach

Re: Localhost wird plötzlich nicht mehr geladen

Postby Nobbie » 15. March 2013 11:56

Hast Du irgendeine gehackte Software o.ä. installiert, oder eine Firewall, oder irgendetwas in der Art? Wenn ich das richtig sehe, hast Du WindowsXP im EInsatz (müssen wir leider raten)?! Was ist "F:"? Was verbirgt sich dahinter?

Hast Du Änderungen in der Windows hosts Datei ggf. selbst durchgeführt?

Hast Du Skype installiert?

Dein Winsocket ist irgenwie verbogen, öffne mal ein Terminal (DOSBox bzw. "cmd.exe", am besten auch gleich "Als Administrator starten") und gib auf der Kommandozeile diesen Befehl ein:

Code: Select all
netsh winsock reset


Versuche danach Apache neu zu starten, Du kannst auch ggf. booten und dann nochmal versuchen.
Nobbie
 
Posts: 7034
Joined: 09. March 2008 13:04

Re: Localhost wird plötzlich nicht mehr geladen

Postby maffy » 15. March 2013 12:07

letzte Woche hat noch alles ohne Problem funktioniert.
Bei der Installation des installer Paket für Xampp kahm eine Meldung wegen der Benutzerkontrolleinstellung

Ich verwende nur Freeware und habe eigendlich nur die jetzt kostenlosen Illustrator cs2 und InDesgin cs2 Programme von Adobe installiert.

Ich habe kaspersky 2013 installiert hat es damit zu tun?
maffy
 
Posts: 8
Joined: 04. October 2009 09:45
Location: Bad Bocklet - Steinach

Re: Localhost wird plötzlich nicht mehr geladen

Postby Nobbie » 15. March 2013 12:08

maffy wrote:Ich habe kaspersky 2013 installiert hat es damit zu tun?


Sehr gut möglich. Aber Du solltest in jedem Fall auch noch die obige Lösung ausprobieren ("netsh winsock reset" als Administrator in einer DOS Box).
Nobbie
 
Posts: 7034
Joined: 09. March 2008 13:04

Re: Localhost wird plötzlich nicht mehr geladen

Postby maffy » 15. March 2013 12:52

Ich habe jetzt mal noch folgendes

Im ControllPanel 3.0.2 steht:

Mögliche Problem:
Port 80 in Benutzung von httpd.exe
Port 443 in Benutzung von httpd.exe
port 3306 in Benutzung von mysqld.exe

Image
maffy
 
Posts: 8
Joined: 04. October 2009 09:45
Location: Bad Bocklet - Steinach

Re: Localhost wird plötzlich nicht mehr geladen

Postby Nobbie » 15. March 2013 14:45

Hast Du den Lösungsvorschlag endlich mal ausgeführt?
Nobbie
 
Posts: 7034
Joined: 09. March 2008 13:04

Re: Localhost wird plötzlich nicht mehr geladen

Postby maffy » 15. March 2013 17:02

Ich habe nun den obigen Vorschlag ausgeführt und den Computer neu gestartet.
Nun funktioniert wieder alles. Danke.

Sollte man Skyp besser nicht installieren wenn das Programm alles durcheinander haut?

Mfg maffy
maffy
 
Posts: 8
Joined: 04. October 2009 09:45
Location: Bad Bocklet - Steinach

Re: Localhost wird plötzlich nicht mehr geladen

Postby maffy » 17. March 2013 16:42

Nobbie wrote:
maffy wrote:Sollte man Skyp besser nicht installieren wenn das Programm alles durcheinander haut?


Nein, man muss es nur richtig konfigurieren. Von Skype hast Du bisher allerdings nichts gesagt, wie kommst Du jetzt darauf?


Ich hatte skyp installiert aber wieder runter geschmissen.
maffy
 
Posts: 8
Joined: 04. October 2009 09:45
Location: Bad Bocklet - Steinach


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 5 guests