PHP SafeMode On obwohl er off ist?!

Alles, was PHP betrifft, kann hier besprochen werden.

PHP SafeMode On obwohl er off ist?!

Postby acx » 14. March 2013 16:37

Ich habe folgendes Problem mit meinem Windows vServer:

ich will eine Software installieren, die aber die Fehlermeldung anzeigt "PHP Safemode Enabled".
In der Plesk Oberfläche ist Safemode auf Off gestellt.
In der PHP Info steht auch das der Safemode off ist, genauso wie in der PHP.ini
Ein Script welches den Safemode abfragt sagt das er ON ist.

Sowohl owncloud als auch Joomla zeigen an, dass er auf On steht.

Kennt jemand eine Lösung?
acx
 
Posts: 1
Joined: 14. March 2013 16:36
XAMPP Version: 5.6.3
Operating System: Windows

Re: PHP SafeMode On obwohl er off ist?!

Postby Altrea » 14. March 2013 17:19

Wenn phpinfo sagt die Funktion sei abgeschaltet, die Anwendung aber etwas anderes behauptet, dann wirst du entweder die Einstellung überschreiben (htaccess, Apache Konfiguration, lokale php.ini, oder im Code der Anwendung selbst), oder die Prüfung der Einstellung ist fehlerhaft.
Prüfer in welchem Kontext die Einstellung gesetzt und abgefragt wird (gilt sie global, nur für dieses Verzeichnis oder wann?)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6471
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to PHP

Who is online

Users browsing this forum: No registered users and 3 guests