Virtualhost problems (not localhost)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Virtualhost problems (not localhost)

Postby mccarthyp64 » 17. February 2013 05:47

Hi,
My virtualhosts keeps on flaking out on me.
I have a dyndns setup for my domain and have subdomains which I would like to use.
I need "forum.trgperth.tk", "bans.trgperth.tk", "www.trgperth.tk" and "trgperth.tk" (it has a .htaccess that redirects to www.trgperth.tk).
My vhosts.conf:
Code: Select all
NameVirtualHost *:80
<VirtualHost *:80>
    DocumentRoot "C:/xampp/htdocs"
    ServerName "trgperth.tk"
</VirtualHost>
<VirtualHost *:80>
    DocumentRoot "C:/xampp/www"
    ServerName "www.trgperth.tk"
</VirtualHost>
<VirtualHost *:80>
    DocumentRoot "C:/xampp/forum"
    ServerName "forum.trgperth.tk"
</VirtualHost>
<VirtualHost *:80>
    DocumentRoot "C:/xampp/bans"
    ServerName "bans.trgperth.tk"
</VirtualHost>

Any help would be appreciated.
mccarthyp64
 
Posts: 6
Joined: 17. February 2013 05:32
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Virtualhost problems (not localhost)

Postby JonB » 18. February 2013 17:51

Please to help us:

What is 'flaking out', exactly??

Is that a new error message? :shock:

You have to be specific for us to assist you...

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Virtualhost problems (not localhost)

Postby mccarthyp64 » 23. February 2013 06:52

Any subdomain displays the "www" subdomain (which is my wordpress now).
mccarthyp64
 
Posts: 6
Joined: 17. February 2013 05:32
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Virtualhost problems (not localhost)

Postby Nobbie » 23. February 2013 13:58

mccarthyp64 wrote:Any subdomain displays the "www" subdomain (which is my wordpress now).


Subdomains cannot "display" anything, so would you please be more precisely what is going wrong on your Server?! It is definately impossible to give any hints on that poor information.
Nobbie
 
Posts: 6577
Joined: 09. March 2008 13:04

Re: Virtualhost problems (not localhost)

Postby mccarthyp64 » 24. February 2013 02:22

Let me try again. If I go onto bans.trgperth.tk, and it comes up with the wordpress (www.trgperth.tk) site contained in C:/xampp/htdocs/. Same thing happens with forum.trgperth.tk.
mccarthyp64
 
Posts: 6
Joined: 17. February 2013 05:32
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Virtualhost problems (not localhost)

Postby mccarthyp64 » 02. March 2013 01:56

bump
mccarthyp64
 
Posts: 6
Joined: 17. February 2013 05:32
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Virtualhost problems (not localhost)

Postby Altrea » 02. March 2013 07:11

Hi mccarthyp64,

Your VHosts definitions are working correctly on my testenvironment (after adding some Apache access rules).
Do you have restarted Apache after changing any configuration files?
Can you show us your \xampp\apache\logs\error.log and \xampp\apache\logs\access.log (especially the entrys with the not working requests)?
Are your DynDNS Entrys configured properly?

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Virtualhost problems (not localhost)

Postby mccarthyp64 » 04. March 2013 13:30

access rules you say...
mccarthyp64
 
Posts: 6
Joined: 17. February 2013 05:32
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Virtualhost problems (not localhost)

Postby Altrea » 04. March 2013 16:02

mccarthyp64 wrote:access rules you say...

The access rules are not your problem. The effect of wrong / missing access rules would be that you would get a http status error 403 page and not that a different access rule will take effect.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Virtualhost problems (not localhost)

Postby mccarthyp64 » 06. March 2013 13:04

For "forum.trgperth.tk", here is the access.log snippet:
Code: Select all
xxx.xxx.xxx.xxx - - [06/Mar/2013:20:02:51 +0800] "GET / HTTP/1.1" 200 7566 "-" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.152 Safari/537.22"
xxx.xxx.xxx.xxx - - [06/Mar/2013:20:02:53 +0800] "GET /favicon.ico HTTP/1.1" 200 - "-" "Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.152 Safari/537.22"


No changes in error.log
mccarthyp64
 
Posts: 6
Joined: 17. February 2013 05:32
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Virtualhost problems (not localhost)

Postby Altrea » 06. March 2013 16:09

Sorry. I can't identify the problem.
Your vhost configuration is working on my test environment so I guess the problem has something to do with your DynDNS configuration.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Virtualhost problems (not localhost)

Postby Nobbie » 06. March 2013 17:22

I am pretty shure that vhost.conf is not included in httpd.conf
Nobbie
 
Posts: 6577
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests