Error 403 for phpmyadmin [Solved]

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Re: Error 403 for phpmyadmin

Postby LeBon » 06. July 2012 19:39

I had exactly the same problem. So I followed this thread. The "Require all granted" command was the solution. Thanks to dookan and JonB
for the contribution.
LeBon
 
Posts: 9
Joined: 29. March 2008 11:44
Location: Hamburg
XAMPP Version: 5.6.3
Operating System: Linux OpenSuse 11.4 KDE

Re: Error 403 for phpmyadmin

Postby dookan » 09. July 2012 02:52

Well, thanks for all the support JonB, I'm appreciated!
And, good luck with any future releases.
dookan
 
Posts: 9
Joined: 04. July 2012 23:41
XAMPP Version: 5.6.3
Operating System: Linux Mint 13 Cinnamon

Re: Error 403 for phpmyadmin [Solved]

Postby MrJxN » 14. July 2012 22:11

I was searching for this as I had the exact same problem. I tried the OP's solution first and it worked a charm. Thanks :)

In case this makes it more clear (especially for beginners), the steps I took (After backing up the original httpd-xampp.conf) :

In a terminal:
Code: Select all
sudo gedit /opt/lampp/etc/extra/httpd-xampp.conf


In gedit, Find:
<Directory "/opt/lampp/phpmyadmin">

And add the line to the <Directory>:
Require all granted

After this, the section reads:
Code: Select all
<Directory "/opt/lampp/phpmyadmin">
    AllowOverride AuthConfig Limit
    Order allow,deny
    Allow from all
    Require all granted
</Directory>


Save the file, close gedit, then back at the terminal:
Code: Select all
/opt/lampp/lampp restart


http://localhost/phpmyadmin/ now correctly loads.

MrJxN

[edit] My system: Ubuntu 12.04 hosted on Oracle VirtualBox in WIndows 7.
MrJxN
 
Posts: 3
Joined: 14. July 2012 21:41
XAMPP Version: 5.6.3
Operating System: Ubuntu12 thru VirtualBox on W7

Re: Error 403 for phpmyadmin [Solved]

Postby MaxiSantos » 15. July 2012 02:11

I also found another solution.

sudo /opt/lampp/lampp security

I wasn't able to enter localhost/phpmyadmin neither localhost/phpmyadmin/index.php

At the moment, everything works fine.
MaxiSantos
 
Posts: 1
Joined: 15. July 2012 02:05
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04

Re: Error 403 for phpmyadmin [Solved]

Postby praise » 01. September 2012 10:25

:D Thank you very much for sharing
praise
 
Posts: 1
Joined: 01. September 2012 10:23
XAMPP Version: 5.6.3
Operating System: linux ubuntu 12.4

Re: Error 403 for phpmyadmin [Solved]

Postby iBaf » 13. February 2013 22:33

Dont use this code, its allow access from all..
Just update your httpd-xampp.conf.
Replace the End with:
Code: Select all
#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
   <RequireAny>
    Require ip ::1 127.0.0.0/8 \
      fc00::/7 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 \
      fe80::/10 169.254.0.0/16
   </RequireAny>
   ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>

Than restart your lampp with:
Code: Select all
sudo /opt/lampp/lampp restart
iBaf
 
Posts: 4
Joined: 13. February 2013 21:27
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04 LTS AND Windows 7

Re: Error 403 for phpmyadmin [Solved]

Postby JonB » 08. March 2013 16:28

I think iBaf is referring to these directives written by MrJxN - When he says
Dont use this code, its allow access from all..


Code: Select all
<Directory "/opt/lampp/phpmyadmin">
    AllowOverride AuthConfig Limit
    Order allow,deny
    Allow from all
    Require all granted
</Directory>


Subject to review -

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Error 403 for phpmyadmin [Solved]

Postby stevieontario » 10. January 2014 17:16

I have tried all of the solutions given here, and still cannot access phpMyAdmin. Still get the Access Forbidden and 403 error.

Maybe it's the combination of my linux version (actually it's ubuntu 11.04, natty, not 11.10 as I entered when I was composing this post) and xampp 1.8.1?
stevieontario
 
Posts: 1
Joined: 10. January 2014 17:08
XAMPP Version: 1.8.2-4
Operating System: linux ubuntu 11.10

Re: Error 403 for phpmyadmin [Solved]

Postby kimmy » 10. March 2014 16:55

this works
Code: Select all
<Directory "/opt/lampp/phpmyadmin">
    AllowOverride AuthConfig Limit
    Require all granted
</Directory>


see

Image
screenshot captor
kimmy
 
Posts: 15
Joined: 21. September 2012 17:50
XAMPP Version: 5.6.3
Operating System: unity 64bit

Previous

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests