Can't connect to localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't connect to localhost

Postby OverRide » 13. February 2013 17:31

Hello all, I'm trying to access phpmyadmin on xampp but I am unable to access the localhost.
I have changed the port from 80, to 8080, but I still get the main window thingy saying "error system using port 80" (check below for actual message)
Both apache and MySQL are green and are running, I should mention that the port thing for apache is saying port 8080 in the port window thing with 413. I am running windows 8 (My friend is also running windows 8 and its running fine before someone mentions its windows 8 (heard it many times already)) if there is anything else you need just say and i'll post, thanks in advance.

Below is the error.log
[Wed Feb 13 16:19:39.177535 2013] [ssl:warn] [pid 19964:tid 332] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Feb 13 16:19:40.187562 2013] [mpm_winnt:notice] [pid 19964:tid 332] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed Feb 13 16:19:40.187562 2013] [mpm_winnt:notice] [pid 19964:tid 332] AH00456: Server built: Aug 18 2012 12:41:37
[Wed Feb 13 16:19:40.187562 2013] [core:notice] [pid 19964:tid 332] AH00094: Command line: 'c:\\users\\matthew\\desktop\\xampp\\apache\\bin\\httpd.exe -d C:/Users/Matthew/Desktop/xampp/apache'
[Wed Feb 13 16:19:40.187562 2013] [mpm_winnt:notice] [pid 19964:tid 332] AH00418: Parent: Created child process 16404
[Wed Feb 13 16:19:41.528242 2013] [ssl:warn] [pid 16404:tid 328] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Feb 13 16:19:41.578245 2013] [mpm_winnt:notice] [pid 16404:tid 328] AH00354: Child: Starting 150 worker threads.


Below is the main window thingy errors
16:28:00 [Apache] Problem detected!
16:28:00 [Apache] Port 80 in use by "system"!
16:28:00 [Apache] Apache WILL NOT start without the configured ports free!
16:28:00 [Apache] You need to uninstall/disable/reconfigure the blocking application
16:28:00 [Apache] or reconfigure Apache to listen on a different port
OverRide
 
Posts: 2
Joined: 13. February 2013 17:24
XAMPP Version: 5.6.3
Operating System: Windows 8/ Windows 7

Re: Can't connect to localhost

Postby Altrea » 13. February 2013 17:53

Hi OverRide,

OverRide wrote:
[Wed Feb 13 16:19:40.187562 2013] [core:notice] [pid 19964:tid 332] AH00094: Command line: 'c:\\users\\matthew\\desktop\\xampp\\apache\\bin\\httpd.exe -d C:/Users/Matthew/Desktop/xampp/apache'

Please don't install XAMPP in a user related folder. The recommend installation path is C:\xampp

OverRide wrote:but I still get the main window thingy saying "error system using port 80" (check below for actual message)

That's normal. The XAMPP control panel don't parses any configuration files, so it don't realizes that you have changed any ports and still observes the old ones.
You can configure the observed ports in the configuration of the control panel itself.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Can't connect to localhost

Postby OverRide » 13. February 2013 17:59

Altrea wrote:Hi OverRide,

OverRide wrote:
[Wed Feb 13 16:19:40.187562 2013] [core:notice] [pid 19964:tid 332] AH00094: Command line: 'c:\\users\\matthew\\desktop\\xampp\\apache\\bin\\httpd.exe -d C:/Users/Matthew/Desktop/xampp/apache'

Please don't install XAMPP in a user related folder. The recommend installation path is C:\xampp

OverRide wrote:but I still get the main window thingy saying "error system using port 80" (check below for actual message)

That's normal. The XAMPP control panel don't parses any configuration files, so it don't realizes that you have changed any ports and still observes the old ones.
You can configure the observed ports in the configuration of the control panel itself.

best wishes,
Altrea

Ah thanks changing it to C: worked, now I just feel like an idiot, thanks :) Solved
OverRide
 
Posts: 2
Joined: 13. February 2013 17:24
XAMPP Version: 5.6.3
Operating System: Windows 8/ Windows 7

Re: Can't connect to localhost

Postby Altrea » 14. February 2013 05:56

You're welcome. I'm glad your issue could be solved :D
Have fun with XAMPP and all that fancy stuff 8)
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests