Apache server won't start [solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Apache server won't start

Postby Altrea » 07. February 2013 14:59

kirwood wrote:I don't think XAMPP can use port 80. Should not Virtualhost be *:39393?

You are correct, my mistake :D

kirwood wrote:Can I change Documentroot to D:/kim? This is the drive all the websites are stored on.

You can, but then you have to define access rules for the directory too, because it is outside of the by default configurated base directory \xampp\htdocs\

so, it can look something like this:

Code: Select all
<VirtualHost *:39393>
    DocumentRoot "C:/xampp/htdocs"
    ServerName localhost
</VirtualHost>

<VirtualHost *:39393>
    DocumentRoot "D:/kim"
    ServerName kim
    <Directory "D:/kim">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Require all granted
    </Directory>
</VirtualHost>

<VirtualHost *:39393>
    DocumentRoot "D:/tc"
    ServerName tc
    <Directory "D:/tc">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Require all granted
    </Directory>
</VirtualHost>


so the urls would be
http://localhost:39393/ for the XAMPP Administration page
http://kim:39393/ for the kim vhost
http://tc:39393/ for the tc vhost

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6754
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache server won't start

Postby kirwood » 07. February 2013 15:31

OK, I used the code you suggested and
I got the XAMPP admin page
but
I got this for http://kim:39393/
Server error!
The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.

Error 500
kim
Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache server won't start

Postby Altrea » 07. February 2013 15:42

In my test environment this configuration is working correctly so i guess it is a problem with your application.
What is the contents of your Apache error.log file?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6754
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache server won't start

Postby kirwood » 07. February 2013 15:44

[Thu Feb 07 14:29:50.261589 2013] [core:alert] [pid 4920:tid 1732] [client 127.0.0.1:57515] D:/kim/.htaccess: </html> without matching <html> section
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache server won't start

Postby Altrea » 07. February 2013 15:52

so what is the contents of this .htaccess file?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6754
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache server won't start

Postby kirwood » 07. February 2013 16:56

My mistake. I missed out the opening tag.
I think all is now working and we can close this case.
Thank you again for all your help.
David
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests