eAccelerator on the XAMPP 1.8.1 (OS Ubuntu 12.04.1)

Problems with the Linux version of XAMPP, questions, comments, and anything related.

eAccelerator on the XAMPP 1.8.1 (OS Ubuntu 12.04.1)

Postby thewhitenightwolf » 31. January 2013 20:01

Hi!
I have installed XAMPP 1.8.1. After that I activated eAccelerator. Browser tries to download a file located in the root directory of my website, for example index.php. I just uncommented the settings eAccelerator in the file php.ini and nothing else more.
This is access_log before activated:
Code: Select all
127.0.0.1 - - [31/Jan/2013:19:59:12 +0400] "GET / HTTP/1.1" 200 174

This's after:
Code: Select all
127.0.0.1 - - [31/Jan/2013:20:00:23 +0400] "GET / HTTP/1.1" 200 191

And http-headers:
http://site1.ru/

GET / HTTP/1.1
Host: site1.ru
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: ru-RU,ru;q=0.8,en-US;q=0.5,en;q=0.3
Accept-Encoding: gzip, deflate
Connection: keep-alive
Cache-Control: max-age=0

HTTP/1.1 200 OK
Date: Thu, 31 Jan 2013 18:45:45 GMT
Server: Apache/2.4.3 (Unix) OpenSSL/1.0.1c
Last-Modified: Thu, 31 Jan 2013 16:38:33 GMT
Etag: "c4-4d49841f4de44"
Accept-Ranges: bytes
Content-Length: 196
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: application/x-httpd-php
----------------------------------------------------------

What I'm doing wrong?
thewhitenightwolf
 
Posts: 4
Joined: 31. January 2013 19:14
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.1LTS

Re: eAccelerator on the XAMPP 1.8.1 (OS Ubuntu 12.04.1)

Postby JonB » 01. February 2013 16:53

Do the sites work correctly with eAccelerator disabled? :shock:

Good Luck
:)


ysfc
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: eAccelerator on the XAMPP 1.8.1 (OS Ubuntu 12.04.1)

Postby thewhitenightwolf » 01. February 2013 18:43

Sorry for my English language:) Probably I don't understand you. Any way... Yes, the site correctly worked with disabled eAccelerator. Now, I commented strings php.ini, where placed settings eAccelerator. Thank you for you're feedback!
thewhitenightwolf
 
Posts: 4
Joined: 31. January 2013 19:14
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.1LTS

Re: eAccelerator on the XAMPP 1.8.1 (OS Ubuntu 12.04.1)

Postby JonB » 06. February 2013 16:53

What is in the Apache error log when you try to run with eAccelerator enabled?? It may tell us what the exact error is.

Thanks and Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: eAccelerator on the XAMPP 1.8.1 (OS Ubuntu 12.04.1)

Postby thewhitenightwolf » 06. February 2013 18:49

Ok! Let's see!
This is what Apache write in the error_log file BEFORE enabled eAccelerator:
Code: Select all
[Wed Feb 06 19:20:39.803820 2013] [:error] [pid 10533] [client 127.0.0.1:56804] PHP Warning:  move_uploaded_file(): Unable to move '/tmp/phpqC0BG0' to '/opt/lampp/htdocs/site1.ru' in /opt/lampp/htdocs/site1.ru/upload.php on line 13, referer: http://site1.ru/upload.php

(Look on a date and time)
This AFTER:
Code: Select all
[Wed Feb 06 19:20:39.803820 2013] [:error] [pid 10533] [client 127.0.0.1:56804] PHP Warning:  move_uploaded_file(): Unable to move '/tmp/phpqC0BG0' to '/opt/lampp/htdocs/site1.ru' in /opt/lampp/htdocs/site1.ru/upload.php on line 13, referer: http://site1.ru/upload.php

So, can you see, there is no change.
thewhitenightwolf
 
Posts: 4
Joined: 31. January 2013 19:14
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.1LTS

Re: eAccelerator on the XAMPP 1.8.1 (OS Ubuntu 12.04.1)

Postby JonB » 06. February 2013 22:41

Well you do have a problem but 'that problem' is not what is keeping Apache from running eAccelerator. That's a php 'Warning' not an error.

and that is not the whole error log from an attempt to start Apache with eAccelerator running.

I have several ideas of what might be wrong (one is closely related to your other issue)


Good Luck whatever you chose to do.
:)



ysf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: eAccelerator on the XAMPP 1.8.1 (OS Ubuntu 12.04.1)

Postby thewhitenightwolf » 07. February 2013 10:02

Yes, of course, that is not the whole error log. I can show the whole log, if you wish :), but file very big!
Ok, I can run server on the other virtual host, where in the error_log, on this moment, nothing is writed.
Let's do it).. I just a created index.php(is one file in the root directory my site) with content:
Code: Select all
<?php echo "<h1>hello,world!</h1>";?>

Error_log without eAccelerator:
Code: Select all
empty

HTTP Headers:
http://site4.ru/

GET / HTTP/1.1
Host: site4.ru
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: ru-RU,ru;q=0.8,en-US;q=0.5,en;q=0.3
Accept-Encoding: gzip, deflate
Connection: keep-alive
Cache-Control: max-age=0

HTTP/1.1 200 OK
Date: Thu, 07 Feb 2013 08:39:57 GMT
Server: Apache/2.4.3 (Unix) OpenSSL/1.0.1c PHP/5.4.7
X-Powered-By: PHP/5.4.7
Content-Length: 20
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: text/html
----------------------------------------------------------

Look the string Content-Type: text/html
FF show me header: "Hello, world!"
Next step: Error_log with eAccelerator running:
Code: Select all
empty too...

HTTP Headers:
http://site4.ru/

GET / HTTP/1.1
Host: site4.ru
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:18.0) Gecko/20100101 Firefox/18.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: ru-RU,ru;q=0.8,en-US;q=0.5,en;q=0.3
Accept-Encoding: gzip, deflate
Connection: keep-alive

HTTP/1.1 200 OK
Date: Thu, 07 Feb 2013 08:45:01 GMT
Server: Apache/2.4.3 (Unix) OpenSSL/1.0.1c
Last-Modified: Thu, 07 Feb 2013 08:33:45 GMT
Etag: "27-4d51e4d1037fb"
Accept-Ranges: bytes
Content-Length: 39
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: application/x-httpd-php

----------------------------------------------------------
Now look the string Content-Type: application/x-httpd-php.
Now FF tries to download the script!
And access_log (just in case):
Code: Select all
   127.0.0.1 - - [07/Feb/2013:12:33:53 +0400] "GET / HTTP/1.1" 200 20
   127.0.0.1 - - [07/Feb/2013:12:33:53 +0400] "GET /favicon.ico HTTP/1.1" 404 994
   127.0.0.1 - - [07/Feb/2013:12:33:53 +0400] "GET /favicon.ico HTTP/1.1" 404 994
   127.0.0.1 - - [07/Feb/2013:12:39:57 +0400] "GET / HTTP/1.1" 200 20
   127.0.0.1 - - [07/Feb/2013:12:44:47 +0400] "GET / HTTP/1.1" 200 39
   127.0.0.1 - - [07/Feb/2013:12:45:01 +0400] "GET / HTTP/1.1" 200 39

Сan you share your thoughts and ideas what might be wrong? :wink:
thewhitenightwolf
 
Posts: 4
Joined: 31. January 2013 19:14
XAMPP Version: 5.6.3
Operating System: Ubuntu 12.04.1LTS


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 9 guests