connecting to xampp server

Problems with the Windows version of XAMPP, questions, comments, and anything related.

connecting to xampp server

Postby droidus » 05. February 2013 20:08

Hello everyone,

I am trying to do local testing with Dreamweaver. I have Apache/MySQL running. In DW, I have the Local Site folder set to C:\xampp\php_site\. The server folder is C:\xampp\php_site\. The web URL is http://localhost/php_site/. I was following this tutorial: http://www.adobe.com/devnet/dreamweaver/articles/setup_php.html. When I click on "Live View", this error message is sent back:

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404

localhost
Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7

Thanks.
droidus
 
Posts: 7
Joined: 05. February 2013 04:43
XAMPP Version: 5.6.3
Operating System: win7

Re: connecting to xampp server

Postby Altrea » 05. February 2013 21:48

Hi droidus,

droidus wrote:In DW, I have the Local Site folder set to C:\xampp\php_site\.

Thats not a requestable directory. Your local site folder have to be inside C:\xampp\htdocs\, so for example C:\xampp\htdocs\php_site\

best wishes,
Altrea

P.S.: For further reading
http://www.apachefriends.org/en/xampp-windows.html
http://www.apachefriends.org/en/faq-xampp-windows.html
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: connecting to xampp server

Postby droidus » 05. February 2013 22:39

awesome - thank you!
droidus
 
Posts: 7
Joined: 05. February 2013 04:43
XAMPP Version: 5.6.3
Operating System: win7

Re: connecting to xampp server

Postby droidus » 05. February 2013 22:56

is there any reason why some pages would not be displaying the php properly?

here is what i'm getting: http://tinypic.com/view.php?pic=x3sc2&s=6
droidus
 
Posts: 7
Joined: 05. February 2013 04:43
XAMPP Version: 5.6.3
Operating System: win7

Re: connecting to xampp server

Postby Altrea » 05. February 2013 23:50

droidus wrote:is there any reason why some pages would not be displaying the php properly?

Don't use short_open_tag. It is disabled by default.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: connecting to xampp server

Postby droidus » 07. February 2013 00:19

so i just take out the "<?" and "?>"?

not sure what you mean
droidus
 
Posts: 7
Joined: 05. February 2013 04:43
XAMPP Version: 5.6.3
Operating System: win7

Re: connecting to xampp server

Postby Altrea » 07. February 2013 00:23

droidus wrote:so i just take out the "<?" and "?>"?

not sure what you mean

Didn't you read the link i am posting for you?
http://www.php.net/manual/en/ini.core.php#ini.short-open-tag wrote:Also, if disabled, you must use the long form of the PHP open tag (<?php ?>).
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: connecting to xampp server

Postby droidus » 07. February 2013 02:40

when you say "by default", how can I change this?
droidus
 
Posts: 7
Joined: 05. February 2013 04:43
XAMPP Version: 5.6.3
Operating System: win7

Re: connecting to xampp server

Postby Altrea » 07. February 2013 10:54

droidus wrote:when you say "by default", how can I change this?

It is bad practice to make the functionality of a scripts dependent of a specific php setting especially if that setting is just a code styling one and not a functionality itself.
With that dependency your script maybe don't run on some servers where this setting is deactivated and that without any good reason.
but this is just a hint from an experienced programmer.

if you want to change this setting, search for short_open_tag = Off in your \xampp\php\php.ini, change it to On and restart Apache.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6536
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests