Apache server won't start [solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache server won't start [solved]

Postby kirwood » 16. December 2012 19:54

I am using Xampp V 1.8.1 with Control panel 3.1.0.3.1.0. The C++ package is installed
The Apache Server won't start and reports
The Apache service named reported the following error:
>>> order takes one argument, 'allow,deny', 'deny,allow', or 'mutual-failure' .

Here is the relevant section from httpd-vhosts.conf
<Directory d:/>
Order deny,allow
allow from all
</Directory>

# NameVirtualHost *:80

<VirtualHost *:80>
DocumentRoot c:/xampp/htdocs/
ServerName localhost
</VirtualHost>

<VirtualHost *:80>
DocumentRoot d:/kim
ServerName kim
ServerAlias kim
</VirtualHost>

And here is the Apache error log
[Sun Dec 16 11:20:21.377997 2012] [ssl:warn] [pid 1856:tid 412] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Dec 16 11:20:22.764162 2012] [mpm_winnt:notice] [pid 1856:tid 412] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Sun Dec 16 11:20:22.765139 2012] [mpm_winnt:notice] [pid 1856:tid 412] AH00456: Server built: Aug 18 2012 12:41:37
[Sun Dec 16 11:20:22.765139 2012] [core:notice] [pid 1856:tid 412] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Dec 16 11:20:22.768070 2012] [mpm_winnt:notice] [pid 1856:tid 412] AH00418: Parent: Created child process 2252
[Sun Dec 16 11:20:24.889798 2012] [ssl:warn] [pid 2252:tid 296] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Dec 16 11:20:25.061666 2012] [mpm_winnt:notice] [pid 2252:tid 296] AH00354: Child: Starting 150 worker threads.
[Sun Dec 16 11:44:05.282410 2012] [mpm_winnt:notice] [pid 1856:tid 412] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Sun Dec 16 11:44:07.329190 2012] [mpm_winnt:notice] [pid 2252:tid 296] AH00364: Child: All worker threads have exited.
[Sun Dec 16 11:44:07.360438 2012] [mpm_winnt:notice] [pid 1856:tid 412] AH00430: Parent: Child process exited successfully.
[Sun Dec 16 11:45:34.734272 2012] [ssl:warn] [pid 1868:tid 348] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Dec 16 11:45:35.503768 2012] [mpm_winnt:notice] [pid 1868:tid 348] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Sun Dec 16 11:45:35.503768 2012] [mpm_winnt:notice] [pid 1868:tid 348] AH00456: Server built: Aug 18 2012 12:41:37
[Sun Dec 16 11:45:35.503768 2012] [core:notice] [pid 1868:tid 348] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Dec 16 11:45:35.514510 2012] [mpm_winnt:notice] [pid 1868:tid 348] AH00418: Parent: Created child process 2476
[Sun Dec 16 11:45:37.296895 2012] [ssl:warn] [pid 2476:tid 292] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Dec 16 11:45:37.405777 2012] [mpm_winnt:notice] [pid 2476:tid 292] AH00354: Child: Starting 150 worker threads.

I am at a loss to solve this. I don't know anything about SSLSessionCache. Any help appreciated
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache server won't start

Postby JonB » 17. December 2012 03:23

If your problem is accessing your Vhosts, and Apache shows as running:

The problem is that the Authorization paradigm for Apache 2.2 changed radically for Apache 2.4

Read this.
http://httpd.apache.org/docs/current/upgrading.html

You might want to consider running XAMPP 1.7.7 which is the last XAMPP with Apache 2.2 release - you won't have to learn all new syntax.

The SSLSessionCache is a non-issue. this is the tail from a peoprely running XAMPP 1.8.0 server on Win 7:

Code: Select all
[Sun Dec 16 09:12:11.161339 2012] [mpm_winnt:notice] [pid 6100:tid 248] AH00456: Server built: May 13 2012 14:10:15
[Sun Dec 16 09:12:11.161339 2012] [core:notice] [pid 6100:tid 248] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Dec 16 09:12:11.176339 2012] [mpm_winnt:notice] [pid 6100:tid 248] AH00418: Parent: Created child process 5348
[Sun Dec 16 09:12:13.276369 2012] [ssl:warn] [pid 5348:tid 260] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Dec 16 09:12:13.373870 2012] [mpm_winnt:notice] [pid 5348:tid 260] AH00354: Child: Starting 150 worker threads.

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache server won't start

Postby Altrea » 17. December 2012 06:05

Hi kirwood,

kirwood wrote:The Apache service named reported the following error:
>>> order takes one argument, 'allow,deny', 'deny,allow', or 'mutual-failure'

This error message indicates, that you haven't posted the correct path where the error occurs or that you don't copied the correct sourcecode of that file.
AFAIK the error message only occurs if you misspell the Order directive, e.g. placing a space between deny, and allow.

But, Order deny,allow is old syntax (as JonB already said).
Although learning a new syntax takes always some time the new syntax is quite easy.

Instead of
Code: Select all
Order deny,allow
Deny from all

you could simply write
Code: Select all
Require all denied


Instead of
Code: Select all
Order allow,deny
Allow from all

simply write
Code: Select all
Require all granted


The only thing which will not work is mixing old access syntax with new syntax.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6614
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache server won't start

Postby kirwood » 03. February 2013 17:45

Hi,
I followed your instructions but I could not get any thing working :cry: so I deleted all and reinstalled a clean version
I set Apache to port 39393, it also selected 443 itself.
According to the control panel Apache and NYSQL server are now running.

Now I cannot get localhost to run.
httpd-vhosts.conf contains this
VirtualHost *:39393>
ServerAdmin postmaster@dummy-host.localhost
DocumentRoot "C:/xampp/htdocs/dummy-host.localhost"
ServerName dummy-host.localhost
ServerAlias www.dummy-host.localhost
ErrorLog "logs/dummy-host.localhost-error.log"
CustomLog "logs/dummy-host.localhost-access.log" combined
</VirtualHost>
Host file contains this
127.0.0.1 dummy-host2.localhost

That's it. Nothing else. I tried localhost and dummy-host2.localhost in the browser; response is Page not Found.

:?: What must I do? I also want to add other virtual servers eg kim.
I know we must move forward but this version has cost me so much time and frustration I wonder if it might not be wiser to go back to an older version. Is one available and still supported?
Thank you in anticipation.
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache server won't start

Postby kirwood » 03. February 2013 17:53

This is the error log file>

AH00112: Warning: DocumentRoot [C:/xampp/htdocs/dummy-host.localhost] does not exist
[Sun Feb 03 15:13:19.216284 2013] [core:warn] [pid 8104:tid 268] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Feb 03 15:13:19.685009 2013] [ssl:warn] [pid 8104:tid 268] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Feb 03 15:13:20.091241 2013] [mpm_winnt:notice] [pid 8104:tid 268] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Sun Feb 03 15:13:20.091241 2013] [mpm_winnt:notice] [pid 8104:tid 268] AH00456: Server built: Aug 18 2012 12:41:37
[Sun Feb 03 15:13:20.091241 2013] [core:notice] [pid 8104:tid 268] AH00094: Command line: 'apache\\bin\\httpd.exe -d C:/xampp/apache -f conf\\httpd.conf'
[Sun Feb 03 15:13:20.091241 2013] [mpm_winnt:notice] [pid 8104:tid 268] AH00418: Parent: Created child process 6872
AH00112: Warning: DocumentRoot [C:/xampp/htdocs/dummy-host.localhost] does not exist
Apache server shutdown initiated...
ampp/htdocs/dummy-host.localhost] does not exist
[Sun Feb 03 15:13:21.653669 2013] [ssl:warn] [pid 6872:tid 300] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Feb 03 15:13:21.747415 2013] [mpm_winnt:notice] [pid 6872:tid 300] AH00354: Child: Starting 150 worker threads.
[Sun Feb 03 15:13:26.465943 2013] [mpm_winnt:notice] [pid 8104:tid 268] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Sun Feb 03 15:13:28.497098 2013] [mpm_winnt:notice] [pid 6872:tid 300] AH00364: Child: All worker threads have exited.
[Sun Feb 03 15:13:28.543972 2013] [mpm_winnt:notice] [pid 8104:tid 268] AH00430: Parent: Child process exited successfully.
AH00112: Warning: DocumentRoot [C:/xampp/htdocs/dummy-host.localhost] does not exist
[Sun Feb 03 15:13:47.121226 2013] [ssl:warn] [pid 3660:tid 296] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Feb 03 15:13:47.214975 2013] [mpm_winnt:notice] [pid 3660:tid 296] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Sun Feb 03 15:13:47.214975 2013] [mpm_winnt:notice] [pid 3660:tid 296] AH00456: Server built: Aug 18 2012 12:41:37
[Sun Feb 03 15:13:47.214975 2013] [core:notice] [pid 3660:tid 296] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Feb 03 15:13:47.230599 2013] [mpm_winnt:notice] [pid 3660:tid 296] AH00418: Parent: Created child process 3368
AH00112: Warning: DocumentRoot [C:/xampp/htdocs/dummy-host.localhost] does not exist
AH00112: Warning: DocumentRoot [C:/xampp/htdocs/dummy-host.localhost] does not exist
[Sun Feb 03 15:13:49.011763 2013] [ssl:warn] [pid 3368:tid 300] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Feb 03 15:13:49.105512 2013] [mpm_winnt:notice] [pid 3368:tid 300] AH00354: Child: Starting 150 worker threads.
AH00112: Warning: DocumentRoot [C:/xampp/htdocs/dummy-host.localhost] does not exist
[Sun Feb 03 16:05:14.212486 2013] [core:warn] [pid 5844:tid 292] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Feb 03 16:05:14.728088 2013] [ssl:warn] [pid 5844:tid 292] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Feb 03 16:05:14.931204 2013] [mpm_winnt:notice] [pid 5844:tid 292] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Sun Feb 03 16:05:14.931204 2013] [mpm_winnt:notice] [pid 5844:tid 292] AH00456: Server built: Aug 18 2012 12:41:37
[Sun Feb 03 16:05:14.931204 2013] [core:notice] [pid 5844:tid 292] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Sun Feb 03 16:05:14.946828 2013] [mpm_winnt:notice] [pid 5844:tid 292] AH00418: Parent: Created child process 5908
AH00112: Warning: DocumentRoot [C:/xampp/htdocs/dummy-host.localhost] does not exist
AH00112: Warning: DocumentRoot [C:/xampp/htdocs/dummy-host.localhost] does not exist
[Sun Feb 03 16:05:16.540504 2013] [ssl:warn] [pid 5908:tid 300] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Sun Feb 03 16:05:16.649876 2013] [mpm_winnt:notice] [pid 5908:tid 300] AH00354: Child: Starting 150 worker threads.
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache server won't start

Postby Altrea » 03. February 2013 18:01

Hi kirwood,

kirwood wrote:AH00112: Warning: DocumentRoot [C:/xampp/htdocs/dummy-host.localhost] does not exist

Your DocumentRoot directory doesn't exist.

kirwood wrote:I tried localhost and dummy-host2.localhost in the browser; response is Page not Found.

You have changed the port for http. Have you tried http://localhost:39393/ and http://dummy-host2.localhost:39393/ too?
btw: you setted dummy-host2.localhost in your hosts file, but setted dummy-host.localhost in your VirtualHost definition.

kirwood wrote:I also want to add other virtual servers eg kim.

One step after another

kirwood wrote:I wonder if it might not be wiser to go back to an older version.

Older versions don't work with wrong configuration either.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6614
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache server won't start

Postby kirwood » 06. February 2013 16:46

Thank you. I have rectified code and some things have changed:-
Folder called xampp/htdocs/dummy-host.localhost created.
Changed host to dummy-host.localhost
localhost gives page not found
Port 80 is being used by windows system, Port 39393 came up when I was Googling the problem. No other reason for choice
http://dummy-host.localhost:39393/ gives
Index of /

Name Last modified Size Description
Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 Server at dummy-host.localhost Port 39393

So something is happening but still not functional
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache server won't start

Postby Altrea » 06. February 2013 18:40

kirwood wrote:http://dummy-host.localhost:39393/ gives
Index of /

Name Last modified Size Description
Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 Server at dummy-host.localhost Port 39393

So something is happening but still not functional

Your Apache is working very well.
You have successfully requested your vhost dummy-host.localhost on port 39393.
You haven't specified an exact filename in your url and Apache can't find any of its default directory index files, so the default behaviour is to print out an index table of the contents of your requested folder.

kirwood wrote:localhost gives page not found

Have you specified a virtual host for localhost?
have you added the port 39393 in your localhost request too?

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6614
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache server won't start

Postby kirwood » 06. February 2013 20:37

I am not understanding you - sorry,
I have this
"<VirtualHost *:39393>
ServerAdmin postmaster@dummy-host.localhost
DocumentRoot "C:/xampp/htdocs/dummy-host.localhost"
ServerName dummy-host.localhost
ServerAlias www.dummy-host.localhost
ErrorLog "logs/dummy-host.localhost-error.log"
CustomLog "logs/dummy-host.localhost-access.log" combined
</VirtualHost>"
but it may not be what you mean?>
What I would like initially is to be able to access the XAMPP configuration page and PHPMYHADMIN
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache server won't start

Postby Altrea » 06. February 2013 21:23

kirwood wrote:What I would like initially is to be able to access the XAMPP configuration page and PHPMYHADMIN

If this is the only goal to achieve, you don't need any vhosts (especially not if you don't know what vhosts do and how to configure them properly)
Simply comment the whole virtualhost block, restart Apache and request http://localhost:39393/xampp/ for the XAMPP Administration page.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6614
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache server won't start

Postby kirwood » 07. February 2013 10:25

No, it is not the only goal. I thought that if I got there first I might understand better what is happening.
I do need about ten other virtual hosts, each with a MySQL database.
How may I take that step?
And thanks for your help and patience.
David
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache server won't start

Postby Altrea » 07. February 2013 11:44

kirwood wrote:I do need about ten other virtual hosts, each with a MySQL database.

It would be much easier to provide help, if we would now what you want to achieve with vhosts.

virtual hosts are just needed, if you want to simulate/run multiple webservers services on the same physical machine with just one Apache.
Each can have their own hostname, DocumentRoot folder, log files, etc.

Just to have several webapplications on the same machine, vhosts are not needed. For that you can create a subdirectory for each webapplication inside your htdocs folder:
Code: Select all
htdocs/
    app1/
    app2/
    app3/

And request them already by adding the folder in your url:
http://localhost:39393/app1/
http://localhost:39393/app2/
http://localhost:39393/app3/
which is much easier then creating vhosts.

MySQL databases are completely independend from that requirement.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6614
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache server won't start

Postby kirwood » 07. February 2013 12:27

I ran the old version of XAMPP for two years.
What I had was a virtual host for each separate website, specified in hosts and httpd-vhosts.conf, that I was developing, accessed by the host name e.g. kim/, tc/ etc. in the browser. I use Dreamweaver for development work and the two worked perfectly in the setup worked. It is the method set out in Adobe tutorials.
If I could replicate that on this new version I would be happy.

I am using "dummy-host.localhost" because that was in the httpd-vhosts.conf. Can I change that to just "localhost" in httpd-vhosts.conf and modify htdocs?

I understand MySQL is a different issue but the only way I know to create/modify databases is via XAMPP. I would like to import the old databases I saved and at the moment I cannot.
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Re: Apache server won't start

Postby Altrea » 07. February 2013 12:38

kirwood wrote:What I had was a virtual host for each separate website, specified in hosts and httpd-vhosts.conf, that I was developing, accessed by the host name e.g. kim/, tc/ etc. in the browser.

Okay, so you want to separate and simulate domain names. Thats a request we can work with.

Assuming your domainnames will be kim and tc and are already added in your Windows hosts file:
create three vhosts in your httpd-vhosts.conf file
Code: Select all
<VirtualHost *:80>
    DocumentRoot "C:/xampp/htdocs"
    ServerName localhost
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:/xampp/htdocs/kim"
    ServerName kim
</VirtualHost>

<VirtualHost *:80>
    DocumentRoot "C:/xampp/htdocs/tc"
    ServerName tc
</VirtualHost>


kirwood wrote:I am using "dummy-host.localhost" because that was in the httpd-vhosts.conf. Can I change that to just "localhost" in httpd-vhosts.conf and modify htdocs?

As you see in the example, you are free to use what name and folder you want.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6614
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache server won't start

Postby kirwood » 07. February 2013 14:29

Two questions before I do anything
I don't think XAMPP can use port 80. Should not Virtualhost be *:39393?
Can I change Documentroot to D:/kim? This is the drive all the websites are stored on.

<VirtualHost *:80>
DocumentRoot "C:/xampp/htdocs/kim"
ServerName kim
</VirtualHost>
User avatar
kirwood
 
Posts: 27
Joined: 03. February 2011 12:07
XAMPP Version: 5.6.3
Operating System: Windows 8 64bit

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests