Lampp 1.8.0 internal server error 500 with php_value

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Lampp 1.8.0 internal server error 500 with php_value

Postby awk » 31. January 2013 01:30

Hey everyone! I'm quite new to the world of websites and web hosting. I'm fellow programmer learning C++, SQL and Python. However I had to setup a website for my needs but I occur at downloading my index.php file and an internal server error everytime I try to access my website hosted under OpenSuSE 12.2 using Lampp 1.8.0. My website required me to enable certain apache and php modules though ... However I'm stuck at this issue of mine from three days now, my last hope is getting a sensible assistance from the community of Xampp!

Apache modules enabled: mod_rewrite, mod_headers, mod_expires, mod_deflate

PHP modules enabled: php_curl, php_openssl, php_soap, php_gd

On the PHP modules I noticed xampp doesn't have php_gd but has phpgd2, so I enabled it following prime logic.

My error log says:
[Thu Jan 31 02:02:49.674549 2013] [core:alert] [pid 4111] [client] /opt/lampp/htdocs/.htaccess:
Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration

The only line that uses php_value in my .htaccess file is: php_value zlib.output_compression off

Thanks everyone for participating in my issue in advance! I'm looking forward any suggestions how to fix it. :)

~ Awk
Posts: 1
Joined: 31. January 2013 01:22
XAMPP Version: 5.6.14
Operating System: windows/linux

Re: Lampp 1.8.0 internal server error 500 with php_value

Postby JonB » 01. February 2013 17:30

OK -

After some research using the XAMPP phpinfo() page and PHP Docs

I think you can simply remove that line and things will be OK - because: ... sion-level

(which to me seems to indicate that is a php.ini only setting - and that may be the cause of your error)

NEVER-THE-LESS the value is defaulted 'off' anyway.

In the Zlib section of phpinfo():

Code: Select all
zlib.output_compression     Off   Off
zlib.output_compressionLevel   -1   -1
zlib.output_handler  no value no value

Try it out and let me know -
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-3
Operating System: Windows XP/7 - Fedora 15 1.7.7

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests