xampp apache will not start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp apache will not start

Postby golddragon007 » 24. January 2013 20:53

Hi,

I have this problem too, I installed the 3.1.0 XAMPP now, and when I start the apache, it won't want to work, automatically stop running. I get this message in the control panel:
20:43:40 [Apache] Status change detected: stopped
20:43:40 [Apache] Error: Apache shutdown unexpectedly.
20:43:40 [Apache] This may be due to a blocked port, missing dependencies,
20:43:40 [Apache] improper privileges, a crash, or a shutdown by another method.
20:43:40 [Apache] Check the "/xampp/apache/logs/error.log" file
20:43:40 [Apache] and the Windows Event Viewer for more clues
But the error.log is empty.... I tried changeing the ports, but still doesn't work... Any other idea?
golddragon007
 
Posts: 4
Joined: 24. January 2013 20:49
XAMPP Version: 5.6.3
Operating System: Windows 7 x64

Re: xampp apache will not start

Postby Altrea » 24. January 2013 21:44

Hi golddragon007,

i have separated your post from the original one (one new topic per issue and user rule).

Back to topic:
Please try to start Apache with the \xampp\apache_start.bat script and tell us, what messages the command line are printing.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6671
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: xampp apache will not start

Postby golddragon007 » 24. January 2013 21:51

httpd.exe: Syntax error on line 70 of C:/xampp/apache/conf/httpd.conf: Cannot load modules/mod_authn_default.so into server: The specified path wasn't found.
I watched the apache/modules/mod_authn_default.so and there's exist that file.
golddragon007
 
Posts: 4
Joined: 24. January 2013 20:49
XAMPP Version: 5.6.3
Operating System: Windows 7 x64

Re: xampp apache will not start

Postby Altrea » 24. January 2013 22:35

golddragon007 wrote:Syntax error on line 70 of C:/xampp/apache/conf/httpd.conf: Cannot load modules/mod_authn_default.so into server: The specified path wasn't found.

That line is not present in my XAMPP 1.8.1 testinstallation. So how does it come into yours?
Maybe this is one of the many "installing over an previous XAMPP version" issues!?

Ressources:
How to "upgrade" to XAMPP 1.8.0 or 1.8.1
Read before installing or upgrading to 1.8.0 or 1.8.1
Apache Upgrading to 2.4 from 2.2

http://httpd.apache.org/docs/2.4/upgrading.html wrote:These modules have been removed: mod_authn_default, mod_authz_default, mod_mem_cache. If you were using mod_mem_cache in 2.2, look at mod_cache_disk in 2.4.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6671
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: xampp apache will not start

Postby golddragon007 » 24. January 2013 23:27

yeah, maybe that was the problem...
golddragon007
 
Posts: 4
Joined: 24. January 2013 20:49
XAMPP Version: 5.6.3
Operating System: Windows 7 x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 30 guests