MySQL-Datenbanken im Status deaktiviert

Alles, was MySQL betrifft, kann hier besprochen werden.

MySQL-Datenbanken im Status deaktiviert

Postby Nono » 19. January 2013 12:13

Hallo,
ich habe MySQL normal über den Control Panel gestartet und es ist auch grün hinterlegt, dass heißt für mich, es ist gestartet.
Allerdings steht bei dem XAMPP-Status, dass MySQL Datenbanken deaktiviert sind. Auf phpMyAdmin kommt keine Fehlermeldung, es läuft normal.
Hier kommt aber jetzt das Problem das ich habe:

Wenn ich meine Seite aufrufen möchte kommt folgende Meldung:

Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\spiel\verbindung.php on line 8


In Zeile 8 steht folgendes:

Code: Select all
$mysqli = new MySQLi("$host", "$benutzer", "$passwort", "$dbname");


Ich denke, dass hängt damit zusammen, dass der Status von MySQL Datenbanken deaktiviert ist.
Das Problem ist vor ein paar Tagen auf einmal aufgetreten. Ich habe jetzt bereits die neuste Version von XAMPP installiert (alte deinstalliert und dann neu installiert) und der Fehler tritt immer noch auf.
Mich wunderts, dass der Fehler von heute auf morgen aufgetreten ist, ohne dass ich bewusst was geändert habe.
Ich würde mich sehr freuen, wenn mir jemand helfen könnte.
Liebe Grüße
Nono
Nono
 
Posts: 7
Joined: 17. January 2013 16:18
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: MySQL-Datenbanken im Status deaktiviert

Postby Nono » 20. January 2013 11:52

Ich habe max_execution_time auf 300 gesetzt in der php.ini und jetzt kommt die Fehlermeldung nicht mehr. Es dauert aber noch sehr lange, bis meine Seite geladen ist. Woran könnte das liegen, dass meine Seite auf einmal so lange zum Laden braucht?
Nono
 
Posts: 7
Joined: 17. January 2013 16:18
XAMPP Version: 5.6.3
Operating System: Windows 7


Return to MySQL

Who is online

Users browsing this forum: No registered users and 4 guests