php.ini settings getting overriden [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

php.ini settings getting overriden [Solved]

Postby nemesisjack » 17. January 2013 18:28

I set up an install of XAMPP to build an ecommerce site using OpenCart. I put the OpenCart install on C:\xampp\htdocs\opencart\upload and I set the php.ini file in it and set memory_limit = 1G and max_execution_time = 600.

The problem I'm having is that these settings are getting overwritten by something in XAMPP. When I run phpinfo(), it shows memory_limit as 128M and max_execution_time = 30
nemesisjack
 
Posts: 2
Joined: 17. January 2013 18:18
XAMPP Version: 5.6.3
Operating System: Windows XP

Re: php.ini settings getting overriden

Postby Altrea » 17. January 2013 18:45

Hi nemesisjack,

nemesisjack wrote:The problem I'm having is that these settings are getting overwritten by something in XAMPP.

Thats not correct. Changing values in php.ini works pretty well, if you do it the right way:
  • Change the correct configuration file (can be found in phpinfo setting Loaded Configuration File)
  • Change the correct line in that configuration line (some lines are just for commentary (commented out by a leading semicolon ; ))
  • give it a valid value for that setting
  • save the file
  • Restart yourApache after your change

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6490
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: php.ini settings getting overriden

Postby nemesisjack » 17. January 2013 19:03

I found the problem:

I was changing settings on the php.ini file provided by OpenCart. I had to change them on the one at C:\xampp\php\php.ini
nemesisjack
 
Posts: 2
Joined: 17. January 2013 18:18
XAMPP Version: 5.6.3
Operating System: Windows XP


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests