Tomcat can't start - error -1073741510 - [ Solved ]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Tomcat can't start - error -1073741510 - [ Solved ]

Postby smadzara » 25. October 2012 20:00

After a clean install of XAMPP (1.8.1) all servers are working fine as a service or manual.
When I change configuration in Control Panel (3.1.0) default text editor I can't get Tomcat started.

Image

Both of paths are correct and I really don't know what to do.

When I put back default text editor (notepad.exe) things are stay the same, Tomcat could not be started.

Sometimes I get error 1073741510, sometimes I get this
Code: Select all
20:58:12  [Tomcat]    Attempting to start Tomcat app...
20:58:12  [Tomcat]    Executing "cmd" "/c "d:\web_development\xampp\catalina_start.bat""
20:58:29  [Tomcat]    Return code: 0

Any ideas? Thanks in advance.

Code: Select all
[XAMPP]: Searching for JDK or JRE HOME with reg query ...

Error:  The system was unable to find the specified registry key or value
. [XAMPP]: Could not find 32 bit or 64 bit JDK
. [XAMPP]: Looking for 32 bit JDK on 64 bit machine

Error:  The system was unable to find the specified registry key or value
. [XAMPP]: Could not find 32 bit JDK
. [XAMPP]: Looking for 32 bit or 64 bit JRE

! REG.EXE VERSION 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment
    Java6FamilyVersion  REG_SZ  1.6.0_11
    CurrentVersion      REG_SZ  1.6
    BrowserJavaVersion  REG_SZ  1.6.0_11

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.6
    JavaHome    REG_SZ  C:\Program Files\Java\jre6
    RuntimeLib  REG_SZ  C:\Program Files\Java\jre6\bin\client\jvm.dll
    MicroVersion        REG_SZ  0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.6.0_11
    JavaHome    REG_SZ  C:\Program Files\Java\jre6
    MicroVersion        REG_SZ  0
    RuntimeLib  REG_SZ  C:\Program Files\Java\jre6\bin\client\jvm.dll

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Runtime Environment\1.6.0_11\MSI
    JU  REG_SZ  1
    OEMUPDATE   REG_SZ
    MODE        REG_SZ  C
    FROMVERSION REG_SZ  NA
    KERNEL      REG_SZ
    PRODUCTVERSION      REG_SZ  6.0.110
    INSTALLDIR  REG_SZ  C:\Program Files\Java\jre6\
    SYSTRAY     REG_SZ  1
    EULA        REG_SZ  0
    IEXPLORER   REG_SZ  1
    MOZILLA     REG_SZ  0
    JAVAUPDATE  REG_SZ  1
    AUTOUPDATECHECK     REG_SZ  1
    AUTOUPDATEDELAY     REG_SZ
    ImageCkSum  REG_SZ  3406536120
    FullVersion REG_SZ  1.6.0_11-b03

[XAMPP]: Using JRE

[XAMPP]: Seems fine!
[XAMPP]: Set JRE_HOME : C:\Program Files\Java\jre6
[XAMPP]: Set CATALINA_HOME : C:\Program Files\Notepad++\tomcat

The system cannot find the path specified.
The system cannot find the path specified.
done.
Press any key to continue . . .
Last edited by smadzara on 06. November 2012 12:24, edited 1 time in total.
smadzara
 
Posts: 8
Joined: 25. October 2012 17:25
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Tomcat can't start - error -1073741510

Postby hackattack142 » 26. October 2012 00:00

Well this appears to be the problem line: [XAMPP]: Set CATALINA_HOME : C:\Program Files\Notepad++\tomcat

Did you move/edit the batch file or any files?

That path is set by taking the current directory of the 'catalina_start.bat' batch file and it assumes it is in the XAMPP root directory.

The batch files are independent of the control panel so any changes to the control panel settings should have no effect on the batch files.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Tomcat can't start - error -1073741510

Postby smadzara » 26. October 2012 08:58

I didn't move or edit nothing except as I described before. Only text editor in CP. After that Tomcat stop working.
When I make a new install and don't touch text editor settings, everything works just fine.

Without touching anything, now I get
Code: Select all
[XAMPP]: Using JRE

[XAMPP]: Seems fine!
[XAMPP]: Set JRE_HOME : C:\Program Files\Java\jre6
[XAMPP]: Set CATALINA_HOME : D:\WEB_Development\xampp\tmp\tomcat

The system cannot find the path specified.
The system cannot find the path specified.
done.


My installation is just on that path so I really don't get it :|
smadzara
 
Posts: 8
Joined: 25. October 2012 17:25
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Tomcat can't start - error -1073741510

Postby hackattack142 » 26. October 2012 22:27

Strange, that still does not look right.

[XAMPP]: Set CATALINA_HOME : D:\WEB_Development\xampp\tmp\tomcat

That is the output with a fresh install with no changes?

What is the output in a terminal (Start > Run > cmd) if you put the following in:
Code: Select all
echo %cd%
echo %CURRENT_DIR%
echo %CATALINA_HOME%


I set my default editor to notepad++ also and I do not see any behavior like this nor does it break my tomcat.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Tomcat can't start - error -1073741510

Postby smadzara » 26. October 2012 22:51

hackattack142 wrote:Strange, that still does not look right.

[XAMPP]: Set CATALINA_HOME : D:\WEB_Development\xampp\tmp\tomcat

That is the output with a fresh install with no changes?


Yes that's from the fresh install.
I was only add that directory which didn't exist, "tomcat"

hackattack142 wrote:What is the output in a terminal (Start > Run > cmd) if you put the following in:
Code: Select all
echo %cd%
echo %CURRENT_DIR%
echo %CATALINA_HOME%


Output:
Code: Select all
C:\Documents and Settings\systemadmin>echo %cd%
C:\Documents and Settings\systemadmin

C:\Documents and Settings\systemadmin>echo %CURRENT_DIR%
%CURRENT_DIR%

C:\Documents and Settings\systemadmin>echo %CATALINA_HOME%
%CATALINA_HOME%

C:\Documents and Settings\systemadmin>


Edit:

Right now I just installed JDK 1.7.0_09
After that I made restart of the system. I start XAMPP CP trying to start Tomcat.
This is what I'm get:
Code: Select all
[XAMPP]: Searching for JDK or JRE HOME with reg query ...

! REG.EXE VERSION 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit
    CurrentVersion      REG_SZ  1.7

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.7
    JavaHome    REG_SZ  C:\Program Files\Java\jdk1.7.0_09
    MicroVersion        REG_SZ  0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.7.0_09
    JavaHome    REG_SZ  C:\Program Files\Java\jdk1.7.0_09
    MicroVersion        REG_SZ  0

[XAMPP]: Using JDK

[XAMPP]: Seems fine!
[XAMPP]: Set JAVA_HOME : C:\Program Files\Java\jdk1.7.0_09
[XAMPP]: Set CATALINA_HOME : D:\WEB_Development\xampp\tmp\tomcat

The system cannot find the path specified.
The system cannot find the path specified.
done.
Press any key to continue . . .

But when I start catalina_start.bat directly from Explorer, Tomcat start to boot and works like a charm. :|
With previous version of Java (JRE 1.6.0_11) I didn't make to start Tomcat even directly from catalina_start.bat from Explorer.
smadzara
 
Posts: 8
Joined: 25. October 2012 17:25
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Tomcat can't start - error -1073741510

Postby hackattack142 » 27. October 2012 01:31

I was only add that directory which didn't exist, "tomcat"

What do you mean the Tomcat directory did not exist? Are you using the full version of XAMPP or missing files?

I would expect that path to look like "D:\WEB_Development\xampp\tomcat"

When you run the 'catalina_start.bat', are you running the one in the /xampp folder or the one in the tomcat folder?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Tomcat can't start - error -1073741510

Postby skndmx » 28. October 2012 10:21

You can copy tomcat folder to the tmp folder.
And keep the catalina_home as ......\tmp\tomcat
Hope this will help.
skndmx
 
Posts: 1
Joined: 28. October 2012 10:18
XAMPP Version: 5.6.3
Operating System: Windows 8 x64

Re: Tomcat can't start - error -1073741510

Postby smadzara » 28. October 2012 12:03

hackattack142 wrote:What do you mean the Tomcat directory did not exist? Are you using the full version of XAMPP or missing files?

I would expect that path to look like "D:\WEB_Development\xampp\tomcat"


I'm using full version of XAMPP.

D:\WEB_Development\xampp\tmp\tomcat
Tomcat directory didn't exist, so I create it and now path looks like it should be D:\WEB_Development\xampp\tmp\tomcat

hackattack142 wrote:When you run the 'catalina_start.bat', are you running the one in the /xampp folder or the one in the tomcat folder?


/xampp/tomcat

but now I try and that one in /xampp folder. It also works.

Only one it not work is one from the CP, but it does not make sense :|
smadzara
 
Posts: 8
Joined: 25. October 2012 17:25
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Tomcat can't start - error -1073741510

Postby hackattack142 » 28. October 2012 16:18

Tomcat directory didn't exist

This is the first issue i am concerned about. If you have the full version of XAMPP, it should be there or something is wrong with your installer/zip. If you downloaded XAMPP Portable, it does not come with Tomcat.

The Control Panel calls the one in the /xampp folder. If it works manually, it confuses me why it does not work otherwise.

Could you post the entire log window of the control panel after starting it up.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Tomcat can't start - error -1073741510

Postby smadzara » 28. October 2012 20:32

Besides of Tomcat directory that does not exist, first error was about Tomcat directory on the notepad++ path, but when I create it, i don't get the error, just that one with /xampp folder.

I have full version of XAMPP not the portable one.

Code: Select all
20:30:28  [main]    Initializing Control Panel
20:30:28  [main]    Windows Version: Windows XP SP3 32-bit
20:30:28  [main]    XAMPP Version: 1.8.1
20:30:28  [main]    Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
20:30:28  [main]    Running with Administrator rights - good!
20:30:28  [main]    XAMPP Installation Directory: "d:\web_development\xampp\"
20:30:28  [main]    Checking for prerequisites
20:30:28  [main]    All prerequisites found
20:30:28  [main]    Initializing Modules
20:30:28  [Apache]    Initializing module...
20:30:28  [Apache]    Checking for module existence...
20:30:28  [Apache]    Checking for required tools...
20:30:28  [Apache]    Checking for service (name="Apache2.4"): Service not installed
20:30:28  [Apache]    Service Path: Service Not Installed
20:30:28  [Apache]    Checking default ports...
20:30:28  [mysql]    Initializing module...
20:30:28  [mysql]    Checking for module existence...
20:30:28  [mysql]    Checking for required tools...
20:30:28  [mysql]    Checking for service (name="mysql"): Service not installed
20:30:28  [mysql]    Service Path: Service Not Installed
20:30:28  [mysql]    Checking default ports...
20:30:28  [filezilla]    Initializing module...
20:30:28  [filezilla]    Checking for module existence...
20:30:28  [filezilla]    Checking for required tools...
20:30:28  [filezilla]    Checking for service (name="FileZillaServer"): Service not installed
20:30:28  [filezilla]    Service Path: Service Not Installed
20:30:28  [filezilla]    Checking default ports...
20:30:28  [mercury]    Initializing module...
20:30:28  [mercury]    Checking for module existence...
20:30:28  [mercury]    Checking for required tools...
20:30:28  [mercury]    Checking default ports...
20:30:28  [Tomcat]    Initializing module...
20:30:28  [Tomcat]    Checking for module existence...
20:30:28  [Tomcat]    Checking for required tools...
20:30:28  [Tomcat]    Checking for service (name="Tomcat7"): Service not installed
20:30:28  [Tomcat]    Service Path: Service Not Installed
20:30:28  [Tomcat]    Checking default ports...
20:30:28  [main]    Starting Check-Timer
20:30:28  [main]    Control Panel Ready
20:33:00  [Tomcat]    Status change detected: running
smadzara
 
Posts: 8
Joined: 25. October 2012 17:25
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Tomcat can't start - error -1073741510

Postby maduserweb » 05. November 2012 16:58

Hi, I have had the same problem.

I think this is caused by the configuration files.

Problem occurred in file
catalina_start.bat


Around line 6x, the CURRENT_DIR is set to "xampp\tmp\", which is wrong.

Workaround:

Modify the following line
Code: Select all
set "CURRENT_DIR=%cd%"

into
Code: Select all
cd..
set "CURRENT_DIR=%cd%"


This fixed my problem, hope it will also help yours.
maduserweb
 
Posts: 1
Joined: 05. November 2012 16:46
XAMPP Version: 5.6.3
Operating System: Windows 7 x64

Re: Tomcat can't start - error -1073741510

Postby smadzara » 06. November 2012 12:24

Thank you very much. Works like a charm.
Solved! :)
smadzara
 
Posts: 8
Joined: 25. October 2012 17:25
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: Tomcat can't start - error -1073741510 - [ Solved ]

Postby IronWill » 17. November 2012 02:55

I had the same problem but found that XAMPP Control Panel start link had start folder set to D:\SrvApps\xamp\tmp
When I changed that to D:\SrvApps\xamp it worked as intended.
IronWill
 
Posts: 1
Joined: 17. November 2012 02:33
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Tomcat can't start - error -1073741510 - [ Solved ]

Postby shr386 » 04. January 2013 10:07

I had the same problem today, and found that the default directory for the shortcut for xampp-control.exe was set to 'c:\xampp\tmp'.
To fix, I clicked the shortcut icon with mouse right button, and then select 'property' menu item, and then changed 'Start In:' field as 'c:\xampp' , where I installed xampp.
Wish this help others having the same problem.
shr386
 
Posts: 1
Joined: 04. January 2013 10:00
XAMPP Version: 5.6.3
Operating System: windows xp

Re: Tomcat can't start - error -1073741510 - [ Solved ]

Postby rjmolloy » 16. January 2013 19:16

Changing the "Start In:" directory worked for me. Thanks.
rjmolloy
 
Posts: 1
Joined: 16. January 2013 19:13
XAMPP Version: 5.6.3
Operating System: Windows 8 64-bit

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests