Enabling WebDAV

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Enabling WebDAV

Postby saltyfoam » 05. January 2013 08:30

I downloaded XAMPP 1.8.1 and got it working with HTTP requests. I have since been trying to enable the WebDAV as described in several different posts on different Web sites with all different techniques and it still isn't working - returning 405 error when I try to POST. At this point I uninstalled and reinstalled (which pointed out some problems with the uninstall not removing some registry entries) a few times until things are back to a clean state. I then uncommented the dav modules (two of the three were commented) in the httpd.conf file, then uncommented the line that includes the httpd-dav.conf file. I have not yet worked on the password file but at this point I should not be getting a 405 so I need to get around this problem. Any suggestions on why it's complaining that POST is not available?
Posts: 1
Joined: 05. January 2013 06:07
XAMPP Version: 5.6.14
Operating System: Windows 7

Re: Enabling WebDAV

Postby JJ_Tagy » 05. January 2013 12:49

If I remember right, there is an issue with WEBDAV and Win7. You might need to google it.
Posts: 595
Joined: 30. January 2012 13:44
XAMPP Version: 1.8.3-1
Operating System: Windows 7 x64

Re: Enabling WebDAV

Postby ElectronicWar » 01. February 2013 11:34

Hey I got the same problem with XAMPP 1.8.1
I was running 1.7.3 for years without a problem. Now I tried 1.8.1 with exact the same WebDAV configuration and it just returns Error 405 Method Not Allowed.

Looks like a problem with that new Apache 2.4?
I'm on Windows 8 Professional x64 and XAMPP 1.7.3 with Apache 2.2 works without any issues.
Posts: 1
Joined: 01. February 2013 11:27
Location: Germany
XAMPP Version: 1.8.3-2
Operating System: Windows 8 Pro x64

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests