sendmail.exe problem (formmail.pl)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

sendmail.exe problem (formmail.pl)

Postby hailstorm22 » 28. December 2012 06:25

Hello everyone, name is Jared, I am developing a news media site on Xampp 3.0.12
I am trying to get my contact form setup using a .pl script in the action sequence...

Code: Select all
<form action="formmail.pl" method="post">


I visited a certain site (won't name it because I'm afraid that might not be permitted here) and I was told to define the location of my sendmail program inside of xampp. I did so and labelled it...

Code: Select all
$mailprog = '/xampp/sendmail/sendmail.exe -i -t';


I was also told to place a copy of my formmail.pl script in my server's cgi-bin, which I did. So, currently I have one copy in my root folder and another in xampp/cgi-bin

NOW, lol, when I fill in my test form and click submit it transfers me to a screen saying everything is perfectly fine and that the data has been sent to the address in the format and order I specified. But, I'm sure you guessed it, I didn't receive an email. I have tried altering the .pl script into a .cgi script but it seems to have no affect either.

Any ideas? If anyone needs additional information I would be happy to provide it via private message, I am using open licence script.
hailstorm22
 
Posts: 3
Joined: 28. December 2012 06:05
XAMPP Version: 5.6.3
Operating System: xampp 3.0.12 - windows

Re: sendmail.exe problem (formmail.pl)

Postby hailstorm22 » 28. December 2012 21:35

Can anyone help me in this problem?

If anyone needs more information to help me with the problem I am happy to give it. Thanks!
hailstorm22
 
Posts: 3
Joined: 28. December 2012 06:05
XAMPP Version: 5.6.3
Operating System: xampp 3.0.12 - windows

Re: sendmail.exe problem (formmail.pl)

Postby hailstorm22 » 29. December 2012 07:32

ok, thanks. I guess there is no reason to return to this site. cheers!
hailstorm22
 
Posts: 3
Joined: 28. December 2012 06:05
XAMPP Version: 5.6.3
Operating System: xampp 3.0.12 - windows

Re: sendmail.exe problem (formmail.pl)

Postby Altrea » 31. December 2012 17:56

Hi Jared,

hailstorm22 wrote:ok, thanks. I guess there is no reason to return to this site. cheers!

Goodbye then. This is a volunteer forum. (A very few) People here are trying to solve other people problems in their free time alongside of families, hobbies, friends, holidays, etc. Some topics will be replied in hours, others in days or weeks, some others will never (because nobody of the free helpers have a clue where to start or for other reasons). If that is not enough service for you this will be indeed the wrong place for you.

There are other paid freelancer job boards in the internet where you can expect faster support for an fairly amount of money. Maybe that is more what you like and want.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests