PHP_GD2 mit XAMPP 1.8.1

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

PHP_GD2 mit XAMPP 1.8.1

Postby Reange » 26. December 2012 01:43

Hallo,

ich möchte gerne GD_LIB nutzen, allerdings wird die extension nicht richtig geladen!
Die php_gd2.dll befindet sich (seit der Installation von xampp 1.8.1) im extension-Verzeichnis von PHP (C:\xampp\php\ext) und ist in die php.ini eingetragen:
Code: Select all
extension=php_gd2.dll

Allerdings wird php_gd (und andere extensions wie z.B. curl) trotzdem nicht geladen!
Woran liegt das?

Ich Danke jetzt schonmal für eure mühen!
Reange
Reange
 
Posts: 5
Joined: 26. December 2012 01:23
XAMPP Version: 5.6.3
Operating System: Windows 7 (32-Bit)

Re: PHP_GD2 mit XAMPP 1.8.1

Postby Nobbie » 26. December 2012 12:20

Meistens liegt es daran, dass irgendeine von den Microsoft Redistributable Paketen (das sind die Laufzeitbibliotheken zum C++ Compiler) nicht installiert sind. Ich weiß aber nicht, welche für Xampp 1.8.1 benötigt werden (vielleicht steht es irgendwo in einem Readme).
Nobbie
 
Posts: 7147
Joined: 09. March 2008 13:04

Re: PHP_GD2 mit XAMPP 1.8.1

Postby Reange » 26. December 2012 13:04

Ich habe gerade die Microsoft Visual C++ 2008 Redistributable Erweiterung von http://www.microsoft.com/en-us/download/details.aspx?id=5582 installiert. Das war das einzige Redistributable-Paket, das in der Readme angegeben war!
Aber auch nach einem System-Neustart laufen die Extensions leider nicht.
Reange
 
Posts: 5
Joined: 26. December 2012 01:23
XAMPP Version: 5.6.3
Operating System: Windows 7 (32-Bit)

Re: PHP_GD2 mit XAMPP 1.8.1

Postby Nobbie » 26. December 2012 13:31

Reange wrote:Ich habe gerade die Microsoft Visual C++ 2008 Redistributable Erweiterung von http://www.microsoft.com/en-us/download ... px?id=5582 installiert. Das war das einzige Redistributable-Paket, das in der Readme angegeben war!
Aber auch nach einem System-Neustart laufen die Extensions leider nicht.


Dann ist das wahrscheinlich ein Bug, ich bin leider nicht im Xampp Team und kann nichts zu sagen. Findest Du denn irgendeine Fehlermeldung im error_log?
Nobbie
 
Posts: 7147
Joined: 09. March 2008 13:04

Re: PHP_GD2 mit XAMPP 1.8.1

Postby Reange » 26. December 2012 15:04

Ich finde leider nichts im error.log, was auf mein Problem hindeutet, aber ich kenne mich damit auch nicht so gut aus!
Hier der error.log von heute:
Code: Select all
[Wed Dec 26 00:37:22.022874 2012] [mpm_winnt:notice] [pid 1508:tid 332] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Dec 26 00:37:24.022876 2012] [mpm_winnt:notice] [pid 2044:tid 232] AH00364: Child: All worker threads have exited.
[Wed Dec 26 00:37:24.062876 2012] [mpm_winnt:notice] [pid 1508:tid 332] AH00430: Parent: Child process exited successfully.
[Wed Dec 26 00:37:30.002885 2012] [ssl:warn] [pid 5040:tid 332] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 00:37:30.012885 2012] [mpm_winnt:notice] [pid 5040:tid 332] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed Dec 26 00:37:30.012885 2012] [mpm_winnt:notice] [pid 5040:tid 332] AH00456: Server built: Aug 18 2012 12:41:37
[Wed Dec 26 00:37:30.012885 2012] [core:notice] [pid 5040:tid 332] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Dec 26 00:37:30.012885 2012] [mpm_winnt:notice] [pid 5040:tid 332] AH00418: Parent: Created child process 4492
[Wed Dec 26 00:37:31.662887 2012] [ssl:warn] [pid 4492:tid 232] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 00:37:31.672887 2012] [mpm_winnt:notice] [pid 4492:tid 232] AH00354: Child: Starting 150 worker threads.
[Wed Dec 26 01:16:24.873135 2012] [mpm_winnt:notice] [pid 5040:tid 332] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Dec 26 01:16:26.901138 2012] [mpm_winnt:notice] [pid 4492:tid 232] AH00364: Child: All worker threads have exited.
[Wed Dec 26 01:16:26.916738 2012] [mpm_winnt:notice] [pid 5040:tid 332] AH00430: Parent: Child process exited successfully.
[Wed Dec 26 01:17:20.076433 2012] [ssl:warn] [pid 624:tid 332] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 01:17:20.092033 2012] [mpm_winnt:notice] [pid 624:tid 332] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed Dec 26 01:17:20.092033 2012] [mpm_winnt:notice] [pid 624:tid 332] AH00456: Server built: Aug 18 2012 12:41:37
[Wed Dec 26 01:17:20.092033 2012] [core:notice] [pid 624:tid 332] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Dec 26 01:17:20.092033 2012] [mpm_winnt:notice] [pid 624:tid 332] AH00418: Parent: Created child process 2208
[Wed Dec 26 01:17:22.416437 2012] [ssl:warn] [pid 2208:tid 232] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 01:17:22.447637 2012] [mpm_winnt:notice] [pid 2208:tid 232] AH00354: Child: Starting 150 worker threads.
[Wed Dec 26 01:51:01.031984 2012] [mpm_winnt:notice] [pid 624:tid 332] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Dec 26 01:51:03.031986 2012] [mpm_winnt:notice] [pid 2208:tid 232] AH00364: Child: All worker threads have exited.
[Wed Dec 26 01:51:03.061986 2012] [mpm_winnt:notice] [pid 624:tid 332] AH00430: Parent: Child process exited successfully.
[Wed Dec 26 01:51:07.871993 2012] [ssl:warn] [pid 5064:tid 332] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 01:51:07.881993 2012] [mpm_winnt:notice] [pid 5064:tid 332] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed Dec 26 01:51:07.881993 2012] [mpm_winnt:notice] [pid 5064:tid 332] AH00456: Server built: Aug 18 2012 12:41:37
[Wed Dec 26 01:51:07.881993 2012] [core:notice] [pid 5064:tid 332] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Dec 26 01:51:07.891993 2012] [mpm_winnt:notice] [pid 5064:tid 332] AH00418: Parent: Created child process 3380
[Wed Dec 26 01:51:09.691996 2012] [ssl:warn] [pid 3380:tid 232] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 01:51:09.701996 2012] [mpm_winnt:notice] [pid 3380:tid 232] AH00354: Child: Starting 150 worker threads.
[Wed Dec 26 02:08:46.968223 2012] [mpm_winnt:notice] [pid 5064:tid 332] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Dec 26 02:08:48.996227 2012] [mpm_winnt:notice] [pid 3380:tid 232] AH00364: Child: All worker threads have exited.
[Wed Dec 26 02:08:49.011827 2012] [mpm_winnt:notice] [pid 5064:tid 332] AH00430: Parent: Child process exited successfully.
[Wed Dec 26 11:26:00.982836 2012] [ssl:warn] [pid 1504:tid 332] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 11:26:01.029636 2012] [mpm_winnt:notice] [pid 1504:tid 332] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed Dec 26 11:26:01.029636 2012] [mpm_winnt:notice] [pid 1504:tid 332] AH00456: Server built: Aug 18 2012 12:41:37
[Wed Dec 26 11:26:01.029636 2012] [core:notice] [pid 1504:tid 332] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Dec 26 11:26:01.029636 2012] [mpm_winnt:notice] [pid 1504:tid 332] AH00418: Parent: Created child process 272
[Wed Dec 26 11:26:02.854839 2012] [ssl:warn] [pid 272:tid 232] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 11:26:02.870439 2012] [mpm_winnt:notice] [pid 272:tid 232] AH00354: Child: Starting 150 worker threads.
[Wed Dec 26 12:52:17.858101 2012] [mpm_winnt:notice] [pid 1504:tid 332] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Dec 26 12:52:19.886105 2012] [mpm_winnt:notice] [pid 272:tid 232] AH00364: Child: All worker threads have exited.
[Wed Dec 26 12:52:19.901705 2012] [mpm_winnt:notice] [pid 1504:tid 332] AH00430: Parent: Child process exited successfully.
[Wed Dec 26 12:53:08.057639 2012] [ssl:warn] [pid 1516:tid 332] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 12:53:09.492842 2012] [mpm_winnt:notice] [pid 1516:tid 332] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed Dec 26 12:53:09.492842 2012] [mpm_winnt:notice] [pid 1516:tid 332] AH00456: Server built: Aug 18 2012 12:41:37
[Wed Dec 26 12:53:09.492842 2012] [core:notice] [pid 1516:tid 332] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Dec 26 12:53:09.492842 2012] [mpm_winnt:notice] [pid 1516:tid 332] AH00418: Parent: Created child process 364
[Wed Dec 26 12:53:11.271245 2012] [ssl:warn] [pid 364:tid 232] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 12:53:11.286845 2012] [mpm_winnt:notice] [pid 364:tid 232] AH00354: Child: Starting 150 worker threads.
[Wed Dec 26 13:05:26.703151 2012] [mpm_winnt:notice] [pid 1516:tid 332] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Wed Dec 26 13:05:28.731155 2012] [mpm_winnt:notice] [pid 364:tid 232] AH00364: Child: All worker threads have exited.
[Wed Dec 26 13:05:28.746755 2012] [mpm_winnt:notice] [pid 1516:tid 332] AH00430: Parent: Child process exited successfully.
[Wed Dec 26 14:56:00.684837 2012] [ssl:warn] [pid 1516:tid 332] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 14:56:01.293238 2012] [mpm_winnt:notice] [pid 1516:tid 332] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Wed Dec 26 14:56:01.293238 2012] [mpm_winnt:notice] [pid 1516:tid 332] AH00456: Server built: Aug 18 2012 12:41:37
[Wed Dec 26 14:56:01.293238 2012] [core:notice] [pid 1516:tid 332] AH00094: Command line: 'C:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Wed Dec 26 14:56:01.293238 2012] [mpm_winnt:notice] [pid 1516:tid 332] AH00418: Parent: Created child process 396
[Wed Dec 26 14:56:03.243241 2012] [ssl:warn] [pid 396:tid 232] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Dec 26 14:56:03.258841 2012] [mpm_winnt:notice] [pid 396:tid 232] AH00354: Child: Starting 150 worker threads.
Reange
 
Posts: 5
Joined: 26. December 2012 01:23
XAMPP Version: 5.6.3
Operating System: Windows 7 (32-Bit)

Re: PHP_GD2 mit XAMPP 1.8.1

Postby Altrea » 26. December 2012 17:28

Hallo Reange,

Reange wrote:Allerdings wird php_gd (und andere extensions wie z.B. curl) trotzdem nicht geladen!

Woran siehst du denn, dass die Extension nicht geladen wird?
Wird sie in phpinfo() nicht angezeigt, oder sagt dir deine Anwendung, dass sie nicht installiert ist?

Denn im log selbst sehe ich keinen Eintrag zu GD2.
Und in meiner XAMPP 1.8.1 Testinstallation wird sowohl GD2 als auch cURL fehlerfrei eingebunden.

Als Microsoft Visual C++ Runtimes sollten übrigens sowohl Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) für PHP als auch Microsoft Visual C++ 2010 SP1 Redistributable Package (x86) für Apache installiert sein (wichtig, dass es die x86 Versionen sind, auch wenn man ein x64 Betriebssystem hat).

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6946
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: PHP_GD2 mit XAMPP 1.8.1

Postby Reange » 26. December 2012 18:56

Als Microsoft Visual C++ Runtimes sollten übrigens sowohl Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) für PHP als auch Microsoft Visual C++ 2010 SP1 Redistributable Package (x86) für Apache installiert sein (wichtig, dass es die x86 Versionen sind, auch wenn man ein x64 Betriebssystem hat).

Sind beide vorhanden, läuft aber leider trotzdem nicht! (32-Bit-System)

Wird sie in phpinfo() nicht angezeigt, oder sagt dir deine Anwendung, dass sie nicht installiert ist?

Zum Einen wird GD nicht in phpinfo angezeigt, zum Anderen bekomme ich beim Aufruf ein GD-Funktion den Fehler
Code: Select all
Fatal error: Call to undefined function ImageCreate() in
Reange
 
Posts: 5
Joined: 26. December 2012 01:23
XAMPP Version: 5.6.3
Operating System: Windows 7 (32-Bit)

Re: PHP_GD2 mit XAMPP 1.8.1

Postby Nobbie » 27. December 2012 12:15

Kann es sein, dass Du eine "falsche" php.ini bearbeitest? Das ist ein sehr beliebter und heimtückischer Fehler. Überprüfe erst mal genau (mit phpinfo()), ob die php.ini auch wirklich die ist, welche PHP dann benutzt.
Nobbie
 
Posts: 7147
Joined: 09. March 2008 13:04

Re: PHP_GD2 mit XAMPP 1.8.1

Postby Reange » 27. December 2012 13:42

Hallo,

allen nochmals vielen Dank für die Hilfe!

Kann es sein, dass Du eine "falsche" php.ini bearbeitest?
Das war einer der wenigen Lösungsvorschläge, die ich durch eine Google-Suche bereits vor meiner Anfrage hier bekommen habe. Somit habe ich darauf geachte, ich kann den Fehler also ausschließen!

Ich habe XAMPP gerade de- und wieder neu installiert und jetzt läuft PHP_GD! :D
Leider weiß ich immer noch nicht, wo der Fehler lag, aber mein Problem ist gelöst.

Reange
Reange
 
Posts: 5
Joined: 26. December 2012 01:23
XAMPP Version: 5.6.3
Operating System: Windows 7 (32-Bit)


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 10 guests

cron