Upgraded to v.1.8.1 and Privileges tab missing in phpMyAdmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Upgraded to v.1.8.1 and Privileges tab missing in phpMyAdmin

Postby luismartin » 28. November 2012 15:22

I've just upgraded Xampp from 1.7 to 1.8.1. Well, I've followed these steps I saw somewhere:

1- Exported old databases with phpMyAdmin,
2- Renamed /xampp to /xampp_old
3- Installed new xampp in /xampp
4- Imported old databases (I managed to do it with MySQL Administrator because phpMyAdmin failed this time due to collisions with default databases on new installation, and I couldn't drop any of these databases from phpmyadmin).

Finally this is how I've configured config.inc.php in /xampp/phpmyadmin/

Code: Select all
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
$cfg['Lang'] = '';


Despite being root with no password, I can't manage users through the phpmyadmin GUI. I had to do it directly in the mysql>user table.

Any help to enable this tab would be appreciated.
luismartin
 
Posts: 14
Joined: 10. September 2011 10:05

Re: Upgraded to v.1.8.1 and Privileges tab missing in phpMyA

Postby hackattack142 » 28. November 2012 15:46

Simply go to the Users tab when you open PHPMyAdmin. There is not a privileges tab in the newer version on the main screen.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Upgraded to v.1.8.1 and Privileges tab missing in phpMyA

Postby luismartin » 28. November 2012 16:44

There is no Users tab either.
luismartin
 
Posts: 14
Joined: 10. September 2011 10:05

Re: Upgraded to v.1.8.1 and Privileges tab missing in phpMyA

Postby hackattack142 » 29. November 2012 01:25

Hmm, here are my next suggestions:
1. Try a different browser. I have seen people report issues with the Users tab missing while using Chrome
2. Make sure you are on the phpMyAdmin home (don't have any databases selected)
3. If you imported old server tables (information_schema, mysql, performance_schema, phpmyadmin) over new ones, that could potentially cause issues if the old version was significantly older and the table structure was different.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Upgraded to v.1.8.1 and Privileges tab missing in phpMyA

Postby luismartin » 18. December 2012 13:02

Excuse the delay. I was temporarily using "root" with no password. I tried using Firefox and the Users tab appeared. It's just as you said, an issue with Chrome. I guess it's up to the phpMyAdmin programmers to get this issue fixed.

Thanks a lot for your help! By the way, great new graphic interface you made! :)
luismartin
 
Posts: 14
Joined: 10. September 2011 10:05


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests