My XAMPP use alot ports. Crash after a while.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

My XAMPP use alot ports. Crash after a while.

Postby kjetim » 29. November 2012 19:03

Hi

I an using a Windows XP SP3 Corp. Edition.
Have installed XAMPP 1.8.1.
My computer:
Acer Aspire Revo R3700
- Intel Atom D525 CPU (dual core, 1.8GHz)
- 4GB DDR3-SDRAM Dual Channel RAM
- 320GB SATA HDD 7200 RPM Hard Drive

My problem is that XAMPP use alot of ports. Get high CPU load. Sometime I got 150 similar connections and then XAMPP "crash" and restarts.
I am running 4 websites. All with Wordpress. The windows Host file is empty. Edit php.ini with more load time and more memory. See more info bellow.
Have no Skype. Edited the port on Teamviewer.

If someone know why I have so many ports connected I would be happy!!
It should only be port 80, or??


Ports in use:
Image
Big view: http://bildr.no/image/1330554.jpeg

Image
Big view: http://bildr.no/image/1330563.jpeg

httpd-ssl.conf
#Listen 0.0.0.0:443
#Listen [::]:443
Listen 443

<VirtualHost _default_:443>
# General setup for the virtual host
DocumentRoot "C:/xampp/htdocs"
ServerName localhost:443

httpd.conf
#Listen 0.0.0.0:80
#Listen [::]:80
Listen 80

ServerName localhost:80


Setting on my router:
Image
Big view: http://bildr.no/image/1330571.jpeg


HOST file in windows folder is empty.
kjetim
 
Posts: 1
Joined: 29. November 2012 18:28
XAMPP Version: 5.6.3
Operating System: Windows XP SP3

Re: My XAMPP use alot ports. Crash after a while.

Postby hackattack142 » 03. December 2012 05:28

Apache only listens for connections on port 80 and does not process connections on that port. When a new request is received, it opens a new port to handle that connection.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: My XAMPP use alot ports. Crash after a while.

Postby andyjh122 » 13. December 2012 16:49

I have this same problem. Tried everything to solve. It's not my webapps...
andyjh122
 
Posts: 8
Joined: 25. September 2012 21:24
XAMPP Version: 5.6.3
Operating System: win2k3

Re: My XAMPP use alot ports. Crash after a while.

Postby andyjh122 » 13. December 2012 22:11

I can post similar screen shots using TCPView.

It looks like there are multiple connections with the same remote port being opened.

They get into a timed_wait or closed_wait state and never close.

Then the server stops responding to subsequent requests. It doesn't crash since if you close those connections it will respond again.

Getting to the point of crashing/not accepting new connections happens with varying intervals from a fresh restart of the server.

Could be 2 days, could be 2 hours.

This didn't happen in Apache 2.2, and I'm using the same web apps from then...
andyjh122
 
Posts: 8
Joined: 25. September 2012 21:24
XAMPP Version: 5.6.3
Operating System: win2k3

Re: My XAMPP use alot ports. Crash after a while.

Postby andyjh122 » 13. December 2012 22:13

Also, looks like it's walking up the ports instead of using an already open port...

Maybe it's Ajax related?
andyjh122
 
Posts: 8
Joined: 25. September 2012 21:24
XAMPP Version: 5.6.3
Operating System: win2k3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests