Installing vqmod on localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Installing vqmod on localhost

Postby rbwater » 07. December 2012 03:50

Hope someone can help with a problem I'm having. I have installed XAMPP & successfully have OpenCart eCommerce software running on it (after a few retries). However, when I tried to install vqmod, I repeatedly get "Server Error 500." I followed the process described in several YouTube videos & everything was successful until running the install command {http://localhost/xampp/opencart/vqmod/install/}. The final line of the error log was:

[Thu Dec 06 20:55:00.297148 2012] [core:alert] [pid 12148:tid 1740] [client ::1:54271] C:/xampp/htdocs/xampp/OpenCart/vqmod/.htaccess: Options not allowed here

I have lots of experience with computers, programming, etc. but am new to Apache, php, etc. Does this give any clue as to why this problem occurred & how to fix it. Thanks.

RB
rbwater
 
Posts: 5
Joined: 07. December 2012 03:14
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Installing vqmod on localhost

Postby Altrea » 07. December 2012 07:23

Hi rbwater (there is ALWAYS time for a short salutation, especially if you are asking for help on a community board. Thats a matter of politeness),

rbwater wrote:http://localhost/xampp/opencart/vqmod/install/}. The final line of the error log was:

[Thu Dec 06 20:55:00.297148 2012] [core:alert] [pid 12148:tid 1740] [client ::1:54271] C:/xampp/htdocs/xampp/OpenCart/vqmod/.htaccess: Options not allowed here

Don't install any applications in the \xampp\htdocs\xampp\ folder but directly in \xampp\htdocs\ please.
The xampp folder inside htdocs is just for the xampp related orange administration page and configurated in a special way.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6545
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Installing vqmod on localhost

Postby rbwater » 07. December 2012 07:59

Hello Altrea,

Apologies for lack of salutation. I was a bit "mind boggled" after many hours of searching fora (plural of forum I hope) and rather poor documentation associated with OpenCart. Thanks for your response. I must have misunderstood the tutorial I was following on how/where to install applications on Xampp. I will move files & reinstall & hope all will be resolved.

Regards,

RB
rbwater
 
Posts: 5
Joined: 07. December 2012 03:14
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Installing vqmod on localhost

Postby rbwater » 07. December 2012 17:12

Hello Again,

I checked the tutorial I was following at this link: http://www.oscommerce-template-easy.com/oscommerce-build-up-development-server-local-computer/03-document-root-of-xampp-server/03-document-root-of-xampp-server.html (actually for osCommerce app not OpenCart but same process). It does recommend installing app in \xampp\htdocs\xampp\ folder. I guess more users than me must have been mislead.

Thx again for your help.

RB
rbwater
 
Posts: 5
Joined: 07. December 2012 03:14
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Installing vqmod on localhost

Postby Altrea » 08. December 2012 01:44

I can't recommend that tutorial for at minimum three reasons:
  • wrong document root directory (said already)
  • starting and using a FTP server on the local machine is absolutely useless and a security issue too if not properly configurated
  • giving global permissions to the database user is a security issue
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6545
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Installing vqmod on localhost

Postby rbwater » 12. December 2012 20:04

Altrea,

Thx. again for your help. To close the loop, I can report that when I reinstalled Opencart in the proper directory & added vqmod as per its installation instructions everything worked properly.

As for the tutorial, I guess you can't believe everything you find on the Internet :roll: !!!!!!!!! Too bad for the beginner that gets sent down the garden path.

RB
rbwater
 
Posts: 5
Joined: 07. December 2012 03:14
XAMPP Version: 5.6.3
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 79 guests