FTP connects but comes up blank

Problems with the Linux version of XAMPP, questions, comments, and anything related.

FTP connects but comes up blank

Postby BinaryClash » 07. December 2012 10:08

I got XAMPP running but when I log into it via FTP, there isn't any directories or anything, plus I cant upload any files. I tried another FTP client and got the same results.
Do I have to set up the FTP account with any specific settings or directories before using it?
because I don't know what the problem could be. I'm running XAMPP on Fedora with ports 21, 80, 8080 open. anything I'm missing?
Also, after it connects to my XAMPP set up, all that happens in my FTP client is that I get the message "Connection timed out. Failed to retrieve directory listing"
So I guess it might be an issue of it not getting the directories after it connects.

edit: also what is the default MySQL username and password I should put into my PHP files when connecting to MySQL? (and where do I find this info cause I'm having a hard time locating info to use XAMPP resources even though it all doesnt really have passwords) My FTP info is correct though.

update: I fixed it

the solution is to add the following line (under port) to proftpd.conf in /opt/lampp/etc

# 'proftpd.conf' for actual use. It establishes a single server
# and a single anonymous login. It assumes that you have a user/group
# "nobody" and "ftp" for normal operation and anon.

ServerName "ProFTPD"
ServerType standalone
DefaultServer on

# Port 21 is the standard FTP port.
Port 21
PassivePorts 30000 30001
# Umask 022 is a good standard umask to prevent new dirs and files
# from being group and world writable.

Then open ports 30000 and 30001 in your linux firewall. (I'm using Fedora on XFCE in this case)

I still cant find the proper guide with the default information to put in the MySQL database or FTP. I really wish they made this product easier to use since it's suppose to ease development. I'm happy though and at least I got the whole thing up and running now. May have to toy with MySQL some more to see how it works.
Posts: 1
Joined: 07. December 2012 10:01
XAMPP Version: 5.6.3
Operating System: Linux

Re: FTP connects but comes up blank

Postby JonB » 09. December 2012 06:08

I hate to tell you this BUT: (as they say)

YOU (as the 'developer') will need to create the appropriate MySQL users for your needs. You can use the MySQL CLI, phpMyAdmin or MySQL Workbench to do that. Users are created in the 'mysql/user' database/table.
You should not access/use MySQL in applications as the 'root' account. The 'pma' user that is already created is a special user for phpMyAdmin. If you are creating only for development, you may want to restrict the MySQL users you create to 'localhost' - you can always change that.

ALL fresh MySQL installations have the 'root' user set with a NULL(blank) password. (think about it)

There's a Security Page in XAMPP to help you with this,

There's a link there to call to set passwords -
/opt/lampp/lampp security

I'm not sure why you had to add the PassivePorts - I have many lampp/Linux installs and I have not run into that (nor have I answered that question) - I will have to do some tests.

(Edit - just checked 2 machines)
I have no problem connecting in passive mode with the default setting of Port 21. So we have an odd one.

Good Luck.
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests