xampp keeps crashing [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp keeps crashing [Solved]

Postby av6330 » 02. December 2012 18:54

xampp keeps crashing, windows 7

it's not skype, i unchecked the "use port 80 as an alternative." i even changed the port in xampp to listen:8888, that is port 8888.

i am not using IIS= internet information services.

now i open xampp,

then i try to start mysql and its fine, then when i try to start apache, it always crashes then says,

system error. code 5. access is denied.

access violation at address 005A in module "xampp-control.exe" read of address 00000042 access violation at address 005A in module "xampp-control.exe" read of address 00000042
av6330
 
Posts: 1
Joined: 02. December 2012 13:39
XAMPP Version: 1.7
Operating System: windows 7

Re: xampp keeps crashing

Postby hackattack142 » 03. December 2012 05:37

Are you running the control panel as admin?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: xampp keeps crashing

Postby frizi » 09. December 2012 19:12

Hi, working on Win 8 64 bit, the Skype used the same 80 port so there was an apache conflict as I try to stop and start the apache service. Later I've try to change the ports to 81, 444 and 3307 which caused a memory load failure ( xampp access violation at address 005abefe ).

Quitting Skype and reset the ports to the original ones: 80 apache, 443 ssl, 3306 Mysql solved my problems.
frizi
 
Posts: 1
Joined: 09. December 2012 18:54
XAMPP Version: 5.6.3
Operating System: Windows 8 64b

Re: xampp keeps crashing [Solved]

Postby djferano » 29. March 2013 21:26

Hi Guys,

I have had the same problems.
Turned out I had to change httpd.conf and httpd-ssl.conf:

httpd-ssl:
I commented Listen 443 and changed #Listen 0.0.0.0:443 to 127.0.0.1:443
#
# Note: Configurations that use IPv6 but not IPv4-mapped addresses need two
# Listen directives: "Listen [::]:443" and "Listen 0.0.0.0:443"
#
Listen 127.0.0.1:443
#Listen [::]:443
#Listen 443


httpd:
I commented Listen 80 and changed #Listen 0.0.0.0:80 to 127.0.0.1:80
# Change this to Listen on specific IP addresses as shown below to
# prevent Apache from glomming onto all bound IP addresses.
#
Listen 127.0.0.1:80
#Listen [::]:80
#Listen 80

Also if you have skype, disable it or uncheck use port 80 and 443 as alternative...
djferano
 
Posts: 1
Joined: 29. March 2013 21:20
XAMPP Version: 5.6.3
Operating System: Windows 7 x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests