XAMPP-Admin-Oberfläche trotz VHost

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP-Admin-Oberfläche trotz VHost

Postby Amasit » 09. November 2012 00:09

Habe XAMPP 1.8.1. Danke für die hilfreichen Tipps. Habe damit im httpd-vhosts.config folgendes konfiguriert:
Code: Select all
NameVirtualHost *:80

### Default vHost
<VirtualHost *:80>
    DocumentRoot "D:/webstage"
    ServerName localhost
    <Directory "D:/webstage">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Require all granted
    </Directory>
</VirtualHost>


Gebe ich im Browser nun "localhost" ein, erhalte ich wunschgemäss einen Index mit allen Webprojekten, deren Root-Folder im Verzeichnis "D:/webstage" liegen.

Was ich nun aber verloren habe ist die XAMPP-Admin-Oberfläche wenn ich "localhost/xampp" eingebe. Die Daten dazu liegen bei mir unter C:/xampp/htdocs/xampp

Wie ist es möglich trotz vHosts auch auf die XAMPP-Admin zu gelangen?
Amasit
 
Posts: 2
Joined: 08. November 2012 23:54
XAMPP Version: 5.6.3
Operating System: Windows7

Re: XAMPP-Admin-Oberfläche trotz VHost

Postby Altrea » 09. November 2012 05:35

Hallo Amasit,

Ich habe dein Thema vom Ursprungsthread abgetrennt, da deine Beschreibung mit dem Problem des anderen Threads in keinem Zusammenhang steht.
Weiterhin verfolgen wir hier eine "ein Thread pro Problem und User" philosophie, um das suchen und finden von Lösungen und Lösungswegen so einfach wie möglich zu gestalten.

Nun zu deinem Problem:
Wenn du virtual Hosts einsetzt solltest du natürlich alle Ressourcen darüber umsetzen und nicht nur eine.
So hast du nun der XAMPP Administration Page das Dokumentenwurzelverzeichnis entzogen und derzeit keine Möglichkeit diese Seite im Browser zu adressieren.

Eine Mögliche Lösung wäre es also, einen eigenen VHost für XAMPP/Default anzulegen und den anderen für deine Seite.
Das ganze könnte dann so aussehen:

Code: Select all
NameVirtualHost *:80

### Default vHost
<VirtualHost *:80>
    DocumentRoot "C:/xampp/htdocs"
    ServerName localhost
</VirtualHost>

### webstage vHost
<VirtualHost *:80>
    DocumentRoot "D:/webstage"
    ServerName webstage
    <Directory "D:/webstage">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Require all granted
    </Directory>
</VirtualHost>


Danach musst du den DomainName webstage nurnoch in deiner C:\Windows\system32\drivers\etc\HOSTS Datei auf IP 127.0.0.1 routen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6829
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: XAMPP-Admin-Oberfläche trotz VHost

Postby Amasit » 11. November 2012 14:39

Vielen Dank für das Verschieben. Hat jetzt geklappt. Hatte den gleichen Ansatz, aber mit dem Fehler, dass ich bei beiden vHosts denselben Namen (localhost) drin hatte.
Grüsse, Amasit
Amasit
 
Posts: 2
Joined: 08. November 2012 23:54
XAMPP Version: 5.6.3
Operating System: Windows7


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests