Apache funktioniert, aber nicht als Dienst

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache funktioniert, aber nicht als Dienst

Postby buhr » 07. November 2012 14:43

Hallo,
ich habe XAMPP installiert und Apache lässt sich mit dem Control Panel starten und funktioniert einwandfrei.
Wenn ich Apache aber als Dienst installiere und dann starten will funktionierts nicht.
An was könnte das liegen?
(Skype hab ich nicht)
Im Event Viewer steht was davon, dass make_bind nicht erfolgreich war.
An der Konfigdatei habe ich nichts verändert.
Gruß
Bernhard
buhr
 
Posts: 2
Joined: 07. November 2012 14:37
XAMPP Version: 5.6.3
Operating System: Windows XP

Re: Apache funktioniert, aber nicht als Dienst

Postby Altrea » 07. November 2012 15:52

Hallo Bernhard,

Schau dir bitte einmal im Windows Dienste Dialog den Apache2 Dienst an, genau genommen die Information die bei "Pfad zur EXE Datei:" steht.
Sollte dort nicht der richtige Pfad, oder der Laufwerksbuchstabe am Anfang fehlen, deinstalliere den Dienst bitte wieder, führe einmal die \xampp\setup_xampp.bat Datei aus, um die Pfade geradezuziehen und registriere den Dienst dann erneut.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6830
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: Windows 10 Pro x64

Re: Apache funktioniert, aber nicht als Dienst

Postby buhr » 08. November 2012 08:28

Hallo Altrea,
ich habs mal nachgeschaut. Das müsste eigentlich passen. Im Dienst steht:
"c:\xampp\apache\bin\httpd.exe" -k runservice
und der tatsächliche Pfad ist:
C:\xampp\apache\bin\httpd.exe

Das zeigt mir das Control Panel an:
07:20:23 [Apache] Statusänderung erkannt: gestartet
07:20:34 [Apache] Statusänderung erkannt: gestoppt
07:20:34 [Apache] Fehler: Apache wurde unerwartet beendet.
07:20:34 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
07:20:34 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
07:20:34 [Apache] Überprüfe die Datei "/xampp/apache/logs/error.log"
07:20:34 [Apache] und die Windows Ereignisanzeige für weitere Hinweise

Das steht in der error.log
[Thu Nov 08 07:23:50.281250 2012] [core:warn] [pid 1264:tid 280] AH00098: pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Thu Nov 08 07:23:50.859375 2012] [ssl:warn] [pid 1264:tid 280] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Nov 08 07:23:51.406250 2012] [mpm_winnt:notice] [pid 1264:tid 280] AH00455: Apache/2.4.3 (Win32) OpenSSL/1.0.1c PHP/5.4.7 configured -- resuming normal operations
[Thu Nov 08 07:23:51.406250 2012] [mpm_winnt:notice] [pid 1264:tid 280] AH00456: Server built: Aug 18 2012 12:41:37
[Thu Nov 08 07:23:51.406250 2012] [core:notice] [pid 1264:tid 280] AH00094: Command line: 'c:\\xampp\\apache\\bin\\httpd.exe -d C:/xampp/apache'
[Thu Nov 08 07:23:51.421875 2012] [mpm_winnt:notice] [pid 1264:tid 280] AH00418: Parent: Created child process 3892
[Thu Nov 08 07:23:54.109375 2012] [mpm_winnt:crit] [pid 1264:tid 280] AH00419: master_main: create child process failed. Exiting.

Hilft das? Was ist denn das Session Cache? Kann das was damit zu tun haben?
buhr
 
Posts: 2
Joined: 07. November 2012 14:37
XAMPP Version: 5.6.3
Operating System: Windows XP


Return to XAMPP für Windows

Who is online

Users browsing this forum: Nobbie and 8 guests