PHPMyAdmin enable ONLY localhost access

Problems with the Linux version of XAMPP, questions, comments, and anything related.

PHPMyAdmin enable ONLY localhost access

Postby igorpan » 03. November 2012 09:38

Hello! After xampp installation on fedora 17 i had a very common problem: i couldn't access phpmyadmin and was getting access forbidden message. I *fixed* it by adding "Require all granted" line to <Directory> tag in /opt/lampp/etc/extra/httpd-xampp.config. Now I can access it, but the problem is: anybody can. Even when I type in my_ip_address/phpmyadmin phpmyadmin opens.

It looks like this part doesn't function at all?

Code: Select all
#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
   Order deny,allow
   Deny from all
   Allow from all ::1 127.0.0.0/8 \
      fc00::/7 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 \
      fe80::/10 169.254.0.0/16

   ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>
igorpan
 
Posts: 2
Joined: 03. November 2012 09:29
XAMPP Version: 5.6.3
Operating System: Fedora 17

Re: PHPMyAdmin enable ONLY localhost access

Postby igorpan » 04. November 2012 15:39

After 2 days of searching, I found a solution on this very forum in German part.

Had to change XAMPP security concept to this:

http://community.apachefriends.org/f/viewtopic.php?f=3&t=50969

Now it works perfectly, I can open phpmyadmin from localhost but its inaccessible from outside my local network :)
igorpan
 
Posts: 2
Joined: 03. November 2012 09:29
XAMPP Version: 5.6.3
Operating System: Fedora 17


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests