XAMPP v3.0.12

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP v3.0.12

Postby Wasley » 01. November 2012 18:24

Hi all,

Trying to install XAMPP for a friend. For some reason, it isn't allowing me to load MySQL. I was having troubles launching Apache so a simple uninstall and downgrade to version 1.8.0 (I think), solved the issue.

17:25:30 [mysql] Starting mysql app...
17:25:31 [mysql] Status change detected: running
17:25:32 [mysql] Status change detected: stopped

Error log for MySQL:
http://pastebin.com/est9VKiH

Any ideas?

Cheers
Wasley
 
Posts: 6
Joined: 09. July 2012 21:57
XAMPP Version: 5.6.3
Operating System: Windows

Re: XAMPP v3.0.12

Postby Altrea » 01. November 2012 19:22

Hi Wasley,

first: v3.0.12 is just the version number of the XAMPP control panel.
The correct version information for the XAMPP package can be found in the readme file which is located in your xampp directory.

121101 17:11:20 [ERROR] Fatal error: Can't open and lock privilege tables: Can't find file: 'host' (errno: 2)

This is the issue.
This is a 0 Byte file MySQL needs to found.
Very common this happens if you are choosing the .7z version of XAMPP and you are using an extractor which don't extract these 0 Byte files.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6755
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: XAMPP v3.0.12

Postby Wasley » 01. November 2012 20:37

Altrea,

Thanks for the quick reply. I used the .exe file on sourceforge. How do I work around this? Will i need to re-download?
Wasley
 
Posts: 6
Joined: 09. July 2012 21:57
XAMPP Version: 5.6.3
Operating System: Windows

Re: XAMPP v3.0.12

Postby Wasley » 01. November 2012 21:42

Quick update.

Re-installed xampp and running on a slightly older version. MySQL now working, but Apache isn't.

I've changed the port from 80 to 1223 but every time I try and "start" Apache on xampp, it trys launching it on port 80?

I edited httpd.conf

EDIT - I'm slowly getting some where. As stated above, I've edited the httpd.conf file to port 1223 and I've also edited the file XAMPP.INI to the said port and placed it into the root directory.

XAMPP shows that it's trying to start of 1223 but is declared "busy" when the start button is pushed.

EDIT 2 - Problem Solved.

# Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf

change to this by adding the comment character:
# Secure (SSL/TLS) connections
# Include conf/extra/httpd-ssl.conf
:mrgreen:
Wasley
 
Posts: 6
Joined: 09. July 2012 21:57
XAMPP Version: 5.6.3
Operating System: Windows

Re: XAMPP v3.0.12

Postby viswaprabha » 22. November 2012 08:20

EDIT 2 - Problem Solved.

# Secure (SSL/TLS) connections
Include conf/extra/httpd-ssl.conf

change to this by adding the comment character:
# Secure (SSL/TLS) connections
# Include conf/extra/httpd-ssl.conf


That really helped! I had a smooth installation running on my local PC which suddenly started refusing to start Apache after I upgraded to the new XAMPP version. Spent quite some time to figure out why Apache wouldn't start.

With the above line disabled, the problem went away!

Thank you!
viswaprabha
 
Posts: 1
Joined: 22. November 2012 08:14
XAMPP Version: 5.6.3
Operating System: Windows 7 32 Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests