MozRepl installation errors on opensuse 12.2 - with mozilla

Einfach Dinge, die nichts mit XAMPP, Apache Friends, Apache, MySQL, PHP und alle dem zu tun haben. Allerlei halt. ;)

MozRepl installation errors on opensuse 12.2 - with mozilla

Postby unleash » 30. October 2012 20:18

gentlemen,

I want to install mozrepl on OpenSUSE version 12.2. It gets pretty tricky - note Mozrepl is a additional part that is needed by the WWW::Mechanize::Firefox::
I had a bunch of troubles with mozRepl - and I tried to follow the first 3-4 steps from CPAN. I tried to install it with zypper in or with the repo: https://github.com/bard/mozrepl.github

See many good links and ressources regarding Mechanize - Firefox - Troubleshooting https://duckduckgo.com/html/?q=mozrepl https://github.com/bard/mozrepl.github

see the issues that were reported:

https://addons.mozilla.org/en-US/firefox/addon/mozrepl/


note: does the firefox version 16.01 on opensuse 12.2 cause any issues

note: mozrepl is listening on port 4242

note: see the testscript:
Code: Select all

  use WWW::Mechanize::Firefox;
  my $mech = WWW::Mechanize::Firefox->new(
      tab => 'current',
  );
  $mech->get('http://google.com',
      ':content_file' => 'google_com.html' );

and the issues


Code: Select all
martin@linux-wyee:~/perl> perl moz_test3.pl
Can't locate WWW/Mechanize/Firefox.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.16.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.16.0 /usr/lib/perl5/vendor_perl/5.16.0/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.16.0 /usr/lib/perl5/5.16.0/i586-linux-thread-multi /usr/lib/perl5/5.16.0 /usr/lib/perl5/site_perl/5.16.0/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.16.0 /usr/lib/perl5/site_perl .) at moz_test3.pl line 1.
BEGIN failed--compilation aborted at moz_test3.pl line 1.
martin@linux-wyee:~/perl>

what can i do now!?

look forward to hear from you

greetings
unleash
 
Posts: 132
Joined: 03. December 2011 10:16
XAMPP Version: 5.6.3
Operating System: OpenSuse Linux 12.1

Return to Allerlei

Who is online

Users browsing this forum: No registered users and 3 guests