Win 8 Pro belegt Port 80

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Win 8 Pro belegt Port 80

Postby Tofu-san » 30. October 2012 13:18

Hallo Miteinander

Ich habe, da so günstig und ich nicht die Finger davon lassen konnte Windows Pro 64 Bit update installiert. Bei der gelegenheit habe ich auch die Neuste Version von Xampp (xampp-win32-1.8.1-VC9-installer) installiert auf eine extra Partition.

Jedes Mal wenn ich xampp starte kommt die Meldung: Port 80 in Benutzung von "system"!
Ich habe recherchiert und herausgefunden das ein wohl dieser Dienst schult sei das Port 80 beim start beansprucht: Web Deployment Agent Service

In der Deutschen Version gibt es aber kein Dienst der so heißt und habe mal einfach folgenden Dienst beendet: WWW-Publishingdienst
Danach kann man ohne Probleme Xampp starten und den dienst wieder starten.

Ist es der Smart –Screen eventuell oder die Apps die sich andauernd aktualisieren wollen schuld?
Den Cloud Dienst ist bei übrigens mir off, also diese Synchronisationsgeschichte.
Skype sowohl als App als auch als Desktop Anwendung ist jedenfalls nicht die Ursache.

Hat jemand eine Idee wie man das fixen kann? Liege ich damit eventuell völlig falsch?
Für Vorschläge, Erfahrungen oder Vorgehensweise sind willkommen.
Tofu-san
 
Posts: 6
Joined: 06. November 2009 16:40
XAMPP Version: 5.6.3
Operating System: Windows 8 Pro 64Bit

Re: Win 8 Pro belegt Port 80

Postby Altrea » 30. October 2012 15:38

Hallo Tofu-San,

Der WWW-Publishingdienst ist eine Unterkomponente des IIS, also eine Webserverkomponente von Microsoft.
Sofern du diesen nicht benötigst, kannst du ihn (sofern bei Windows 8 möglich) unter den Windows Komponenten entfernen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6749
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Win 8 Pro belegt Port 80

Postby Tofu-san » 31. October 2012 08:37

Hallo Altrea

Ich habe mir schon fast gedacht das der IIS was damit zu tun hat. Ich habe ehrlich gesagt keine Ahnung ob ich es brauche oder nicht. Auf IIS kann ich verzichten aber kann das auch das Betriebssystem Windows 8 Pro? Unter „Windows-Features aktivieren oder deaktivieren“ sind WWW-Dienste in dem Anwendungsentwicklungsfeature aktiv und zwar ".NET-Erweiterbarkeit 4.5" sowie unter Sicherheit die "Anforderungsfilterung".

Eine alternative Idee die ich aber nicht weiß wie man so was umsetzt wäre dem Control Panel von Xampp einfach vor Start von Apache automatisch den "WWW-Dienste "Dienst zu deaktivieren und danach direkt wieder zu aktivieren. Wäre doch eine Alternative da ich nicht einschätzten kann was, welche App oder sonstige Einstellungen davon abhängen.

mit freundlichen Grüßen,

Tofu-San
Tofu-san
 
Posts: 6
Joined: 06. November 2009 16:40
XAMPP Version: 5.6.3
Operating System: Windows 8 Pro 64Bit

Re: Win 8 Pro belegt Port 80

Postby Tofu-san » 31. October 2012 10:30

… Nachtrag


Ich habe herausgefunden dass wen ich das so mache wie oben beschrieben, ändert Xampp automatisch den Port. Kann man das den nicht immer auf einen anderen Port laufen lassen ohne in der URL auch noch den Port anzugeben?
Tofu-san
 
Posts: 6
Joined: 06. November 2009 16:40
XAMPP Version: 5.6.3
Operating System: Windows 8 Pro 64Bit

Re: Win 8 Pro belegt Port 80

Postby Altrea » 31. October 2012 16:58

Tofu-san wrote:Kann man das den nicht immer auf einen anderen Port laufen lassen ohne in der URL auch noch den Port anzugeben?

Kurz und bündig: Nein.
Ohne Portangabe wird eine Anfrage immer an den Standardport der durch das Protokoll definiert wird geschickt, für HTTP ist das nunmal Port 80 und für HTTPS Port 443. Sobald du von den Standardports abweichst, musst du zwingend den Port in der URL mitgeben.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6749
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Win 8 Pro belegt Port 80

Postby Tofu-san » 31. October 2012 19:09

Hallo Altrea

Ok verstanden. Schade eigentlich. Komisch ist nur das wenn ich den Dienst vorher beende, Apache starte und warte biss es grün geworden ist und danach obwohl Apache an ist diesen Dienst wieder starte, Apache einfach hinget und ein anderen Port nutzt. Komisch

mit freundlichen Grüßen

Tofu-San
Tofu-san
 
Posts: 6
Joined: 06. November 2009 16:40
XAMPP Version: 5.6.3
Operating System: Windows 8 Pro 64Bit


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 11 guests