Solved! - Error: Apache shutdown unexpectedly

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Solved! - Error: Apache shutdown unexpectedly

Postby Hoperin » 21. October 2012 19:04

Hi guys. Maybe you can help me? I'm trying to set up a PHP & mySQL database for a class, and am getting stuck on the fiiirst steeep ugh. I installed XAMPP (1.8, windows 7), deactivated the User Account Control as promtped and tried again, was getting error

1:35:32 PM [Apache] Problem detected!
1:35:32 PM [Apache] Port 443 in use by "vmware-hostd.exe"!
1:35:32 PM [Apache] Apache WILL NOT start without the configured ports free!
1:35:32 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
1:35:32 PM [Apache] or reconfigure Apache to listen on a different port

I use VMWare alot and wasn't going to disable it so I changed the apache port (to port 8080) as per http://lekshmideepu.blogspot.ca/2012/03/how-to-change-apache-port-for-xampp.html

but when I tried to restart Apache I would get: 1:38:03 PM [Apache] Attempting to start Apache app...
with nothing happening btu when I tried to start it again:

1:40:33 PM [Apache] Attempting to start Apache app...
1:40:33 PM [Apache] Status change detected: running
1:40:34 PM [Apache] Status change detected: stopped
1:40:34 PM [Apache] Error: Apache shutdown unexpectedly.
1:40:34 PM [Apache] This may be due to a blocked port, missing dependencies,
1:40:34 PM [Apache] improper privileges, a crash, or a shutdown by another method.
1:40:34 PM [Apache] Check the "/xampp/apache/logs/error.log" file
1:40:34 PM [Apache] and the Windows Event Viewer for more clues

any ideas? I couldn't see any previous solved posts with this problem and I don't have class for 2 weeks so I need to figure this out on my own time...

here is my full control panel log:
1:35:10 PM [main] Initializing Control Panel
1:35:10 PM [main] Windows Version: Windows 7 Home Premium 64-bit
1:35:10 PM [main] XAMPP Version: 1.8.1
1:35:10 PM [main] Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
1:35:10 PM [main] Running with Administrator rights - good!
1:35:10 PM [main] XAMPP Installation Directory: "c:\xampp\"
1:35:10 PM [main] Checking for prerequisites
1:35:32 PM [main] All prerequisites found
1:35:32 PM [main] Initializing Modules
1:35:32 PM [Apache] Problem detected!
1:35:32 PM [Apache] Port 443 in use by "vmware-hostd.exe"!
1:35:32 PM [Apache] Apache WILL NOT start without the configured ports free!
1:35:32 PM [Apache] You need to uninstall/disable/reconfigure the blocking application
1:35:32 PM [Apache] or reconfigure Apache to listen on a different port
1:35:32 PM [main] Starting Check-Timer
1:35:32 PM [main] Control Panel Ready
1:35:55 PM [mysql] Attempting to start MySQL app...
1:36:01 PM [mysql] Status change detected: running
1:38:03 PM [Apache] Attempting to start Apache app...
1:40:33 PM [Apache] Attempting to start Apache app...
1:40:33 PM [Apache] Status change detected: running
1:40:34 PM [Apache] Status change detected: stopped
1:40:34 PM [Apache] Error: Apache shutdown unexpectedly.
1:40:34 PM [Apache] This may be due to a blocked port, missing dependencies,
1:40:34 PM [Apache] improper privileges, a crash, or a shutdown by another method.
1:40:34 PM [Apache] Check the "/xampp/apache/logs/error.log" file
1:40:34 PM [Apache] and the Windows Event Viewer for more clues


(PS I cheched /xampp/apache/logs/ and there was no error.log file, and in Windows Event Viewere there is only "The FileZilla Server FTP server service is marked as an interactive service. However, the system is configured to not allow interactive services. This service may not function properly." ... could this be related?)
Last edited by Hoperin on 22. October 2012 18:22, edited 1 time in total.
Hoperin
 
Posts: 2
Joined: 21. October 2012 18:05
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Fresh Install (1.8) - Error: Apache shutdown unexpectedl

Postby JJ_Tagy » 21. October 2012 19:34

Do you use shared VMware hosts? That is what is using 443. Changing port 80 -> 8080 will not help you. You need to either disable shared hosts on vmware or change the port from 443 -> XXX.
JJ_Tagy
 
Posts: 570
Joined: 30. January 2012 13:44
XAMPP Version: 1.8.3
Operating System: Windows 7 x64

Re: Fresh Install (1.8) - Error: Apache shutdown unexpectedl

Postby Hoperin » 22. October 2012 18:21

Oh, VMware, always causing problems... I'm not quite sure what the impications of shared VMware hosts are but I searched forn xampp+vmware host conflicts and followed a guide to change my Apache SSL ports to 4430 to avoid conflict, everything seems to be working now! Thanks for the speedy help! C:
Hoperin
 
Posts: 2
Joined: 21. October 2012 18:05
XAMPP Version: 5.6.3
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests