[BUG] New PHP, very old PEAR packages

Problems with the Linux version of XAMPP, questions, comments, and anything related.

[BUG] New PHP, very old PEAR packages

Postby matteosistisette » 20. October 2012 17:29

Xampp ships with PHP, and apparently PEAR and some PEAR packages installed.
I think the version of pear packages that is chosen to be packaged, should be at the very least recent enough to be COMPATIBLE with the packaged version of PHP.

I've found out the version of the Mail pear package is dated 2005, and it is unusable with the version of PHP included in Xampp. Trying to call Mail::factory() will cause the error:

Assigning the return value of new by reference is deprecated
at /opt/lampp/lib/php/Mail.php(55)
55 $mailer = &new $class($params);
Posts: 38
Joined: 11. January 2011 12:22
XAMPP Version: 5.6.14
Operating System: Windows 7 64bit; Ubuntu 11.10

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests