Oracle LDAP-Library

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Oracle LDAP-Library

Postby Mors_Invictus » 12. October 2012 14:55

Hi,

we want to use XAMPP for Linux to publish a few simple PHP scripts. The scripts collect data from several Oracle DBs and provide users with a simple overview. Unfortunately we can't get the scripts working. We have activated OCI8 and it seems to be working correctly.

The error message is "httpd: getentry.c:35: ldap_first_entry: Assertion `( (ld)->ld_options.ldo_valid == 0x2 )' failed."
According to a post on bugs.php.net this error is due to Oracle using its own LDAP libraries, so PHP has to be configured with --with-ldap=(same oracle client path as with oci8) for PHP to work with Oracle LDAP. Using a local tnsnames.ora might solve this but is not our favoured solution.

Usually we would just change the option using ./configure --with-ldap=... but I couldn't find the tool, so I suppose it is not part of XAMPP (yes, I am a XAMPP-Noob :P ). Is there any simple way to change the library path for LDAP or will we have to go all the way and build our own LAMPP?
Mors_Invictus
 
Posts: 1
Joined: 12. October 2012 13:21
XAMPP Version: 5.6.3
Operating System: Linux, Windows 2008 R2

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests