Apache Error Version 1.8.1

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Error Version 1.8.1

Postby eddiewalshy » 11. October 2012 11:04

I have just installed Xampp 1.8.1
When I try and run Apache this error shows up
Help please

10:54:19 [Apache] Error: Apache shutdown unexpectedly.
10:54:19 [Apache] This may be due to a blocked port, missing dependencies,
10:54:19 [Apache] improper privileges, a crash, or a shutdown by another method.
10:54:19 [Apache] Check the "/xampp/apache/logs/error.log" file
10:54:19 [Apache] and the Windows Event Viewer for more clues
eddiewalshy
 
Posts: 1
Joined: 11. October 2012 10:59
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Apache Error Version 1.8.1

Postby hackattack142 » 11. October 2012 22:16

Could you post the entire Control Panel log.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 701
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Error Version 1.8.1

Postby garethjmsaunders » 11. October 2012 23:03

I'm getting exactly the same error message; I'm running Windows 7 Professional 32-bit.

I was able to start Apache but the module status in the control panel was yellow not green. I checked if anything else was running on port 80 using netstat -o but nothing was. So I stopped Apache, and then tried to start it again and got that same error saying "session cache is not configured".

I opened httpd.conf and changed the port for Apache from 80 to 8045, and restarted Apache. This time it worked, but again when I bounced it it wouldn't start up again.

I really needed XAMPP on my laptop for a meeting tomorrow, so I've just gone back to XAMPP 1.8.0 which installed perfectly and ran straight away on port 80.

It seems to me that there is definitely a problem with Apache on XAMPP 1.8.1. I'll be happy to help tomorrow night once I've got through the meeting and I can reinstall XAMPP 1.8.1 if you need any more details.
garethjmsaunders
 
Posts: 1
Joined: 11. October 2012 22:57
Location: Scotland, UK
XAMPP Version: 5.6.3
Operating System: Windows 7 Professional

Re: Apache Error Version 1.8.1

Postby florinbulat » 12. October 2012 11:52

eddiewalshy wrote:I have just installed Xampp 1.8.1
When I try and run Apache this error shows up
Help please

10:54:19 [Apache] Error: Apache shutdown unexpectedly.
10:54:19 [Apache] This may be due to a blocked port, missing dependencies,
10:54:19 [Apache] improper privileges, a crash, or a shutdown by another method.
10:54:19 [Apache] Check the "/xampp/apache/logs/error.log" file
10:54:19 [Apache] and the Windows Event Viewer for more clues


I have windows xp sp3 and I received the same messages. Do you fix the problem?
florinbulat
 
Posts: 2
Joined: 12. October 2012 11:47
XAMPP Version: 5.6.3
Operating System: windows xp sp3

Re: Apache Error Version 1.8.1

Postby torvista » 14. October 2012 17:00

I had the same problem and error message on XP Pro. There was no apache error log and nothing in event viewer.
Same error with mysql.
Filezilla started ok.

I had forgot to run the setup_xampp.bat...that fixed the "problems".
Apache was yellow while Windows firewall was blocking it.
torvista
 
Posts: 7
Joined: 27. July 2009 04:15

Re: Apache Error Version 1.8.1

Postby hackattack142 » 14. October 2012 17:40

That error message is just a blanket error message that means something has happened that was unexpected. I cannot offer any reasonable advice without more information about your environment and errors. Posting your Control Panel log will at least give me a start to offering advice and any additional information from Apache error logs or the Windows Event Viewer will also help.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 701
Joined: 20. May 2011 23:29
XAMPP Version: 5.6.3
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache Error Version 1.8.1

Postby florinbulat » 15. October 2012 11:37

You must install Visual C++ 2008 Redistributable Package.
florinbulat
 
Posts: 2
Joined: 12. October 2012 11:47
XAMPP Version: 5.6.3
Operating System: windows xp sp3

Re: Apache Error Version 1.8.1

Postby iamxyz123 » 28. November 2012 10:43

Maybe the <VirtualHost *:80> configurations in file <httpd-vhosts.conf>

After I edited it works fine.
iamxyz123
 
Posts: 1
Joined: 28. November 2012 10:38
XAMPP Version: 5.6.3
Operating System: Windows 7 SP1

Re: Apache Error Version 1.8.1

Postby andresitompul » 30. May 2013 16:15

hi there..

i have found that, changing the listen ip to local loop in the httpd.conf its able to start the apache right away..

#Listen 127.0.0.1:80
#Listen [::]:80
Listen 80

previously the ip is 0.0.0.0:80 (this is make i cant start the appache on xampp 1.8 & windows 7) please change to local loop ip 127.0.0.1

i am not trying to change the port though.. but i found this works for me..
andresitompul
 
Posts: 1
Joined: 30. May 2013 15:54
XAMPP Version: 5.6.3
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests