XAMPP 1.7.3

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP 1.7.3

Postby forgotten » 07. October 2012 17:28

Hi There,

I am new to Ubuntu, I just downloaded the ISO File from Ubuntu.Com and installed it on my machine, it has got Inter Core i7 Processor and a 12 GB RAM with 1TB hard disk, I downloaded the XAMPP 1.8.0 then found out that it does not support 64 bit Ubuntu 12.04 LTS. Now I am downloading XAMPP 1.7.3 from other sources as it would be enough for me for now, So my question is that XAMPP 1.7.3, is it compatible with Ubuntu 12.04 LTS 64 Bit.

Is there any idea with anyone when the xampp 1.8.0 would be available on 64 BIT UBUNTU??

Thank you in advance
forgotten
 
Posts: 2
Joined: 07. October 2012 16:38
Location: Bangladesh
XAMPP Version: 1.8.3-1
Operating System: Ubuntu 12.04 LTS 64 Bit

Re: XAMPP 1.7.3

Postby JonB » 07. October 2012 17:36

Wow - that is a very cool machine

I downloaded the XAMPP 1.8.0 then found out that it does not support 64 bit Ubuntu 12.04 LTS


Where did you get that information?

I think of the misunderstanding there is. I believe XAMPP will run on 64 bit Ubuntu. However, the XAMPP APache is of the 32 bit. ALso is the XAMPP 1.7.3 of the 32 bit.

If the origianl information that XAMPP will not run on Ubuntu 12 bit is correct, then it is news to me.

Good Luck
8)

ysf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: XAMPP 1.7.3

Postby forgotten » 11. October 2012 08:27

Hello,

I am sorry and I mean no offense. But I do not understand what you said, do you mean XAMPP 1.8.0 will run in 64 bit Ubuntu? But I saw so many posts saying XAMPP 1.8.0 is not compatible with Ubuntu 12.04 64bit OS. I tried it myself and it did not work.

Thank you for the compliment of my machine.

Regards.
forgotten
 
Posts: 2
Joined: 07. October 2012 16:38
Location: Bangladesh
XAMPP Version: 1.8.3-1
Operating System: Ubuntu 12.04 LTS 64 Bit

Re: XAMPP 1.7.3

Postby JonB » 12. October 2012 02:05

It (XAMPP) should work on almost all Intel Architecture/AMD 64bit machines running current Linux kernels. Won't run on Itanium.

https://help.ubuntu.com/community/32bit_and_64bit

You do have to make sure the 32bit libc++ is present (its part of the ia32-libs). XAMPP/lampp components are compiled from c++ as 32 bit apps. (the same is true on Windows as well)

sudo apt-get install ia32-libs

if that does not work immediately see this topic -
the how-to questions -

http://ubuntuforums.org/showthread.php? ... &t=2000705
Look for "LeeJunFan" - second post....

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests