SendMail

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

SendMail

Postby vwBanditwv » 26. September 2012 03:53

Moin!
Ich habe noch ein kleines Probelm mit SendMail vom Apache.
Wenn ich Mails aus meinem Kontaktformuar sende, die direkt an mich gerichtet sind, empfange ich die richtig auf meinem Konto bei Web.de
Möchte ich mich nun aber auf meiner Website registrieren und gebe eine Mail Adresse an, wird dort keine Bestätiungsmail/Aktievierungsmail hingesendet?
Wodran kann das liegen?
Hier ist ein Ausschnitt aus meiner php.ini

Code: Select all
[mail function]
; XAMPP: Comment out this if you want to work with an SMTP Server like Mercury
 SMTP = localhost
 smtp_port = 25

; For Win32 only.
; http://php.net/sendmail-from
sendmail_from = postmaster@localhost

; XAMPP IMPORTANT NOTE (1): If XAMPP is installed in a base directory with spaces (e.g. c:\program filesD:\xampp) fakemail and mailtodisk do not work correctly.
; XAMPP IMPORTANT NOTE (2): In this case please copy the sendmail or mailtodisk folder in your root folder (e.g. C:\sendmail) and use this for sendmail_path. 
 
; XAMPP: Comment out this if you want to work with fakemail for forwarding to your mailbox (sendmail.exe in the sendmail folder)
sendmail_path = "\"D:\xampp\sendmail\sendmail.exe\" -t"

; XAMPP: Comment out this if you want to work with mailToDisk, It writes all mails in the D:\xampp\mailoutput folder
sendmail_path = "D:\xampp\mailtodisk\mailtodisk.exe"


Und der Ausschnitt aus der sendmail.ini

Code: Select all
[sendmail]

; you must change mail.mydomain.com to your smtp server,
; or to IIS's "pickup" directory.  (generally C:\Inetpub\mailroot\Pickup)
; emails delivered via IIS's pickup directory cause sendmail to
; run quicker, but you won't get error messages back to the calling
; application.

smtp_server=smtp.web.de

; smtp port (normally 25)

smtp_port=25

; SMTPS (SSL) support
;   auto = use SSL for port 465, otherwise try to use TLS
;   ssl  = alway use SSL
;   tls  = always use TLS
;   none = never try to use SSL

smtp_ssl=auto

; the default domain for this server will be read from the registry
; this will be appended to email addresses when one isn't provided
; if you want to override the value in the registry, uncomment and modify

;default_domain=

; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging

error_logfile=error.log

; create debug log as debug.log (defaults to same directory as sendmail.exe)
; uncomment to enable debugging

;debug_logfile=debug.log

; if your smtp server requires authentication, modify the following two lines

auth_username=********
auth_password=********

; if your smtp server uses pop3 before smtp authentication, modify the
; following three lines.  do not enable unless it is required.

pop3_server=pop3.web.de
pop3_username=********
pop3_password=********

; force the sender to always be the following email address
; this will only affect the "MAIL FROM" command, it won't modify
; the "From: " header of the message content

force_sender=

; force the sender to always be the following email address
; this will only affect the "RCTP TO" command, it won't modify
; the "To: " header of the message content

force_recipient=

; sendmail will use your hostname and your default_domain in the ehlo/helo
; smtp greeting.  you can manually set the ehlo/helo name if required

hostname=



Natürlich hab ich anstelle der Sternchen meine Zugangsdaten eingegeben. Das Problem besteht nur, wenn sich jemand auf meiner Seite registrieren will. Dann erhält er keine Email. Nachtichten aus dem Kontaktformular kommen super an.

Vielen Dank für eure Hilfe!
vwBanditwv
 
Posts: 2
Joined: 25. September 2012 23:04
XAMPP Version: 5.6.3
Operating System: Windows 7

Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 8 guests