Uploadprobleme mit AjaXplorer - Security Token has Expired

Alles, was den Apache betrifft, kann hier besprochen werden.

Uploadprobleme mit AjaXplorer - Security Token has Expired

Postby staybb » 23. September 2012 12:15

Hallo,

ich nutze AjaXplorer4.2.2 , php5.3 apache2, auf einem Ubuntu 12.04 server.
Mit SSL Zertifikat für den apache.

Meine php.ini habe ich folgend geändert:


Code: Select all
safe_mode = Off
max_execution_time = 0 ; Maximum execution time of each script, in seconds(0 for unlimited)
max_input_time = -1 ; Maximum amount of time each script may spend parsing request data(-1 for unlimited)
memory_limit = 8000M ; Maximum amount of memory a script may consume
post_max_size =   8000M; Maximum size of POST data that PHP will accept.
upload_max_filesize = 8000M; Maximum allowed size for uploaded files.


Wenn ich im AjaXplorer größere Dateien mit dem Java Plugin "Jumploader" Dateien auf den Webserver hochladen möchte, erhalte ich folgende Fehlermeldung von jumploader mitten während des uploads: "FILE ACCESS ERROR" und AjaXplorer gibt aus "SECURITY TOKEN HAS EXPIRED".

Kleinere Dateien >2 GB lassen sich ohne Fehler hochladen.

Folgende Fehler konnte ich in logs feststellen: in /var/log/apache2/other_vhosts_access.log:

Code: Select all
bogus_host_without_reverse_dns:443 192.168.0.3 - - [17/Sep/2012:16:18:08 +0200] "GET /plugins/editor.soundmanager/sm_preview_player.css?v=4.2.2 HTTP/1.1" 304 245 "https://myside.net/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1"
bogus_host_without_reverse_dns:443 192.168.0.3 - - [17/Sep/2012:16:18:11 +0200] "GET /index.php?secure_token=dee5c165db3cde5d27661f013fb8ae38&get_action=get_template&template_name=jumploader_tpl.html&pluginName=uploader.jumploader&encode=false HTTP/1.1" 200 1732 "https://myside.net/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1"
bogus_host_without_reverse_dns:443 192.168.0.3 - - [17/Sep/2012:16:20:28 +0200] "GET /index.php?secure_token=dee5c165db3cde5d27661f013fb8ae38&get_action=ls&options=al&dir=%2F HTTP/1.1" 200 1548 "https://myside.net/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1"
bogus_host_without_reverse_dns:443 192.168.0.3 - - [17/Sep/2012:16:18:37 +0200] "POST /index.php?secure_token=dee5c165db3cde5d27661f013fb8ae38&get_action=upload&dir=Lw==&ajxp_sessid=h64d4d83qia3eevm01v8k144t0 HTTP/1.1" 200 1449 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1"
bogus_host_without_reverse_dns:443 192.168.0.3 - - [17/Sep/2012:16:20:29 +0200] "POST /index.php?secure_token=dee5c165db3cde5d27661f013fb8ae38 HTTP/1.1" 200 596 "https://myside.net/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1"


Ich habe es auch schon versucht ohne SSL nur mit http hochzuladen, aber das geht auch nicht.
Auch habe ich zum Testen extra eine Windows Umgebung mit xampp v3.0.12 installiert und dort auch AjaXplorer installiert. Auch dort erhalte ich beim Upload einer größeren File in der error.log des Apache:
Code: Select all
127.0.0.1 - - [21/Sep/2012:11:39:17 +0200] "POST /ajaxplorer/index.php?secure_token=41b136d278832b64f0b90124d729474a&get_action=upload&xhr_uploader=true&dir=%2F HTTP/1.1" 200 21 "http://localhost/ajaxplorer/" "Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0"
127.0.0.1 - - [21/Sep/2012:11:39:55 +0200] "GET /ajaxplorer/index.php?secure_token=41b136d278832b64f0b90124d729474a&get_action=ls&options=al&dir=%2F HTTP/1.1" 200 628 "http://localhost/ajaxplorer/" "Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0"
127.0.0.1 - - [21/Sep/2012:11:39:59 +0200] "POST /ajaxplorer/index.php?secure_token=41b136d278832b64f0b90124d729474a HTTP/1.1" 200 7 "http://localhost/ajaxplorer/" "Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0"
127.0.0.1 - - [21/Sep/2012:11:38:59 +0200] "POST /ajaxplorer/index.php?secure_token=41b136d278832b64f0b90124d729474a&get_action=upload&xhr_uploader=true&dir=%2F HTTP/1.1" 200 - "http://localhost/ajaxplorer/" "Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0"
127.0.0.1 - - [21/Sep/2012:11:43:15 +0200] "GET /ajaxplorer/index.php?secure_token=41b136d278832b64f0b90124d729474a&get_action=ls&options=al&dir=%2F HTTP/1.1" 200 963 "http://localhost/ajaxplorer/" "Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0"


Was bedeutet dieser "secure token" ? Es muss ja irgend ein Problem des Apache sein, das er die Session des Uploads einfach unterbricht.

Im AjaXplorer habe ich schon alles mögliche was den upload betrifft auf unlimited konfiguriert. An dem liegt es nicht.

Vielen Dank für eure Hilfe.
staybb
 
Posts: 1
Joined: 23. September 2012 12:05
XAMPP Version: 5.6.3
Operating System: ubuntu 12.04

Return to Apache

Who is online

Users browsing this forum: No registered users and 4 guests