PHP 5.4.x, MySQL - lampp 1.80 - mysqli

Problems with the Linux version of XAMPP, questions, comments, and anything related.

PHP 5.4.x, MySQL - lampp 1.80 - mysqli

Postby JonB » 20. August 2012 17:01

I am looking into the mysqli issue for lampp 1.8.0.

PHP 5.4.x uses a different library to support mysqli, new=mysqlnd, old= libmysql. I don't fully understand the impact on lampp at this point.

http://php.net/manual/en/mysqli.installation.php

According to the phpinfo() it appears to have been correctly compiled for the new library

'--with-mysql=mysqlnd'
'--with-mysqli=mysqlnd'

I don't think you need to add the extension/so to the php.ini as they are 'compile withs' - AFAIK that means the code is hard-linked in.

I am seeking wisdom (or correction).

Thanks and good luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: PHP 5.4.x, MySQL - lampp 1.80 - mysqli

Postby Altrea » 22. June 2013 19:26

Additional information from PHP 5.5 Changelog

http://php.net/ChangeLog-5.php wrote:This extension is now deprecated, and deprecation warnings will be generated when connections are established to databases via mysql_connect(), mysql_pconnect(), or through implicit connection: use MySQLi or PDO_MySQL instead

Deprecated means that the extension will be removed in one of the next PHP releases which can be PHP 5.6 or PHP 6.
It's time to change existing codes to mysqli or PDO
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6617
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests