Apache 2.4.2 Lampp Server PROBLEM

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache 2.4.2 Lampp Server PROBLEM

Postby EVO_Killer » 03. August 2012 05:35

Hey Leute,

ich habe lampp (xampp) auf linux aufgesetzt nur hat auch alles wunderbar geklappt bis auf das wenn ich meine seite: www.sponsorparadise.de im internet aufrufe kommt folgende Meldung:


Neues XAMPP Sicherheitskonzept:

Der Zugriff auf das angeforderte Verzeichnis ist nur aus dem lokalen Netzwerk möglich.

Diese Einstellung kann in der Datei "httpd-xampp.conf" angepasst werden.

Ich habe die httpd-xampp.conf durchgeschaut aber finde dort nichts.
EVO_Killer
 
Posts: 1
Joined: 03. August 2012 05:33
XAMPP Version: 5.6.3
Operating System: Linux Ubuntu 12.04

Re: Apache 2.4.2 Lampp Server PROBLEM

Postby Kristian Marcroft » 12. August 2012 00:03

Hallo,

echt nichts gefunden? :)

Schau mal ganz ans Ende dieser Datei.
Dort solltest du in etwa folgendes finden:
#
# New XAMPP security concept
#
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
Order deny,allow
Deny from all
Allow from ::1 127.0.0.0/8 \
fc00::/7 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 \
fe80::/10 169.254.0.0/16

ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>


Dies ist jedoch eine sinnvolle Schutzfunktion für dein XAMPP.
ggf. solltest du einen anderen VirtualHost nutzen?

Gruß
Kristian
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Re: Apache 2.4.2 Lampp Server PROBLEM

Postby Postfach4703 » 12. August 2012 15:31

Hallo zusammen,
ich kann mich dem Problem nur anschließen. Bei Aufruf (localhost oder 127.0.0.1) von phpmyadmin bekomme ich die Hinweisseite, dass ich die httpd-xampp.conf" editieren soll, aber leider funktioniert es nicht, Ich habe den Sicherheitspassus schon auf "Allow from all" gesetzt aber trotzdem funktioniert es nicht. Muss ich die Rechte des Verzeichnisses "/opt/lampp/phpmyadmin" ändern?
Ich versuche seit drei Tage die Sache zum laufen zu bekommen.

Ich nutze Ubuntu 12.04 und Lampp 1.8.0

Danke für die Hilfe.
Postfach4703
 
Posts: 2
Joined: 12. August 2012 15:23
XAMPP Version: 5.6.3
Operating System: Ubuntu

Re: Apache 2.4.2 Lampp Server PROBLEM

Postby Kristian Marcroft » 12. August 2012 23:00

Hallo,

nach der Konfigurationsänderung LAMPP auch neugestartet?
Was steht denn im Apache error.log?

Gruß
Kristian
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Re: Apache 2.4.2 Lampp Server PROBLEM

Postby Postfach4703 » 13. August 2012 22:57

Hallo,
den Server habe ich nach der Änderung durchgestartet. Ich denke es liegt an Ubuntu und den User Rechten? Ich habe noch nicht ausprobiert das Verzeichnis "/opt/lampp/phpmyadmin" dem User des Servers zuzuordnen, allerdings haben alle User die Rechte lesen und schreiben.

In der error_log
Code: Select all
[Mon Aug 13 23:51:41.088502 2012] [ssl:warn] [pid 5831] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Aug 13 23:51:41.089185 2012] [ssl:warn] [pid 5831] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Aug 13 23:51:41.089330 2012] [suexec:notice] [pid 5831] AH01232: suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Aug 13 23:51:41.423991 2012] [auth_digest:notice] [pid 5832] AH01757: generating secret for digest authentication ...
[Mon Aug 13 23:51:42.265813 2012] [ssl:warn] [pid 5832] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Aug 13 23:51:42.268983 2012] [ssl:warn] [pid 5832] AH01909: RSA certificate configured for www.example.com:443 does NOT include an ID which matches the server name
[Mon Aug 13 23:51:42.269192 2012] [lbmethod_heartbeat:notice] [pid 5832] AH02282: No slotmem from mod_heartmonitor
[Mon Aug 13 23:51:42.413164 2012] [mpm_prefork:notice] [pid 5832] AH00163: Apache/2.4.2 (Unix) OpenSSL/1.0.1c PHP/5.4.4 configured -- resuming normal operations
[Mon Aug 13 23:51:42.413356 2012] [core:notice] [pid 5832] AH00094: Command line: '/opt/lampp/bin/httpd -D SSL -D PHP5 -E /opt/lampp/logs/error_log'
[Mon Aug 13 23:52:18.615005 2012] [authz_core:error] [pid 6035] [client 127.0.0.1:33196] AH01630: client denied by server configuration: /opt/lampp/phpmyadmin/, referer: http://localhost/xampp/navi.php


In der access_log
Code: Select all
127.0.0.1 - - [13/Aug/2012:23:52:18 +0200] "GET /phpmyadmin/ HTTP/1.1" 403 1087


Hier die "htttpd-xampp.conf":
Code: Select all
<LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
        Order deny,allow
        Deny from all
        Allow from all
        ErrorDocument 403 /error/XAMPP_FORBIDDEN.html.var
</LocationMatch>



Danke.
Postfach4703
 
Posts: 2
Joined: 12. August 2012 15:23
XAMPP Version: 5.6.3
Operating System: Ubuntu


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests