Compiling mod_wsgi for XAMPP errors with apxs file

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

Compiling mod_wsgi for XAMPP errors with apxs file

Postby toddhgardner » 12. February 2012 04:36

I am trying to add mod_wsgi to XAMPP on OSX Lion. Following the directions from this thread: http://community.apachefriends.org/f/viewtopic.php?f=17&t=42975&p=186891&hilit=apxs#p186891
When running ./configure on mod_wsgi 3.3, I get a few of these warnings, but it completes without error:

Code: Select all
Use of assignment to $[ is deprecated at /Applications/XAMPP/xamppfiles/bin/apxs line 86.


But when I do a make, I get the following errors

Code: Select all
/Applications/XAMPP/xamppfiles/build/libtool --silent --mode=compile gcc -prefer-pic -I/Applications/XAMPP/xamppfiles/include -L/Applications/XAMPP/xamppfiles/lib -mmacosx-version-min=10.4 -arch i386 -arch ppc  -DDARWIN -DSIGPROCMASK_SETS_THREAD_MASK -no-cpp-precomp  -I/Applications/XAMPP/xamppfiles/include  -I/Applications/XAMPP/xamppfiles/include   -I/Applications/XAMPP/xamppfiles/include -I/Applications/XAMPP/xamppfiles/include -arch i386 -arch ppc -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -DENABLE_DTRACE -DMACOSX -DNDEBUG -DNDEBUG -DENABLE_DTRACE  -c -o mod_wsgi.lo mod_wsgi.c && touch mod_wsgi.slo
llvm-gcc-4.2: error trying to exec '/usr/bin/../llvm-gcc-4.2/bin/powerpc-apple-darwin11-llvm-gcc-4.2': execvp: No such file or directory
lipo: can't figure out the architecture type of: /var/folders/32/m4705p8n2ng3k5ypq_50nzzr0000gn/T//ccwZjfNJ.out
apxs:Error: Command failed with rc=65536


I noticed some references to ppc architecture, which seems weird as I'm running on an intel x64 architecture.
I also opened a stack overflow question here (http://stackoverflow.com/questions/9244966/installing-mod-wsgi-into-xampp-on-osx-lion) where it was suggested that the apxs file was not playing together with mod_wsgi

Thanks in advance for any assistance; and XAMPP is awesome!
toddhgardner
 
Posts: 1
Joined: 12. February 2012 04:24
XAMPP Version: 1.8.3-2
Operating System: OSX Lion

Re: Compiling mod_wsgi for XAMPP errors with apxs file

Postby kitgrose » 24. July 2012 03:58

This is caused by the XAMPP configuration trying to build for PowerPC as well as Intel.

Update /Applications/XAMPP/xamppfiles/build/config.nice and /Applications/XAMPP/xamppfiles/build/config_vars.mk and remove all references to "-arch PPC".
kitgrose
 
Posts: 1
Joined: 24. July 2012 03:54
XAMPP Version: 1.8.3-1
Operating System: Mac OS X Lion

Re: Compiling mod_wsgi for XAMPP errors with apxs file

Postby informatrex » 24. October 2012 00:12

Very helpful!!!

Thanx
informatrex
 
Posts: 1
Joined: 24. October 2012 00:09
XAMPP Version: 5.5.19
Operating System: Mac OSX


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 4 guests