Virtual Host leitet auf xampp Seite um

Irgendwelche Probleme mit XAMPP für Mac OS X? Dann ist hier genau der richtige Ort um nachzufragen.

Virtual Host leitet auf xampp Seite um

Postby erasor2010 » 01. July 2012 01:00

Hi,

ich hab nen Virtual Host angelegt. Leider wird der browser immer auf die Xampp Startseite umgeleitet.

Woran liegt das

httpd-vhosts.conf:
Code: Select all
<VirtualHost 127.0.0.1>
DocumentRoot "/Users/maxsim/Desktop/Serien/"
ServerName serienfiles.local
ServerAlias www.serienfiles.local
<Directory "/Users/maxsim/Desktop/Serien/">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOveride All
        Order Allow,Deny
        Allow From All
</Directory>
</VirtualHost>
erasor2010
 
Posts: 2
Joined: 01. July 2012 00:54
XAMPP Version: 1.8.3-2
Operating System: MacOsx 10.7.4

Re: Virtual Host leitet auf xampp Seite um

Postby Altrea » 01. July 2012 06:35

Hi erasor2010,

erasor2010 wrote:Woran liegt das

Im Zweifel daran, dass dein VirtualHost nicht matcht oder der Apache garnicht mitbekommen hat, dass du einen angelegt hast (Neustart nicht vergessen).
Du hast auch mindestens einen Schreibfehler in deinen Anweisungen. Überprüfe am besten die Schreibweisen all deiner Anweisungen nochmals.
Einträge in deinem Apache error logfile können dir bei der Fehlersuche helfen.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6476
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Virtual Host leitet auf xampp Seite um

Postby erasor2010 » 01. July 2012 15:55

Also ich hab den Schreibfehler bei Override gefunden und die Zeile für Log files eingetragen.

Ich bekomme aber keine Logs und es wird weiterhin zu xampp umgeleitet. Hab ich noch nen Schreibfehler drin

Code: Select all
<VirtualHost 127.0.0.1>
DocumentRoot "/Users/maxsim/Desktop/Serien/"
ServerName serienfiles.local
ServerAlias serienfiles.local
<Directory "/Users/maxsim/Desktop/Serien/">
        Options Indexes FollowSymLinks Includes ExecCGI
        AllowOverride All
        Order Allow,Deny
        Allow From All
</Directory>
ErrorLog "/Users/maxsim/Desktop/Serien/Log/"
CustomLog "/Users/maxsim/Desktop/Serien/Log/"
</VirtualHost>


Ich hab den Server auch nach jeder änderung neu gestartet
erasor2010
 
Posts: 2
Joined: 01. July 2012 00:54
XAMPP Version: 1.8.3-2
Operating System: MacOsx 10.7.4

Re: Virtual Host leitet auf xampp Seite um

Postby Altrea » 01. July 2012 19:08

Fehler sehe ich keine mehr.

  • den ServerAlias kannst du dir sparen, der wird bei dir schon durch den ServerName abgedeckt
  • Hast du eine NameVirtualHost Zeile um namebased virtual hosts zu aktivieren?
  • Ist deine vhosts Konfigurationsdatei auch in der Apache Hauptkonfigurationsdatei eingebunden?
  • Was sagt deine Haupt Apache error.log Datei dazu? Nur hier werden Meldungen über zum Beispiel fehlerhafte Direktiven geloggt

Du könntest auch vorerst die VirtualHost Direktive umschreiben, dass sie generell auf Port 80 hört und nicht nur auf 127.0.0.1.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6476
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64


Return to XAMPP für Mac OS X

Who is online

Users browsing this forum: No registered users and 1 guest