Facing compilation problem with Apache configuration & LDAP

Problems with the Solaris version of XAMPP, questions, comments, and anything related.

Facing compilation problem with Apache configuration & LDAP

Postby sasi1503 » 18. June 2012 15:48

Hi,

We are trying to compile Apache with LDAP and followed below steps for the LDAP configuration followed by compilation.

Mod_Auth_ldap & mod_ldap:

Command Able To Configure Able To Make Able To Make Install
./configure --enable-auth-ldap Yes No No

Details :

This was due to the compilation problem with APR-Util with LDAP support.
In order to get rid of this error again i ran the configure command with the following options:

--with-ldap-include= path to ldap include file
--with-ldap-lib=path = path to ldap lib file
--with-ldap=library = ldap library

After that 'make' command works fine but the flag status for the mod_auth_ldap changed from 'Yes' to 'No'

Command Configure Make Make Install
./configure --enable-ldap Yes No No

Details:

This was due to the compilation problem with APR-Util with LDAP support.
In order to get rid of this error again i ran the configure command with the following options:

--with-ldap-include= path to ldap include file
--with-ldap-lib=path = path to ldap lib file
--with-ldap=library = ldap library

After that 'make' command works fine but the flag status for mod_ldap changed from 'Yes' to 'No'.

In order to overcome the above Apr & Apr-Util problem we tried with the below configure options
and configure was working fine but we faced problems while building of ‘make’ statement and their corresponding errors has been captured as below.

Configure:

./configure --prefix=/Volumes/app/apache2.2/httpd-2.2.22 --enable-threads --enable-other-child - apr
./configure --prefix=/Volumes/app/apache2.2/httpd-2.2.22 --with-apr=../apr --with-ldap-lib=/usr/lib --with-ldap-include=/usr/include --with-ldap=ldap - apr-util
./configure --enable-ldap --enable-authnz-ldap --with-included-apr

Errors:

nawk -f /Volumes/app/apache2.2/httpd-2.2.22/build/make_exports.awk `cat export_files` > exports.c
/Volumes/app/apache2.2/httpd-2.2.22/srclib/apr/libtool --silent --mode=compile gcc -g -O2 -DSOLARIS2=10 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -D_LARGEFILE64_SOURCE -I/Volumes/app/apache2.2/httpd-2.2.22/srclib/pcre -I. -I/Volumes/app/apache2.2/httpd-2.2.22/os/unix -I/Volumes/app/apache2.2/httpd-2.2.22/server/mpm/prefork -I/Volumes/app/apache2.2/httpd-2.2.22/modules/http -I/Volumes/app/apache2.2/httpd-2.2.22/modules/filters -I/Volumes/app/apache2.2/httpd-2.2.22/modules/proxy -I/Volumes/app/apache2.2/httpd-2.2.22/include -I/Volumes/app/apache2.2/httpd-2.2.22/modules/generators -I/Volumes/app/apache2.2/httpd-2.2.22/modules/mappers -I/Volumes/app/apache2.2/httpd-2.2.22/modules/database -I/Volumes/app/apache2.2/httpd-2.2.22/srclib/apr/include -I/Volumes/app/apache2.2/httpd-2.2.22/srclib/apr-util/include -I/Volumes/app/apache2.2/httpd-2.2.22/srclib/apr-util/xml/expat/lib -I/Volumes/app/apache2.2/httpd-2.2.22/modules/proxy/../generators -I/Volumes/app/apache2.2/httpd-2.2.22/modules/ssl -I/Volumes/app/apache2.2/httpd-2.2.22/modules/dav/main -prefer-non-pic -static -c exports.c && touch exports.lo
exports.c:1800: error: redefinition of 'ap_hack_ap_basic_http_header'
exports.c:1681: error: previous definition of 'ap_hack_ap_basic_http_header' was here
exports.c:1801: error: redefinition of 'ap_hack_ap_send_http_trace'
exports.c:1682: error: previous definition of 'ap_hack_ap_send_http_trace' was here
exports.c:1802: error: redefinition of 'ap_hack_ap_send_http_options'
exports.c:1263: error: previous definition of 'ap_hack_apr_version_string' was here
make[2]: *** [exports.lo] Error 1
make[2]: Leaving directory `/Volumes/app/apache2.2/httpd-2.2.22/server'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/Volumes/app/apache2.2/httpd-2.2.22/server'
make: *** [all-recursive] Error 1.
==========================================================================================================================================================

How can I get rid of the above errors?.

Thanks in advance for any suggestions.

Thanks,
Sasi
sasi1503
 
Posts: 1
Joined: 18. June 2012 15:24
XAMPP Version: 1.7.1
Operating System: Unix

Return to XAMPP for Solaris

Who is online

Users browsing this forum: No registered users and 0 guests