Apache startet nicht!

Irgendwelche Probleme mit XAMPP für Windows? Dann ist hier genau der richtige Ort um nachzufragen.

Apache startet nicht!

Postby mrapleist » 21. May 2012 21:02

Wieder einmal ein bekanntes Thema. :D

Nun gut.

Ich habe so ziemlich alles ausprobiert, Apache will einfach nicht starten. MySql startet, aber wenn ich bei Apache auf starten klicke, passiert nichts. (manchmal leutet "running" kurz auf!)
Ich hab Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) Runtime schon installiert, hab es zur Sicherheit noch einmal installiert...
XAMPP habe ich auch erneut installiert..

Unter anderem habe ich mir xampp-portcheck heruntergeladen, alle Ports sind FREE!
Skype ist geschlossen, und das mit dem 80 und 443 Port habe ich abgeschaltet.

Unter apache/logs befindet sich auch nichts!

Bitte um Hilfe !!! :cry:
mrapleist
 
Posts: 4
Joined: 21. May 2012 20:53
XAMPP Version: 5.6.3
Operating System: Windows 7 x64

Re: Apache startet nicht!

Postby Altrea » 21. May 2012 21:44

Hallo mrapleist,

Dann versuche bitte mal folgendes:
  • Windows Eingabeaufforderung starten
  • mit cd C:\xampp\apache\bin ins Apache binary Verzeichnis wechseln
  • mit httpd.exe versuchen Apache zu starten bzw. ggf Fehlermeldungen zu erhalten

Je nachdem wie der Ausgang dessen ist müssen wir dann weitersehen was zu tun ist.

mit freundlichen Grüßen,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6584
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache startet nicht!

Postby mrapleist » 21. May 2012 21:57

Danke um Deine schnelle Hilfe!

Der Befehl, "cd D:\Program Files (x86)\XAMPP" (weil ich es dort installiert habe) funktioniert nicht, so komisch es auch klingt!
Wenn ich ihn eingebe, bekomme ich keine Fehlermeldung, aber es verändert sich auch nichts in CMD. (Es bleibt C:\Users\Admin)

Und wenn ich httpd.exe öffne, erscheint CMD kurz, und verschwindet gleich darauf wieder.

MfG,
mrapleist
mrapleist
 
Posts: 4
Joined: 21. May 2012 20:53
XAMPP Version: 5.6.3
Operating System: Windows 7 x64

Re: Apache startet nicht!

Postby Altrea » 21. May 2012 22:04

Dann installiere XAMPP bitte, wie empfohlen, direkt in C:\ bzw. in deinem Fall D:\ so dass du am Ende einen D:\xampp\ Ordner enthälst.
Das OpenSSL Modul des Apache hat nämlich ein Proböem mit dem (x86) in deinem Ordnernamen.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6584
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Apache startet nicht!

Postby mrapleist » 21. May 2012 22:07

Ah. So ist das.
Oke. Ich werde es versuchen. (:
mrapleist
 
Posts: 4
Joined: 21. May 2012 20:53
XAMPP Version: 5.6.3
Operating System: Windows 7 x64

Re: Apache startet nicht!

Postby mrapleist » 21. May 2012 22:13

DANKE! DANKE! DANKE!
Danke vielmals für deine Hilfe!
Nun funktioniert es, ich habe es in "D:\Program Files" ( nun OHNE (x86) ) installiert, und es funktioniert!
Nochmals DANKE!
mrapleist
 
Posts: 4
Joined: 21. May 2012 20:53
XAMPP Version: 5.6.3
Operating System: Windows 7 x64

Re: Apache startet nicht!

Postby Altrea » 21. May 2012 22:33

mrapleist wrote:Nun funktioniert es, ich habe es in "D:\Program Files" ( nun OHNE (x86) ) installiert, und es funktioniert!

Auch dieses Verzeichnis ist nicht das richtige, denn das ist das Verzeichnis speziell für 64Bit Programme, was de XAMPP Komponenten nicht sind.
Aber letztendlich ist es dein Computer mit dem du soviel Unsinn treiben kannst, wie du es für richtig hälst.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6584
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Apache startet nicht!

Postby Schweijk » 21. August 2012 10:36

Auch ich habe das Problem, nachdem ich mein Win7 (Ultimate, 32bit) neu aufsetzen musste, dass ich den Apache nicht mehr starten kann (nutze das Xampp-Bundle unter C:\xampp). Der manuelle Start über die DOS-Box bringt folgende Fehlermeldung:

Der Zugriff auf einen Socket war augrund der Zugriffsreche des Sockets unzulässig. : make_sock: could not bind to adress 0.0.0.0:80


Kann es sein, dass ich die Installation von Xampp als Admin ausführen muss oder wird Port 80 von der Firewall geblockt? Null Idee. Vielleicht kann mir jemand helfen. Vielen Dank!
Schweijk
 
Posts: 2
Joined: 21. August 2012 10:10
XAMPP Version: 1.8.3-2
Operating System: Win7 32bit

Re: Apache startet nicht!

Postby Schweijk » 21. August 2012 18:04

Problem gelöst. Habe in der httpd.conf den Port 80 auf 81 gesetzt. Funzt! :P
Schweijk
 
Posts: 2
Joined: 21. August 2012 10:10
XAMPP Version: 1.8.3-2
Operating System: Win7 32bit

Re: Apache startet nicht!

Postby sunandmoon » 01. September 2012 14:30

apache und mysql konnte ich gesern noch starten - heute bekomme ich folg. Meldung

15:25:02 [apache] Starte Programm: apache...
15:25:02 [apache] Statusänderung erkannt: gestartet
15:25:03 [apache] Statusänderung erkannt: gestoppt
15:25:06 [mysql] Starte Programm: mysql...
15:25:06 [mysql] Statusänderung erkannt: gestartet
15:25:06 [mysql] Statusänderung erkannt: gestoppt


bitte dringend um hilfe
eva
sunandmoon
 
Posts: 2
Joined: 01. September 2012 14:12
XAMPP Version: 5.6.3
Operating System: Windows7

Re: Apache startet nicht!

Postby Llandyl » 02. October 2012 14:42

Hallo Eva,

hast du vielleicht kürzlich Skype auf deinem Rechner installiert? Das blockiert nämlich den Port 80 und hindert so Apache und MySQL am Start.

Falls ja: Erst Apache und MySQL starten und dann anschließend erst Skype. Hatte das gleiche Problem und damit hats geschnackelt.

Ansonsten kannst du noch unter "Systemsteuerung -> Programme und Funktionen -> Windows-Funktionen aktivieren und deaktivieren" bei "Internetinformationsdienste" den Haken entfernen. Das ist ein ziemlich nutzloser Windowsdienst, der ebenfalls auf Port 80 lauscht und ihn so blockiert.

Gruß Basti
Llandyl
 
Posts: 1
Joined: 02. October 2012 14:34
XAMPP Version: 5.6.3
Operating System: Windows 7 x64

Re: Apache startet nicht!

Postby maztf5c1 » 08. November 2012 03:07

Ah. So ist das.
Oke. Ich werde es versuchen. (:
maztf5c1
 
Posts: 1
Joined: 08. November 2012 03:06
XAMPP Version: 1.8.2
Operating System: WINDOWN 7

Re: Apache startet nicht!

Postby isitrade » 12. November 2012 19:49

WIndows 7 prof. 64 bit / 1.81 installiert /
Ich habe das gleiche Problem wie sunandmoon

19:41:32 [Apache] Statusänderung erkannt: gestartet
19:41:37 [Apache] Statusänderung erkannt: gestoppt
19:41:37 [Apache] Fehler: Apache wurde unerwartet beendet.
19:41:37 [Apache] Ursache könnte ein geblockter Port, fehlende Abhängigkeiten,
19:41:37 [Apache] fehlende Berechtigungen, ein Absturz oder ein Abbruch einer anderen Methode sein.
19:41:37 [Apache] Überprüfe die Datei "/xampp/apache/logs/error.log"
19:41:37 [Apache] und die Windows Ereignisanzeige für weitere Hinweise

aus der error.log:
[Mon Nov 12 19:41:36.413352 2012] [ssl:warn] [pid 6132:tid 40] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Mon Nov 12 19:41:36.473353 2012] [mpm_winnt:crit] [pid 6132:tid 40] (OS 6)Das Handle ist ungültig. : AH00389: Child: Unable to access the scoreboard from the parent
[Mon Nov 12 19:41:36.573353 2012] [mpm_winnt:crit] [pid 1776:tid 260] AH00419: master_main: create child process failed. Exiting.

mehrfach auf unterschiedliche Weise installiert, auch ältere Versionen
Skype deinstalliert
Ports geändert
Programm ist in Firewall freigeg.
Hat jemand noch eine Idee, der mit dem EIntrag in der error.log was anfangen kann. Schon mal danke im voraus.
isitrade
 
Posts: 2
Joined: 12. November 2012 19:43
XAMPP Version: 5.6.3
Operating System: windows 7 prof. 64bit

Re: Apache startet nicht!

Postby isitrade » 20. November 2012 18:40

Hat jemand eine Idee??

Init: Session Cache is not configured - Was ist damit denn gemeint?
isitrade
 
Posts: 2
Joined: 12. November 2012 19:43
XAMPP Version: 5.6.3
Operating System: windows 7 prof. 64bit


Return to XAMPP für Windows

Who is online

Users browsing this forum: No registered users and 6 guests