MySQL strange problem

Problems with the Mac OS X version of XAMPP, questions, comments, and anything related.

MySQL strange problem

Postby kazak71 » 17. October 2011 22:39

Hi XAMPP is great work!
I migrated from Linux to Mac OS Lion. I have installed successfully XAMPP in Lion. But I found one strange problem:
I can create successfully stored functions but when I try use them they don't return anything! All these functions work perfectly in XAMPP for Linux
Please, help me to solve this problem!

Sincerely,
Peter
kazak71
 
Posts: 5
Joined: 17. October 2011 22:29
XAMPP Version: 1.8.3-2
Operating System: Mac OS X Lion

Re: MySQL strange problem

Postby JonB » 17. October 2011 23:45

are you on 10.7.2????

just very very curious --

:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: MySQL strange problem

Postby kazak71 » 17. October 2011 23:53

Yes, I am on 10.7.2
In last 5 min. I created stored function wich returns just constant string. I tried to use this one and result was the same: newly created function doesn't return anything.
kazak71
 
Posts: 5
Joined: 17. October 2011 22:29
XAMPP Version: 1.8.3-2
Operating System: Mac OS X Lion

Re: MySQL strange problem

Postby JonB » 18. October 2011 00:49

note the 'other 3 open' Mac WTF? questions

what's in common -- you guessed it -- 10.7.2

I cannot say that the update is the issue, but these are all effectively 'used to work' or 'should work' items

I don't know if the XAMPP project currently has a Mac super-guru or not... but I will find out.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: MySQL strange problem

Postby kazak71 » 18. October 2011 06:53

Thanks!
I will try on Leopard and I will post my results :)
kazak71
 
Posts: 5
Joined: 17. October 2011 22:29
XAMPP Version: 1.8.3-2
Operating System: Mac OS X Lion

Re: MySQL strange problem

Postby bertosinmac » 18. October 2011 08:20

Hello, I will follow the thread. My case is the same. Thank you.
bertosinmac
 
Posts: 1
Joined: 18. October 2011 08:15
XAMPP Version: 5.6.3
Operating System: mac osx

Re: MySQL strange problem

Postby kazak71 » 18. October 2011 22:13

Hello, The issue was confirmed on another MacBook Pro with Lion. I installed XAMPP on Snow Leopard and then I created simple function called `hello_word`(with one input param) which just returns string 'HELLO_WORD'. When I use function like this: select hello_word('param') ..... I receive error message like "... the function hello_word not found ..."
I installed MAMP and created and used stored functions successfully.
Therefore I think the problem is in XAMPP and it may be in mysql schema settings (somewhere in system tables) where are permissions set. Thanks!
kazak71
 
Posts: 5
Joined: 17. October 2011 22:29
XAMPP Version: 1.8.3-2
Operating System: Mac OS X Lion

Re: MySQL strange problem

Postby kazak71 » 20. October 2011 23:18

I made a lot of test and I am SURE problem is in XAMPP.
However i SOLVED my problem reading this:
http://www.klauskomenda.com/archives/2008/10/07/installing-apache-mysql-and-php-on-leopard/
and this:
http://mymacinations.com/2007/10/28/apache-php-and-mysql-on-leopard/
This is completely working and probably I wouldn't use XAMPP unless this issue stands.
kazak71
 
Posts: 5
Joined: 17. October 2011 22:29
XAMPP Version: 1.8.3-2
Operating System: Mac OS X Lion


Return to XAMPP for Mac OS X

Who is online

Users browsing this forum: No registered users and 3 guests