iconv in PHP Broken

Problems with the Solaris version of XAMPP, questions, comments, and anything related.

iconv in PHP Broken

Postby cneubauer » 18. April 2011 16:45

Trying to use the iconv function in PHP in a fresh install of XAMPP for Solaris 1.7.4 causes an Apache segfault. Some web searching brings up this bug report which looks to be the same issue: http://bugs.php.net/bug.php?id=53844. The solution seems to be to configure PHP using the line with-iconv=/opt/xampp instead of just with-iconv.
cneubauer
 
Posts: 1
Joined: 18. April 2011 16:39

Re: iconv in PHP Broken

Postby slug » 26. September 2011 16:59

iconv still broken in 1.7.7.

Can anyone point me in the direction of what i need to rebuild php-5.3.8, and in what order to rebuild the constituant parts.

I'm running xampp 1.7.7 for solaris (solaris 10 on sparc)
slug
 
Posts: 2
Joined: 26. September 2011 16:20

Re: iconv in PHP Broken

Postby Sharley » 27. September 2011 00:28

Hello and thanks for posting your findings,

I have passed this topic onto the developers for comment.

Regards,
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: iconv in PHP Broken

Postby Oswald » 27. September 2011 06:42

Hi slug,

can you please try these two commands (highlighted) on your system:

sol10u7xampp ~> /opt/xampp/bin/php -r 'echo iconv("UTF-8", "UTF-8", "Hello, world.\n");'
Hello, world.
sol10u7xampp ~> ldd /opt/xampp/bin/php | egrep iconv
libiconv.so.2 => /opt/xampp/lib/libiconv.so.2

Cheers,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Re: iconv in PHP Broken

Postby slug » 04. October 2011 10:30

Hi

Sorry for the delay in posting a reply. I have run the two commands as requested

# /opt/xampp/bin/php -r 'echo iconv("UTF-8", "UTF-8", "Hello, world.\n");'

Segmentation Fault (core dumped)
#
#
# ldd /opt/xampp/bin/php | egrep iconv
libiconv.so.2 => /opt/xampp/lib/libiconv.so.2
#

hope this helps.
slug
 
Posts: 2
Joined: 26. September 2011 16:20


Return to XAMPP for Solaris

Who is online

Users browsing this forum: No registered users and 0 guests