Making my XXAMP website public

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Making my XXAMP website public

Postby Pritchard2 » 21. September 2011 11:37


We have recently rented a Windows 2003 Cloud Server to publish our website online and after about 30 hours continual work (I am completely new to all of this) I seem to be no closer to accessing my website via the world wide web.

The website was developed in XXAMP and uses Mysql and Apache. I have managed to install XXAMP on to the server and provided apache and mysql services are "running" the website and database work fine locally on the server.

If I try to go to my website however using or even (ip address of the server) I just get "page can not be displayed" in IE, or "safari can not connect to the server".

This is sapping all of my energy and motivation, I am so close yet so far. There seem to be a billion ways to "configure a windows 2003 server" to do a billion different functions, and after 30 odd hours of trawling through guide after guide, none of them talk about Apache and Mysql, only IIS and SQL Server 2008.

Please please help. I don't know if it's a firewall issue, a port forwarding issue, a domain registration issue. I've no idea who to turn to or what to do to veryify anything. I expect that if I do get it working I will have done it in an unsecure way and it will be about a day before some hacker steals all of our year's work.
Posts: 1
Joined: 21. September 2011 11:21

Re: Making my XXAMP website public

Postby Sharley » 21. September 2011 11:49

First thing to understand about XAMPP is that it is not intended to be used as a production server but rather a development environment.

There are some security issues to attend to before moving forward and they are addressed simply in the readme_en.txt file in the xampp folder.

If you want to continue then read on.

So you have configured your domain name at the registrar to point to the IP address of the PC that Apache is running on?

You can't access yourself from your PC using your WAN IP unless you go through a proxy and back to your server.

Check that your ISP is not blocking port 80 and port 443, some do.

You have put your web site into the htdocs folder and deleted the 2 index files index.php and index.html that came with the XAMPP release and placed your site index file and associated folders directly in this folder?

What version of XAMPP on the server PC?

You should get all the help you need in this forum to get you moving forward.

Try and get the hang of searching these English forums as most issues with XAMPP have been posted here before and most have been solved.
User avatar
AF Moderator
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests