XAMPP CONTROL PANEL Version 3 Problems

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP CONTROL PANEL Version 3 Problems

Postby Sharley » 10. May 2011 22:26

New XAMPP CONTROL PANEL Version 3

In the German forum you can read all about it and download the bilingual (German and English) version including the source code for testing and use - download and extract the xampp_control3.exe into the XAMPP version folder for example C:\xampp and run the xampp-control3.exe from there - may also work in other older versions of XAMPP.

It seems it is also included in the latest beta version.

Just tested it using the English version on XAMPP 1.7.4 with good results and should help many of you who have found the current 1.7.4 control panel a pain - fixes the MySQL Admin issue and the status error issue plus has many nice new features including port checking on startup (nice).

German Forum link here:
viewtopic.php?f=4&t=46647
Google translate link here:
http://www.google.com/language_tools
Download link here (but may change so check the original German post):
http://arloh.de/xampp/xampp_control3.0.2.zip (Exe & Source)

Thanks to Steffan Shrueber for this very nice new Control Panel version and yes Steffan it does help greatly and well received after many years of inferior offerings - well thought out with most of what is needed to "Control" XAMPP included in an easy to use interface.


You may leave your comments in this topic then perhaps Steffan may read them from time to time. :)

Best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby Sharley » 11. May 2011 09:57

Updated May 11 2011

Small bugs fixed.
http://arloh.de/xampp/xampp_control3.0.2.zip
(Same file name but now with a compile date in the Control Panel window title - 11 May 2011 is current).

If I happen to miss any updates then it may be best to keep checking the German topic linked above for the latest file yourselves.

kvo, the XAMPP for Windows developer, seems to be getting on board so it may soon be available from the Apache Friends web site, I will try and keep you all up to scratch when I spot any new developments.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby dmsclz » 11. May 2011 13:40

Sharley, thanks for translating and forwarding informations here! :-)

Yes Im reading here too. At the moment the only thing in my todo-list is integration of tomcat. wont take much time - at the moment im in office and dont have time for that, maybe this evening.

Any bugs/problems/wishes so far?

In my opinion this app is apart from bugs and that tomcat-integration finished... maybe this app could run as service, dunno yet if i wanna do this.. is this needed?


Best regards,
Steffen
dmsclz
 
Posts: 35
Joined: 05. May 2011 22:41

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby Altrea » 11. May 2011 17:04

dmsclz wrote:Any bugs/problems/wishes so far?

My biggest wish is a XAMPP Shell Button like in XAMPP 1.7.3 with all the XAMPP binaries attached to the include_path :D
Great work so far! I really love it and already use it on one of my developing stations.
Thank you very much, Steffen 8)

P.S.: I will test it on my USB-Stick too if i can find some minutes.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6475
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby WilliL » 11. May 2011 18:18

hint for XAMPP 175b: works too, but script is not included

xampp_shell.bat (XAMPP 173)
Code: Select all
@ECHO OFF

GOTO weiter
:setenv
SET "MIBDIRS=%~dp0php\extras\mibs"
SET "MIBDIRS=%MIBDIRS:\=/%"
SET "MYSQL_HOME=%~dp0mysql\bin"
SET "OPENSSL_CONF=%~dp0apache\bin\openssl.cnf"
SET "OPENSSL_CONF=%OPENSSL_CONF:\=/%"
SET "PHP_PEAR_SYSCONF_DIR=%~dp0php"
SET "PHPRC=%~dp0php"
SET "TMP=%~dp0tmp"
SET "PERL5LIB="
SET "Path=%~dp0;%~dp0php;%~dp0perl\site\bin;%~dp0perl\bin;%~dp0apache\bin;%~dp0mysql\bin;%~dp0FileZillaFTP;%~dp0MercuryMail;%~dp0sendmail;%~dp0webalizer;%~dp0tomcat\bin;%Path%"
GOTO :EOF
:weiter

IF "%1" EQU "setenv" (
    ECHO.
    ECHO Setting environment for using XAMPP for Windows.
    CALL :setenv
) ELSE (
    SETLOCAL
    TITLE XAMPP for Windows
    PROMPT %username%@%computername%$S$P$_#$S
    START "" /B %COMSPEC% /K "%~f0" setenv
)
Willi
WilliL
 
Posts: 619
Joined: 08. January 2010 10:54
XAMPP Version: 5.5.19
Operating System: Win7Home Prem 64 SP1

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby dmsclz » 11. May 2011 20:21

Hi,

http://arloh.de/xampp/xampp_control3.0.2.zip
"May 11th 2011 build #2"

- Tomcat module added
- Shell added

Tomcat should be tested by some users, there are soo many combinations from 32/64 bit :(
I tested on Win7 64bit (JDK = 64bit)

Best regards,
Steffen
dmsclz
 
Posts: 35
Joined: 05. May 2011 22:41

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby Sharley » 12. May 2011 06:13

Steffen, thanks for the new Tomcat and the Shell additions, both useful for those of us who used XAMPP 1.7.3 and it's Carsten Wiedmann compiled XCP (License issue mentioned by Oswald).


Tomcat may throw an error in XAMPP 1.7.4 (or other older versions) stating that:
XCP notify text box wrote:2:55:31 PM [mysql] Possible problem detected: file "C:\xampp\tomcat\bin\tomcat7.exe" not found - run this program from your XAMPP root directory!
Not sure why it shows [mysql] instead of [tomcat] in the error message???

Reason is that tomcat7.exe is not included in 1.7.4 or earlier versions but rather tomcat6.exe is - in 1.7.5 beta versions it has tomcat7 in the bin folder so no issues reported there.

I simply renamed tomcat6.exe to tomcat7.exe so I could move forward testing tomcat.

Next issue for readers, you will definitely need to download and install Java SE 6 JDK (which includes the JRE) from here (Click on the Download JDK button):
http://www.oracle.com/technetwork/java/ ... index.html
as the JRE only that most people use will not be recognised and so you will get even more error consoles pop up in your face when you try and Start Tomcat. ;)

I will post my tomcat test results for XAMPP 1.7.4 on X86 (32bit) XP SP3 when download and installation of the X86 (32 bit) JDK completes.


Steffen, is showing all the Windows processes an intentional design feature?
If so would it be possible to add a configuration to show (ON) or not to show (OFF) all the Windows running processes, as I doubt it would be useful for all XAMPP users to have it on by default, even confusing for some perhaps.

Cheers.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby dmsclz » 12. May 2011 11:48

Thanks for your bugreport, Sharley!

- The module name of tomcat was wrong, I fixed it. Damn copy/paste :)
- Now it is checked for tomcat7.exe OR tomcat6.exe

Yes needing the JDK sucks a little bit, but my program is just using that start_catalina.bat

Yes, it is intentional to show all processes. I thought about filtering out windows processes in the netstat window.
But the reason for this function is to find out, which program is blocking a port. And if some processes / open sockets are filtered out this may be very confusing.

New version up "May 12th 2011 - build #1"
http://arloh.de/xampp/xampp_control3.0.2.zip

Best regards,
Steffen Strüber
dmsclz
 
Posts: 35
Joined: 05. May 2011 22:41

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby Sharley » 13. May 2011 03:07

Thanks for getting back to this thread, it really does help many readers who do not speak German and sorry for this long winded post but I hope it helps the troubleshooting process. :)

dmsclz wrote:Yes, it is intentional to show all processes. I thought about filtering out windows processes in the netstat window.
Actually Steffen, I was not referring to the netstat window but the scrolling log window in XCP3 itself.

It may be associated with the debug level set to 1 - but with the debug = 0 setting it should surely override any debug level settings ?? and is why in 1.7.5b2, using the default ini file it does not show the processes.

On double checking, if you turn off 'Show debug stuff' in the Config settings it does not automatically remove the debug level setting 'Very many details' if it remains set, even though it removes the drop menu box from view - simply revert to 'Details' before removing the tick in the Show debug stuff check box will fix it or change the settings manually in the ini file.

This from the scrolling XCP3 log window - note the reproduced processes I mentioned above but they do not appear in 1.7.5b2 using default debug level=0 and debug=0
Code: Select all
11:07:18 AM  [main]    Initializing main
11:07:18 AM  [main]    Windows version: 5.1 (2600)
11:07:18 AM  [main]    Running as admin - good!
11:07:18 AM  [main]    Working with basedir: "g:\xampp174\"
11:07:18 AM  [processes]    Creating PID-entry 0: g:\xampp174\xampp_control3.exe
11:07:18 AM  [processes]    Creating PID-entry 4: system
11:07:18 AM  [processes]    Creating PID-entry 468: smss.exe
11:07:18 AM  [processes]    Creating PID-entry 536: csrss.exe
11:07:18 AM  [processes]    Creating PID-entry 560: winlogon.exe
11:07:18 AM  [processes]    Creating PID-entry 604: services.exe
11:07:18 AM  [processes]    Creating PID-entry 616: lsass.exe
11:07:18 AM  [processes]    Creating PID-entry 796: svchost.exe
11:07:18 AM  [processes]    Creating PID-entry 876: svchost.exe
11:07:18 AM  [processes]    Creating PID-entry 916: svchost.exe
11:07:18 AM  [processes]    Creating PID-entry 956: svchost.exe
11:07:18 AM  [processes]    Creating PID-entry 1216: c:\windows\explorer.exe
11:07:18 AM  [processes]    Creating PID-entry 1312: spoolsv.exe
11:07:18 AM  [processes]    Creating PID-entry 1432: smc.exe
11:07:18 AM  [processes]    Creating PID-entry 1488: svchost.exe
11:07:18 AM  [processes]    Creating PID-entry 1900: alg.exe
11:07:18 AM  [processes]    Creating PID-entry 2584: e:\program files\filezilla\filezilla.exe
11:07:18 AM  [processes]    Creating PID-entry 520: g:\xampp174\xampp_control3.exe
11:07:18 AM  [main]    Initializing moduls
11:07:18 AM  [main]    Starting check-timer
11:07:33 AM  [apache]    Starting apache app...
11:07:33 AM  [processes]    Creating PID-entry 2352: g:\xampp174\apache\bin\httpd.exe
11:07:33 AM  [apache]    Status change detected: running
11:07:34 AM  [processes]    Creating PID-entry 2892: g:\xampp174\apache\bin\httpd.exe
11:07:39 AM  [mysql]    Starting mysql app...
11:07:40 AM  [processes]    Creating PID-entry 1996: g:\xampp174\mysql\bin\mysqld.exe
11:07:40 AM  [mysql]    Status change detected: running
11:08:13 AM  [tomcat]    Starting tomcat app...
11:08:13 AM  [processes]    Creating PID-entry 3552: c:\windows\system32\cmd.exe
11:08:14 AM  [processes]    Creating PID-entry 3308: g:\xampp174\tomcat\jre\bin\javaw.exe
From the same window with both debug level and debug set to zero
Code: Select all
11:25:39 AM  [main]    Initializing main
11:25:39 AM  [main]    Windows version: 5.1 (2600)
11:25:39 AM  [main]    Running as admin - good!
11:25:39 AM  [main]    Working with basedir: "g:\xampp174\"
11:25:39 AM  [main]    Initializing moduls
11:25:39 AM  [main]    Starting check-timer
11:37:32 AM  [apache]    Starting apache app...
11:37:33 AM  [apache]    Status change detected: running
11:37:38 AM  [mysql]    Starting mysql app...
11:37:39 AM  [mysql]    Status change detected: running
11:37:44 AM  [tomcat]    Starting tomcat app...

As you can see Apache and MySQL have started but Tomcat has not started, the command console window just hangs at this point and has to be closed manually
Code: Select all
[XAMPP]: Searching JDK HOME with reg query ...

! REG.EXE VERSION 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit
    CurrentVersion      REG_SZ  1.6

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.6
    JavaHome    REG_SZ  E:\Program Files\Java\jdk1.6.0_25
    MicroVersion        REG_SZ  0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.6.0_25
    JavaHome    REG_SZ  E:\Program Files\Java\jdk1.6.0_25
    MicroVersion        REG_SZ  0

[XAMPP]: Seems fine!
[XAMPP]: Using E:\Program Files\Java\jdk1.6.0_25

g:\xampp174\tomcat
Using CATALINA_BASE:   G:\xampp174\tomcat
Using CATALINA_HOME:   G:\xampp174\tomcat
Using CATALINA_TMPDIR: G:\xampp174\tomcat\temp
Using JRE_HOME:        G:\xampp174\tomcat\jre

Starts fine and runs well in 1.7.5b2 with no issues I could find at this point in time.

Anything else you would like me to test in 1.7.4 or earlier versions, go for it - but better if you download 1.7.4 and try it out yourself (if you have the time ;) ) as I am not at all thrilled with this poor quality release, see my posts here:
viewtopic.php?f=16&t=44327
There are many 1.7.4 users out there who, I am sure, would like to use XCP3 instead of the very old version supplied with the release, whilst they wait for 1.7.5 to go stable.


Both in 1.7.4 and in 1.7.5b2 there are numerous intermittent Access violation pop up windows on starting and stopping various components including starting XCP3, I will post the details from the window which seems are the same message, sometime 4 or 5 at once - no set pattern to pin down the cause but you may know what it might be?
Code: Select all
Access violation at address 004CEDDB in module 'xampp_control3.exe. Lesen of address 00000004.


Here is the ini file from 1.7.4 XCP3 - see comments above about debug level - the 1.7.5b2 XCP3 ini file remains the default settings
Code: Select all
[Common]
Editor=E:\Program Files\NoteTab Pro\NotePro.exe
Browser=C:\Program Files\SeaMonkey\seamonkey.exe
Debug=0
Debuglevel=1
CheckDefaultPorts=0
Language=en

[Autostart]
Apache=0
MySQL=0
FileZilla=0
Mercury=0
Tomcat=0

[UserConfigs]
Apache=
MySQL=
FileZilla=
Mercury=
Tomcat=

[UserLogs]
Apache=
MySQL=
FileZilla=
Mercury=
Tomcat=


Once again thanks Steffen, the XCP3 is a vast improvement on any previous versions and is getting much closer to a true control panel for XAMPP. :D

Best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby dmsclz » 13. May 2011 17:02

Hi Sharley,

thank again for testing & finding bugs :)

Yes, that Debug-Detail thing is a real bug. It is fixed now. Thanks for giving me the bug with the exact reason for it!

You have written about an access violation. I uploaded a new version with much more debug stuff inside, it will give you (me) better informations about the error.

If there is a problem in starting any external programs, please turn on debug mode (so you see what the program is trying to start). Than try to start that program direct or say me, how you would start it. I need informations about Operating system, especially about 32/64 bit.
Maybe you give me whole log-output - there is everything in like all version informations (all BUT 32/64)

In the new version xampp-CC is trying to guess xampp version (by parsing readme_de.txt) :)

New version up "May 13th 2011 - build #1"
http://arloh.de/xampp/xampp_control3.0.2.zip

Best regards,
Steffen Strueber
dmsclz
 
Posts: 35
Joined: 05. May 2011 22:41

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby Sharley » 14. May 2011 03:40

Hello Steffen,

32bit Windows XP SP3 Administrator user.

I did a fresh download of the 1.7.4 Zip version for these test, so very much an 'out of the box' installation and low and behold Tomcat started no problem but with exceptions similar to Apache and MySQL.

Selected to 'Show debug stuff' then 'Very much detail' which did not seem to make any difference to the log entries if selected or not - but the processes do not appear if selected or not.

There are also exception when ever focus is lost and then regained of the XCP window, see below.

Here is the log split into parts after clicking on the Start button of the 5 components in order and the Tomcat Command Console Window that remains open after Tomcat starts - have to manually close it which also Stops Tomcat, also the component Stop logs.

Best viewed full screen to help prevent word wrap.
11:42:29 AM [main] Windows version: 5.1 (build 2600) - Service Pack 3
11:42:29 AM [main] Xampp version: 1.7.4
11:42:29 AM [main] Control center version: 3.0.2 [ Compiled: May 13th 2011 - build #1 ]
11:42:29 AM [main] Running as admin - good!
11:42:29 AM [main] Working with basedir: "g:\xampp174\"
11:42:29 AM [main] Initializing moduls
11:42:29 AM [main] Starting check-timer

11:43:01 AM [apache] Starting apache app...
11:43:01 AM [apache] Executing "g:\xampp174\apache\bin\httpd.exe"
11:43:01 AM [EXCEPTION] Access violation at address 004EA8DB in module 'xampp_control3.exe'. Lesen of address 00000004
11:43:01 AM [EXCEPTION] [004EA8DB]{xampp_control3.exe} uProcesses.tProcesses.Update (Line 117, "uProcesses.pas" + 41) + $23
11:43:01 AM [EXCEPTION] [004EF63A]{xampp_control3.exe} uMain.TfMain.UpdateStatusAll (Line 873, "uMain.pas" + 1) + $7
11:43:01 AM [EXCEPTION] [0042C858]{xampp_control3.exe} Classes.StdWndProc (Line 12703, "Classes.pas" + 8) + $0

11:43:02 AM [apache] Status change detected: running


11:43:27 AM [mysql] Starting mysql app...
11:43:27 AM [mysql] Executing "g:\xampp174\mysql\bin\mysqld.exe --defaults-file=g:\xampp174\mysql\bin\my.ini --standalone"
11:43:27 AM [EXCEPTION] Access violation at address 004EA8DB in module 'xampp_control3.exe'. Lesen of address 00000004
11:43:27 AM [EXCEPTION] [004EA8DB]{xampp_control3.exe} uProcesses.tProcesses.Update (Line 117, "uProcesses.pas" + 41) + $23
11:43:27 AM [EXCEPTION] [004EF63A]{xampp_control3.exe} uMain.TfMain.UpdateStatusAll (Line 873, "uMain.pas" + 1) + $7
11:43:27 AM [EXCEPTION] [0042C858]{xampp_control3.exe} Classes.StdWndProc (Line 12703, "Classes.pas" + 8) + $0

11:43:27 AM [mysql] Status change detected: running


11:44:03 AM [filezilla] Installing service...
11:44:03 AM [filezilla] Executing "g:\xampp174\filezillaftp\filezillaserver.exe"
11:44:16 AM [filezilla] Status change detected: running
11:44:23 AM [filezilla] Return code: 0
11:44:23 AM [filezilla] Checking for service (name="FileZilla Server"): Application
11:44:23 AM [filezilla] Service was NOT (un)installed!
11:44:23 AM [filezilla] On windows security box you !!!MUST UNCHECK!!! that "yes, cut service's balls" checkbox!!!
(Nice terminology (not) for Filezilla Service to remove the tick in the Protect my computer and data from unauthorized program activity check box, also annoying when there is only one user for a PC who is an administrator anyway but not too annoying as it would not be used much once a service is installed).
11:44:23 AM [filezilla] Status change detected: stopped

11:45:00 AM [filezilla] Installing service...
11:45:00 AM [filezilla] Executing "g:\xampp174\filezillaftp\filezillaserver.exe"
11:45:05 AM [filezilla] Status change detected: running
11:45:15 AM [filezilla] Return code: 0
11:45:15 AM [filezilla] Checking for service (name="FileZilla Server"): Service


11:47:27 AM [mercury] Starting Mercury app...
11:47:27 AM [mercury] Executing "g:\xampp174\MercuryMail\mercury.exe"
11:47:27 AM [mercury] Starting Mercury...
11:47:27 AM [mercury] Status change detected: running


11:48:01 AM [tomcat] Starting tomcat app...
11:48:01 AM [tomcat] Executing "cmd" "/c g:\xampp174\catalina_start.bat"
11:48:01 AM [EXCEPTION] Access violation at address 004EA8DB in module 'xampp_control3.exe'. Lesen of address 00000004
11:48:01 AM [EXCEPTION] [004EA8DB]{xampp_control3.exe} uProcesses.tProcesses.Update (Line 117, "uProcesses.pas" + 41) + $23
11:48:01 AM [EXCEPTION] [004EF63A]{xampp_control3.exe} uMain.TfMain.UpdateStatusAll (Line 873, "uMain.pas" + 1) + $7
11:48:01 AM [EXCEPTION] [0042C858]{xampp_control3.exe} Classes.StdWndProc (Line 12703, "Classes.pas" + 8) + $0
11:48:03 AM [EXCEPTION] Access violation at address 004EA8DB in module 'xampp_control3.exe'. Lesen of address 00000004
11:48:04 AM [EXCEPTION] [004EA8DB]{xampp_control3.exe} uProcesses.tProcesses.Update (Line 117, "uProcesses.pas" + 41) + $23
11:48:04 AM [EXCEPTION] [004EF63A]{xampp_control3.exe} uMain.TfMain.UpdateStatusAll (Line 873, "uMain.pas" + 1) + $7
11:48:04 AM [EXCEPTION] [0042C858]{xampp_control3.exe} Classes.StdWndProc (Line 12703, "Classes.pas" + 8) + $0
11:48:04 AM [EXCEPTION] Access violation at address 004EA8DB in module 'xampp_control3.exe'. Lesen of address 00000004
11:48:04 AM [EXCEPTION] [004EA8DB]{xampp_control3.exe} uProcesses.tProcesses.Update (Line 117, "uProcesses.pas" + 41) + $23
11:48:04 AM [EXCEPTION] [004EF63A]{xampp_control3.exe} uMain.TfMain.UpdateStatusAll (Line 873, "uMain.pas" + 1) + $7
11:48:04 AM [EXCEPTION] [0042C858]{xampp_control3.exe} Classes.StdWndProc (Line 12703, "Classes.pas" + 8) + $0
11:48:04 AM [EXCEPTION] Access violation at address 004EA8DB in module 'xampp_control3.exe'. Lesen of address 00000004
11:48:04 AM [EXCEPTION] [004EA8DB]{xampp_control3.exe} uProcesses.tProcesses.Update (Line 117, "uProcesses.pas" + 41) + $23
11:48:04 AM [EXCEPTION] [004EF63A]{xampp_control3.exe} uMain.TfMain.UpdateStatusAll (Line 873, "uMain.pas" + 1) + $7
11:48:04 AM [EXCEPTION] [0042C858]{xampp_control3.exe} Classes.StdWndProc (Line 12703, "Classes.pas" + 8) + $0

11:48:12 AM [tomcat] Status change detected: running


Command console for Tomcat

[XAMPP]: Searching JDK HOME with reg query ...

! REG.EXE VERSION 3.0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit
CurrentVersion REG_SZ 1.6

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.6
JavaHome REG_SZ E:\Program Files\Java\jdk1.6.0_25
MicroVersion REG_SZ 0

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Development Kit\1.6.0_25
JavaHome REG_SZ E:\Program Files\Java\jdk1.6.0_25
MicroVersion REG_SZ 0

[XAMPP]: Seems fine!
[XAMPP]: Using E:\Program Files\Java\jdk1.6.0_25

g:\xampp174\tomcat
Using CATALINA_BASE: "g:\xampp174\tomcat"
Using CATALINA_HOME: "g:\xampp174\tomcat"
Using CATALINA_TMPDIR: "g:\xampp174\tomcat\temp"
Using JRE_HOME: "E:\Program Files\Java\jdk1.6.0_25"
Using CLASSPATH: "g:\xampp174\tomcat\bin\bootstrap.jar;g:\xampp174\tomcat\bin\tomcat-juli.jar"

14/05/2011 11:48:07 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production envi
ronments was not found on the java.library.path: E:\Program Files\Java\jdk1.6.0_25\bin;.;C:\WINDOWS\
Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32;C:\WINDOWS
14/05/2011 11:48:09 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
14/05/2011 11:48:09 AM org.apache.coyote.ajp.AjpProtocol init
INFO: Initializing Coyote AJP/1.3 on ajp-8009
14/05/2011 11:48:09 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 2861 ms
14/05/2011 11:48:09 AM org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
14/05/2011 11:48:09 AM org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.5
14/05/2011 11:48:09 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory docs
14/05/2011 11:48:10 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory examples
14/05/2011 11:48:11 AM org.apache.catalina.startup.TaglibUriRule body
INFO: TLD skipped. URI: /SimpleTagLibrary is already defined
14/05/2011 11:48:11 AM org.apache.catalina.startup.TaglibUriRule body
INFO: TLD skipped. URI: http://tomcat.apache.org/example-taglib is already defined
14/05/2011 11:48:11 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory host-manager
14/05/2011 11:48:12 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory manager
14/05/2011 11:48:12 AM org.apache.catalina.startup.HostConfig deployDirectory
INFO: Deploying web application directory ROOT
14/05/2011 11:48:12 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
14/05/2011 11:48:12 AM org.apache.coyote.ajp.AjpProtocol start
INFO: Starting Coyote AJP/1.3 on ajp-8009
14/05/2011 11:48:12 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 3118 ms

After closing the above console window
11:48:12 AM [tomcat] Status change detected: running
11:53:53 AM [tomcat] Status change detected: stopped
11:53:54 AM [tomcat] Status change detected: running
11:53:56 AM [tomcat] Status change detected: stopped


When ever the XCP loses focus, say I click on my browser window, then I gain focus of XCP by clicking on a blank part of the window, these exceptions occur:

11:54:27 AM [EXCEPTION] Gleitkommadivision durch Null
11:54:27 AM [EXCEPTION] [004EE6ED]{xampp_control3.exe} uMain.TfMain.FormClick (Line 716, "uMain.pas" + 2) + $8
11:54:27 AM [EXCEPTION] [004826FF]{xampp_control3.exe} Controls.TWinControl.WndProc (Line 9336, "Controls.pas" + 136) + $6
11:54:27 AM [EXCEPTION] [00495EBC]{xampp_control3.exe} Forms.TCustomForm.WndProc (Line 3901, "Forms.pas" + 191) + $5
11:54:27 AM [EXCEPTION] [00481E18]{xampp_control3.exe} Controls.TWinControl.MainWndProc (Line 9065, "Controls.pas" + 3) + $6
11:54:27 AM [EXCEPTION] [0042C858]{xampp_control3.exe} Classes.StdWndProc (Line 12703, "Classes.pas" + 8) + $0

11:55:58 AM [EXCEPTION] Gleitkommadivision durch Null
11:55:58 AM [EXCEPTION] [004EE6ED]{xampp_control3.exe} uMain.TfMain.FormClick (Line 716, "uMain.pas" + 2) + $8
11:55:58 AM [EXCEPTION] [004826FF]{xampp_control3.exe} Controls.TWinControl.WndProc (Line 9336, "Controls.pas" + 136) + $6
11:55:58 AM [EXCEPTION] [00495EBC]{xampp_control3.exe} Forms.TCustomForm.WndProc (Line 3901, "Forms.pas" + 191) + $5
11:55:58 AM [EXCEPTION] [00481E18]{xampp_control3.exe} Controls.TWinControl.MainWndProc (Line 9065, "Controls.pas" + 3) + $6
11:55:58 AM [EXCEPTION] [0042C858]{xampp_control3.exe} Classes.StdWndProc (Line 12703, "Classes.pas" + 8) + $0

11:56:16 AM [EXCEPTION] Gleitkommadivision durch Null
11:56:16 AM [EXCEPTION] [004EE6ED]{xampp_control3.exe} uMain.TfMain.FormClick (Line 716, "uMain.pas" + 2) + $8
11:56:16 AM [EXCEPTION] [004826FF]{xampp_control3.exe} Controls.TWinControl.WndProc (Line 9336, "Controls.pas" + 136) + $6
11:56:16 AM [EXCEPTION] [00495EBC]{xampp_control3.exe} Forms.TCustomForm.WndProc (Line 3901, "Forms.pas" + 191) + $5
11:56:16 AM [EXCEPTION] [00481E18]{xampp_control3.exe} Controls.TWinControl.MainWndProc (Line 9065, "Controls.pas" + 3) + $6
11:56:16 AM [EXCEPTION] [0042C858]{xampp_control3.exe} Classes.StdWndProc (Line 12703, "Classes.pas" + 8) + $0

11:58:12 AM [EXCEPTION] Gleitkommadivision durch Null
11:58:12 AM [EXCEPTION] [004EE6ED]{xampp_control3.exe} uMain.TfMain.FormClick (Line 716, "uMain.pas" + 2) + $8
11:58:12 AM [EXCEPTION] [004826FF]{xampp_control3.exe} Controls.TWinControl.WndProc (Line 9336, "Controls.pas" + 136) + $6
11:58:12 AM [EXCEPTION] [00495EBC]{xampp_control3.exe} Forms.TCustomForm.WndProc (Line 3901, "Forms.pas" + 191) + $5
11:58:12 AM [EXCEPTION] [00481E18]{xampp_control3.exe} Controls.TWinControl.MainWndProc (Line 9065, "Controls.pas" + 3) + $6
11:58:12 AM [EXCEPTION] [0042C858]{xampp_control3.exe} Classes.StdWndProc (Line 12703, "Classes.pas" + 8) + $0

Check the time differences for the number of times I lost and then gained focus for testing this issue.


Stopping log entries:
12:00:27 PM [mercury] Stopping Mercury
12:00:27 PM [mercury] Stopping Mercury
12:00:27 PM [mercury] Executing "g:\xampp174\apache\bin\pv.exe -f -c mercury.exe -q -e"
12:00:28 PM [mercury] Status change detected: stopped
12:00:29 PM [filezilla] Stopping FileZilla service...
12:00:29 PM [filezilla] Executing "net stop "FileZilla Server""
12:00:34 PM [filezilla] Return code: 0
12:00:34 PM [filezilla] Status change detected: stopped
12:00:38 PM [mysql] Stopping mysql (PID: 3452)
12:00:38 PM [mysql] Executing "g:\xampp174\apache\\bin\\pv.exe -f -k -q -i 3452"
12:00:38 PM [mysql] Status change detected: stopped
12:00:48 PM [filezilla] Uninstalling service...
12:00:48 PM [filezilla] Executing "sc" "delete "FileZilla Server""
12:00:51 PM [filezilla] Return code: 0
12:00:51 PM [filezilla] Checking for service (name="FileZilla Server"): Application
12:00:51 PM [filezilla] Service was NOT (un)installed!
12:00:51 PM [filezilla] On windows security box you !!!MUST UNCHECK!!! that "yes, cut service's balls" checkbox!!!
(The above comment appeared even though the check box was not checked)
12:00:58 PM [apache] Stopping apache (PID: 3664)
12:00:58 PM [apache] Executing "g:\xampp174\apache\\bin\\pv.exe -f -k -q -i 3664"
12:00:58 PM [apache] Stopping apache (PID: 3868)
12:00:58 PM [apache] Executing "g:\xampp174\apache\\bin\\pv.exe -f -k -q -i 3868"
12:00:59 PM [apache] Status change detected: stopped


BTW, where are you storing the log file when writing entries?
Are you writing any registry entries at all?
If so how will this affect a portable device installation?
(I have not tested a USB installation yet).

Steffen, I hope all this helps.

Best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby dmsclz » 14. May 2011 11:21

Thank you once again :)

Sorry I forgot to remove my test-exception if you click on that main window. I needed it to test that new debug-output on exceptions.

Registry is NOT used, all configuration is written to xampp_control.ini (created with default values if it does not exist). Registry was used for configuration in very early version of this program - but not anymore.

The "Is-Running" detection for tomcat is very bad, I just scan for any process "java.exe" and check if it has opened 3 TCP-ports. I have no better idea - I didnt find a PID-file or something for unning tomcat. maybe this is the reason for the changing is-Running-messages.


New version is up @ http://arloh.de/xampp/xampp_control3.0.2.zip


Changes ("May 14th 2011 - build #1")

- removed my "test-exception" @ OnClick-Window
- fixed exception at new processed detected
- changed text: One possible reason for failure: On windows security box you !!!MUST UNCHECK!!! that "Protect my computer and data from unauthorized program activity" checkbox!!!
- Logfile is written (on application close) to <Xampp-dir>\xampp_control3.log
- Changed some \\ to \ in pathnames (works but not beatyful)
- Added configuration option: "Tomcat output window visible", checked by default



Best regards,
Steffen Strueber
dmsclz
 
Posts: 35
Joined: 05. May 2011 22:41

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby Sharley » 14. May 2011 12:27

Thanks again Steffen, all systems go except when Stopping FileZilla Service - it still shows that message when removing the tick in the Service check box.

Here is the latest log file
9:09:45 PM [main] Initializing main
9:09:45 PM [main] Windows version: 5.1 (build 2600) - Service Pack 3
9:09:45 PM [main] Xampp version: 1.7.4
9:09:45 PM [main] Control center version: 3.0.2 [ Compiled: May 13th 2011 - build #1 ]
9:09:45 PM [main] Running as admin - good!
9:09:45 PM [main] Working with basedir: "g:\xampp174\"
9:09:45 PM [main] Initializing moduls
9:09:45 PM [main] Starting check-timer

Starting

9:10:18 PM [apache] Starting apache app...
9:10:18 PM [apache] Executing "g:\xampp174\apache\bin\httpd.exe"
9:10:21 PM [apache] Status change detected: running

9:10:29 PM [mysql] Starting mysql app...
9:10:29 PM [mysql] Executing "g:\xampp174\mysql\bin\mysqld.exe --defaults-file=g:\xampp174\mysql\bin\my.ini --standalone"
9:10:30 PM [mysql] Status change detected: running

9:10:43 PM [filezilla] Installing service...
9:10:43 PM [filezilla] Executing "g:\xampp174\filezillaftp\filezillaserver.exe"
9:10:50 PM [filezilla] Status change detected: running
9:11:01 PM [filezilla] Return code: 0
9:11:01 PM [filezilla] Checking for service (name="FileZilla Server")

9:11:06 PM [mercury] Starting Mercury app...
9:11:06 PM [mercury] Executing "g:\xampp174\MercuryMail\mercury.exe"
9:11:06 PM [mercury] Starting Mercury...
9:11:07 PM [mercury] Status change detected: running

9:11:16 PM [tomcat] Starting tomcat app...
9:11:16 PM [tomcat] Executing "cmd" "/c g:\xampp174\catalina_start.bat"
9:11:26 PM [tomcat] Status change detected: running

Stopping

9:11:57 PM [tomcat] Stopping
9:11:57 PM [tomcat] Executing "cmd" "/c g:\xampp174\catalina_stop.bat"
9:11:58 PM [tomcat] Status change detected: stopped

9:12:03 PM [mercury] Stopping Mercury
9:12:03 PM [mercury] Stopping Mercury
9:12:03 PM [mercury] Executing "g:\xampp174\apache\bin\pv.exe -f -c mercury.exe -q -e"
9:12:04 PM [mercury] Status change detected: stopped

9:12:10 PM [filezilla] Stopping FileZilla service...
9:12:10 PM [filezilla] Executing "net stop "FileZilla Server""
9:12:13 PM [filezilla] Return code: 0
9:12:14 PM [filezilla] Status change detected: stopped
9:12:28 PM [filezilla] Uninstalling service...
9:12:28 PM [filezilla] Executing "sc" "delete "FileZilla Server""
9:12:32 PM [filezilla] Return code: 0
9:12:32 PM [filezilla] Checking for service (name="FileZilla Server")
9:12:32 PM [filezilla] Service was NOT (un)installed!
9:12:32 PM [filezilla] One possible reason for failure: On windows security box you !!!MUST UNCHECK!!! that "Protect my computer and data from unauthorized program activity" checkbox!!!

9:12:51 PM [mysql] Stopping mysql (PID: 3332)
9:12:51 PM [mysql] Executing "g:\xampp174\apache\bin\pv.exe -f -k -q -i 3332"
9:12:51 PM [mysql] Status change detected: stopped

9:12:54 PM [apache] Stopping apache (PID: 3328)
9:12:54 PM [apache] Executing "g:\xampp174\apache\bin\pv.exe -f -k -q -i 3328"
9:12:54 PM [apache] Stopping apache (PID: 2384)
9:12:54 PM [apache] Executing "g:\xampp174\apache\bin\pv.exe -f -k -q -i 2384"
9:12:54 PM [apache] Status change detected: stopped
I get the windows security box and I remove the tick when I click on FileZilla Stop and before having to manually remove the tick in the FileZilla Service check box.


Just a small point, if the log file is appended with new data then at some point it will get huge and may go unnoticed - so perhaps another configuration choice to append or to overwrite the log file and a delete log button would help especially when the XCP is loaded many times a day for some of us. ;)

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby dmsclz » 14. May 2011 14:42

Hi again,

oops, nwo i found the problem about that filezille service error-message.
It is fixed now, get it on the old link. It is still named May 14th 2011 - build #1 ....

Shortening logs or overwrite/append maybe an option later.. I dont think it will groß more than 1 MB too quick?! :)

Best regards
Steffen
dmsclz
 
Posts: 35
Joined: 05. May 2011 22:41

Re: *** New XAMPP CONTROL PANEL Version 3 ***

Postby Sharley » 15. May 2011 05:47

Steffen, hello again.
Everything checks out good on a USB except for Tomcat - for other members reading this topic the XAMPP Control Panel version 3 is worth downloading and using on an everyday basis and if you also spot a bug during normal operations then please feel free to post it here so Steffen can take a look at it.


Testing Tomcat.

Shortly after Tomcat starts (green running) it stops and then starts and stops intermittently but only in the XCP as tomcat remains running.

You would need to move the XCP window so you can observe the Tomcat intermittent changes

I was able to reproduce this in 1.7.4 on a clean install on a new USB and on the fresh 1.7.4 install on the fixed drive.

The XAMPP Status page shows Tomcat Activated in green after starting and during these start stop cycles in the XCP.

Here is the log from the USB:
1:22:04 PM [tomcat] Starting tomcat app...
1:22:18 PM [tomcat] Status change detected: running
1:22:39 PM [tomcat] Status change detected: stopped
1:23:02 PM [tomcat] Status change detected: running
1:23:05 PM [tomcat] Status change detected: stopped
1:23:32 PM [tomcat] Status change detected: running
1:24:58 PM [tomcat] Status change detected: stopped
Seems to occur when the various menu items in the XAMPP Welcome Page are activated, as do the other menu items on the Tomcat demo page also when the Admin button in XCP is pressed - if you wait a moment it will show green running again.

When a click on the 'Force stop' button (the only way from the XCP during the intermittent start stop cycles) it momentarily shows green running and then stops Tomcat, also the command console is closed - log:
1:32:28 PM [tomcat] Stopping
1:32:33 PM [tomcat] Status change detected: running
1:32:35 PM [tomcat] Status change detected: stopped



Slightly different result from the fixed drive but still stops and starts intermittently - but has no effect on Tomcat itself only the visuals in the XCP.

Here is the log from the fixed drive:
1:39:11 PM [tomcat] Starting tomcat app...
1:39:19 PM [tomcat] Status change detected: running
1:40:18 PM [tomcat] Status change detected: stopped
1:40:19 PM [tomcat] Status change detected: running
1:40:34 PM [tomcat] Status change detected: stopped
1:41:02 PM [tomcat] Status change detected: running
1:42:56 PM [tomcat] Status change detected: stopped
1:43:32 PM [tomcat] Status change detected: running
1:46:34 PM [tomcat] Status change detected: stopped


After a 'Forced stop' :
1:47:28 PM [tomcat] Stopping
Note no status changes - but tomcat is stopped at this point and the command console is closed.

EDIT - just checked 1.7.5b and it has the same Tomcat Stop/Start behavior and further testing shows that it is the same in all testings of XAMPP installations using the last XCP3 compile.


"Weird or what" :)

Hopefully my last bug report.

Best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests