port 80 issues after previous installation [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

port 80 issues after previous installation [SOLVED]

Postby BassinJason » 09. May 2011 07:34

I have only recently began coding in php and was using xampp to run apache for a few a months.. Recently the apache stopped running.. I did not check the log file as I was not aware of it's existence at the time. I have uninstalled and reinstalled a few times and kept coming up with either port 80 or 443 being already in use. I ran currports to check which it was and found 3 open port 80s. The weird thing is that all three open port 80s had the local port name of http. I was able to close one but am unable to close the other two. These two list their state as listening, not all sure what that means. Naturally, trying to reinstall again produced the same error message. So now I desperately turning towards the community for a little assistance. Any all advice is appreciated... ps I do not use skype and I do not believe any other application is causing the issue. Very confused.. Please Help.
BassinJason
 
Posts: 3
Joined: 09. May 2011 07:22

Re: port 80 issues after previous succesful installation

Postby Sharley » 09. May 2011 07:45

How exactly did you uninstall XAMPP as it would seem that perhaps the Apache Windows service may not have been uninstalled first.

It would be advisable to uninstall correctly and do a fresh install by following this procedure.

Start the XAMPP Control Panel.
Make sure there are no ticks in any of the Svc check boxes or the service module column in XCPv3.
Stop all XAMPP components.
Press 'Exit' or 'Quit' in the XAMPP Control Panel.
Delete the xampp folder completely after backing up your own files.
Reboot as it often helps clean things up.

Try and install again using my preferred method instructions below for the ZIP or 7zip version.

Download the ZIP or 7zip version of XAMPP.
Extract (drag) the xampp folder to the C:\ drive or the root of any drive or partition like D:\, E:\, etc.
Run the C:\xampp\setup_xampp.bat file (this sets the correct paths for you).
Open the XAMPP Control Panel version 3 (xampp-control-3-beta.exe) found in the xampp folder and start Apache and MySQL (do not tick any service module boxes)
When both Apache and MySQL are running type http://localhost/ select your language and exercise all the demos in the left menu frame.

You should now be able to proceed and enjoy XAMPP. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: port 80 issues after previous succesful installation

Postby BassinJason » 09. May 2011 10:44

I was initially using the installer file for installation and simply uninstalling it as an application. After attempting the process you suggested, which I did prefer, I was able to start apache but within a second or two it quit on me.. As far as I can tell it has to be due to the many port 80s that are open. I am unable to close them using currports. Could this problem be a virus of some sort. I have checked for viruses but didn't find any, but you never really know with viruses. Why are there more than one port 80s open? There are 2 open as port 80 with system as the process name, 4 as the process ID, TCP protocol, http as the local port name. One has the local and remote address as 0.0.0.0 and the other one simply has :: as the local and remote address. I don't know anything about this port stuff but as far as I can tell the ports are probably the only problem. What should I do? Help please.
BassinJason
 
Posts: 3
Joined: 09. May 2011 07:22

Re: port 80 issues after previous succesful installation

Postby Sharley » 09. May 2011 11:32

There is something using port 80 and you will not be able to move forward until you locate the culprit and disable it - 'system' may well be IIS, see below.


Read the \xampp\apache\logs\error.log file just after Apache fails to start.
(If Apache has not yet been able to start after installation then there may not be any entries in the error.log file).


You don't use Skype but are you running any other programs that may have access to the Internet, also is World Wide Publishing AKA IIS the Windows default web server disabled?

If not disabled go to the link in this post:
viewtopic.php?p=169028#p169028
Or try this:
To disable IIS go to
Start>Control Panel>Programs and Features
on the leftmost side you will find an option
Turn Windows features on or off
click on it and uncheck
Internet Information Services
click OK
and then restart your computer.


Make sure that you have temporarily disabled your firewall and ZoneAlarm etc and try again to start Apache.


Also you could try this to remove any Sticking Windows Apache services that may be left in the registry:
Click Exit the XAMPP Control Panel.

Next open a command prompt like so
Click start
Click on Run...
Type: cmd.exe
Click OK

To remove old or sticking Apache services.
Type:
sc delete apache2.2
Click OK

Note.
If there are no Apache services installed in the registry then you should see:
"The specified service does not exist as an installed service."


Close the command console.

If the sc command found and deleted the service then start the XAMPP Control Panel again and try and start Apache.


Let me know if any of the above helped as with this issue I am as much in the dark as you and can only suggest some things to try - you do keep on top of your virus checking routine?.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: port 80 issues after previous succesful installation

Postby hehfest » 12. May 2011 07:14

I know for a fact that apache will not work if your skype application is running. I have skype and must close the app out. Not sure if this is the problem or not.
hehfest
 
Posts: 7
Joined: 22. April 2011 23:16

Re: port 80 issues after previous succesful installation

Postby Sharley » 12. May 2011 07:17

You don't need to close Skype out, either start Apache before Skype or configure Skype to use alternative ports.

BTW the OP says in his first post that he does not use Skype.
BassinJason wrote:ps I do not use skype...
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: port 80 issues after previous succesful installation

Postby BassinJason » 13. May 2011 01:06

Thank you Sharley..

It was the IIS that was causing the issues. Running smooth now.
BassinJason
 
Posts: 3
Joined: 09. May 2011 07:22


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 50 guests