Transfer chmodded folders

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Transfer chmodded folders

Postby Repute » 21. January 2004 21:42

I want te transfer al my existing folders to an new linux server. But want to keep all the chmod settings of the folders what is the best way to do that? (The servers are in my private LAN)

How does the new backup system in LAMPP work?

Thnx,

Repute
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby Oswald » 22. January 2004 09:28

Dear Repute! :)

It's very simple:

Step 1

Create the backup by calling

/opt/lampp/lampp backup
or
/opt/lampp/lampp backup secret

Where secret is your MySQL root password.

This command will create the following output:

Code: Select all
# /opt/lampp/lampp backup
Backing up databases...
Backing up configuration, log and htdocs files...
Calculating checksums...
Building final backup file...
Backup finished.
Take care of /opt/lampp/backup/xampp-backup-22-01-04.sh
#


Step 2

The file /opt/lampp/backup/xampp-backup-22-01-04.sh contains your backuped data. Get this file to your new machine.

Step 3

On the new machine you need the same version of XAMPP as on your original/source machine.

Call (as root): sh xampp-backup-22-01-04.sh

You shoud see something like this:

Code: Select all
# sh xampp-backup-22-01-04.sh
Checking integrity of files...
Restoring configuration, log and htdocs files...
Checking versions...
Installed:   XAMPP 1.4.2
Backup from: XAMPP 1.4.2
Restoring MySQL databases...
Restoring MySQL user databases...
Backup complete. Have fun!
You may need to restart XAMPP to complete the restore.
#


That's all. As you can read you may need to restart XAMPP.

It should work perfectly (I tested it many times) but remember it's a beta feature.

Best regards
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Great!!!

Postby Repute » 22. January 2004 11:49

Great wow this peace of software Rules!!! It so simpel...

Your defenitly the best!

Thanks for all your great work!!!

Greets,

Repute
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Cant acces database by backup

Postby Repute » 26. January 2004 15:03

Hhhmm everytime i try to backup with /opt/lampp/lampp backup or /opt/lampp/lampp backup secret
it says:

Can't acces database is Mysql running? etc.

I tried with and without pasword an with MySQL rinnung en not running...

Greets,

Repute
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby Oswald » 26. January 2004 15:05

Dear Repute!

Please call:

/opt/lampp/bin/mysql -uroot -p<yourpassword>

What do you get on your screen?

Regards
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Repute » 26. January 2004 15:13

bash: syntax error near unexpected token `newline'
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby Oswald » 26. January 2004 15:15

WHAT??

Please call only

/opt/lampp/bin/mysql

What do you see now?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Repute » 26. January 2004 15:18

ERROR: 1045 Acces denied for user: root@localhost (using password: NO)
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby Oswald » 26. January 2004 15:23

Okay. Please add now the options to the command:

-uroot -p<your password>

Please replace <your password> with your password. For example: -psecret

And again. What do you get? ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Repute » 26. January 2004 15:24

Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 10 to server version: 4.0.17-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby Oswald » 26. January 2004 15:27

Great. If you still see the mysql> prompt please type quit.

Now call

/opt/lampp/lampp backup secret

Where you have to replace "secret" with your password.

And again, again: what do you see? ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Repute » 26. January 2004 15:33

:? Can't access database. Is MySQL running? Added the MySQL root password to end of command line?
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby Oswald » 26. January 2004 15:37

Okay... step by step...

Next try. Please call:

echo "show databases" | /opt/lampp/bin/mysql -uroot -ppassword
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Repute » 26. January 2004 15:39

Now it shows all the databases in a row
"Keep your face in the sunshine so the shadows fall behind you!"

Repute | http://www.repute.nl
User avatar
Repute
 
Posts: 52
Joined: 12. January 2003 14:33

Postby Oswald » 26. January 2004 15:46

That's very, very strange.

Ok. Now could you please edit /opt/lampp/share/lampp/backup?

At line 27 you find:

d=`echo "show databases" | /opt/lampp/bin/mysql -uroot $passwd 2>/dev/null`

Please remove the 2>/dev/null. It should look like:

d=`echo "show databases" | /opt/lampp/bin/mysql -uroot $passwd`

Save and call again:

/opt/lampp/lampp backup secret

What is happening?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Next

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests